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As we write this guide... 

 

For a long time, engineers in South Korea have favored a particular CAD software called AutoCAD from the 

American company Autodesk. Most CAD training institutions have also focused on teaching how to use 

AutoCAD. 

 

As AutoCAD has been used in nearly every industry—including architecture, civil engineering, plant design, 

facilities, GIS, furniture/interior design, mechanical engineering, mold design, electrical/electronics—the 

auxiliary programs (3rd Party Applications) developed to assist in design have also been based on AutoCAD. 

This trend has resulted in a significant reliance on AutoCAD among designers and reviewers in both private 

enterprises and educational and public institutions. 

 

Despite these challenging conditions, CADian, the only CAD software developed in Korea, was launched 

during the IMF crisis and has now become a 21-year-old young adult. Over the years, various auxiliary 

programs have been released, and CADian has been adopted as an alternative to foreign CAD software by 

almost all major domestic groups, small and medium-sized enterprises, and small businesses. Notably, CADian 

has achieved a larger user base in government and public institutions than AutoCAD. 

 

In recent years, multinational companies have started offering software licenses on a subscription basis, 

charging users periodic fees. This annual rental license system imposes a significant software cost burden on 

not only small businesses in Korea but also mid-sized and large enterprises. As a result, interest in the domestic 

alternative CAD software, CADian, has increased more than ever. 

 

Developed with our own technology and exported to 129 countries, CADian boasts excellent compatibility 

with AutoCAD dwg files, allowing the reuse of existing dwg drawings. It also supports AutoCAD commands 

and shortcuts, eliminating the need for additional learning. This has made CADian the most economical 

alternative CAD solution globally. 

 

In addition to supporting utilities written in AutoLISP, we also offer Dream CAD, which is popular among 

many designers, for free. We promise to continuously develop and add various convenient features needed by 

designers to CADian. 

 

We express our deepest gratitude to all our customers who have used CADian since 1998. We will continue to 



provide frequent updates through online and offline courses. If you have any questions during your learning 

process, please visit the FAQ board on our official website, www.cadian.com, for assistance. 

 

We will continuously improve this guide through a supplementary process if any shortcomings are found. We 

will work tirelessly until the day Korean CAD becomes a globally recognized design authoring tool. Thank 

you. 

 

January 5, 2026 

Paul H. Park, CEO of CADian Inc. 
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1.  Introduction to CADian 2026  
 

CADian (CADian: CAD Enthusiasts) is a Korean CAD (Computer-Aided Design) program developed by 

CADian Inc. This versatile 2D/3D computer-aided design software uses a user-friendly Microsoft Windows 

GUI environment, allowing users to create drawings in various industrial fields, including architecture, 

interior design, civil engineering, structural engineering, electrical engineering, plant design, mechanical 

engineering, and mold design. 

CADian supports the same file format (DWG) as Autodesk, Inc.'s AutoCAD, which is widely used by design 

engineers for project execution. This ensures excellent compatibility between the two programs. Additionally, 

CADian employs the same commands, line types, hatch patterns, and text styles as AutoCAD, making it an 

economical alternative CAD solution that users familiar with AutoCAD can operate without additional 

training. 

 

 Key Features of CADian 

 

· Perfect bidirectional compatibility with all versions of AutoCAD 

· Same command structure and DWG file extension as AutoCAD 

· Support for AutoCAD menus (MNU), dialog boxes (DCL), and scripts (SCR) 

· User design environment consistent with AutoCAD's design environment 

· Support for AutoCAD shortcuts, or the ability to import them 

 

 Applications of CADian 

 

· Architecture and Civil Engineering Design (AEC): Design for architecture and civil · engineering projects. 

· Electrical and Electronic Design (EDA): Design for electrical and electronic projects. 

· Mechanical Design (MDA): Design for mechanical projects. 

· Landscape Design: Design for landscaping projects. 

· Cartography: Map making. 

· Industrial, Interior, and Product Design: Design for industrial, interior, and product applications. 

· Simulation: Simulation for military and scientific fields. 

· Animation: Animation for movies, advertisements, etc. 

· Engineering Drawing: Creation of various engineering drawings. 

 



 Recommended System Requirements for CADian 

 

· CPU: Intel®  and AMD®  processors (Intel i5 or higher recommended) 

  (The Ultra 5 and Ultra 7 CPUs are not recommended.) 

· Memory (RAM): 8GB or more 

· VGA: Resolution of 1024x768 or higher 

· HDD: At least 4GB of free space for installation 

· Input Device: Microsoft mouse-compatible pointing device 

· OS: Microsoft Windows 10, 11 

· Internet: Microsoft Internet Explorer®  11 or Chrome, Firefox, etc. 

· Output Device: Printer or plotter capable of outputting A4, A3 drawing sheets 

 

  



2. Overview of CADian 2026  

 

2-1. Launching CADian 

After installing CADian, double-click the CADian launch icon created on your desktop. 

 

Alternatively, click the Windows Start button, then navigate to and select CADian 2026 ▶ CADian 2026 

Professional x64. (This applies to the Professional version.) 

 

This will launch the CADian 2026 version. 

 

 

 



2-2. CADian Interface Layout 

 

CADian is composed of the following elements. Each part can be freely turned on or off, and some items can 

be repositioned. 

 

Application Button: This button consolidates functions such as opening drawings, saving, and reviewing the 

list of previously worked-on drawings. 

     

Tip: Click on the name of the desired drawing from the list of recent documents on the right to instantly open 

that drawing. 

 

 Quick Menu: This menu groups frequently used functions (such as New, Open, Save, Print, etc.) to help 

you perform tasks quickly. 

 

 

 Workspace: You can change the workspace to CADian Classic, View, and Markup, etc. The default 

setting is 'Drafting and Annotation.' 



 

 

Tip: After switching to CADian Classic, the workspace menu will no longer be displayed. To change the 

workspace back to 'Drafting and Annotation,' click the 'Switch Workspace' button at the bottom right of the 

CADian window, then select 'Drafting and Annotation.' 

 

 

 

 Title Bar: Displays the current version of CADian (e.g., CADian 2026 x64 Professional) and the name of 

the file currently being worked on. 

 

 

 Menu: Displays various functions of CADian as text. Clicking on items such as File, Edit, View, etc., will 

display the menu items. Clicking on a menu item will execute the command. Additionally, clicking on menu 

items with a ‣ symbol will display submenus, and clicking on a submenu item will execute the corresponding 

command. 



 

 

 Toolbar: This tool is designed to allow beginners to easily execute functions by representing CADian 

features in pictorial form rather than text. 

 

 

Tip: To change the position of the toolbar, place the mouse at the front part of the toolbar. When the mouse 

pointer changes to a cross shape, click the left mouse button and drag it to the desired location to move 

the toolbar. 

 

 Ribbon Menu: A new form of GUI that combines the menu and toolbar into one interface. Clicking on a 

top-level item displays the corresponding sub-items, allowing you to click and use the desired function. 

 

 

Tip: To minimize the ribbon menu, click the Customize Quick Access Toolbar button and select the 

Minimize Ribbon option. The ribbon will be minimized, disappearing from the screen, giving you 

more space for the drawing area. 



 

 

 Command Bar (Command Line): This is where you type commands or see the status and messages of 

currently executing commands 

 

Tip: To toggle the command bar off, press the Control key and type the number 9. Pressing Control+9 

again will bring the command bar back. 

 

 Crosshair: Indicates the current position on the screen and the directions of the x, y, and z axes. The 

square at the center is called the pickbox. 

   

Crosshair in 2D mode   Crosshair in 3D mode 

 

Tip: To change the size of the crosshair, type cursorsize in the command line and enter a value between 1 

and 100. Entering 1 makes the crosshair very small, while 100 makes it very large (filling the entire drawing 

area). 

 

 Pickbox: A small rectangular box that indicates the area for selecting objects. It is usually displayed as a 

square at the center of the crosshair. 

  



 

Tip: To change the size of the pickbox, type pickbox in the command line and enter a value between 0 and 

50. Entering 0 makes the pickbox disappear, while 50 makes it very large. 

 

 UCS Icon: Displays the current coordinate system. This is especially useful for checking the xyz directions 

during 3D work. 

  

 

 Status Bar: Displays the current status of the drawing, including the coordinates, the version of the 

drawing in use, the on/off status of snap and ortho modes, and hardware acceleration. 

 

 

Tip: To toggle the status bar on or off, place the mouse cursor over the ribbon menu or menu area, right-

click, and then check or uncheck the Status Bar option. This will turn the status bar on or off. 

 

 

 

  



2-3. Selecting Objects in CADian 

 

 Selecting Objects by Clicking: You can select objects by clicking on them directly with the mouse. When 

an object is clicked, grips appear on the object, indicating that it has been selected. 

 

 

 Cross Selection: By dragging the mouse cursor from the right to the left, a selection area is created. Any 

object that is even partially within this selection area will be selected. After selection, grips appear on the 

objects to indicate their selection status. If the number of selected objects is large, the objects may be displayed 

as dashed lines. 

 

Selecting Objects by Dragging  

 

Grips Indicating Selection 

 

 Window Selection: By dragging the mouse cursor from the left to the right, a selection area is created. 



Only objects completely within this selection area will be selected. Objects that are only partially within the 

selection area will not be selected. After selection, grips appear on the objects to indicate their selection status. 

If the number of selected objects is large, the objects may be displayed as dashed lines. 

 

Selecting objects by dragging  

 

Grips indicating selection after selecting objects 

 

 Removing objects from the selection set: Hold down the Shift key while clicking on the objects with the 

mouse, or drag to select them. The selected objects will be deselected and removed from the selection set. 

 

 

Two objects already selected  



 

Hold down the Shift key and select the circle 

 

  Selecting all objects: Select the menu Edit → All Ctrl+A, to select all objects in the drawing. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



2-4. Utilizing Grips in CADian 

 

 Moving an Object: Click and drag the center grip of an object to move it. 

 

 

 Scaling an Object: Drag the outer grips to scale the object. 

 

  

 Stretching a Rectangle: Drag the corner grips of a rectangle to stretch it. 

 

 

 

 Adjusting a Line's Length: Drag the ▶ shaped grips at the ends of a line to adjust its length while 

maintaining its shape. 

 



 

 

 Right-Click Menu: After selecting an object, right-click to display frequently used menus. Click the desired 

function to execute it. 

 

 

 

 

  



3.  CADian 2026 Menu - File 

 

3-1. New File 

 

Opens a blank drawing for a new project. 

Menu: Select File ▶ New File. (Or type new in the command line, or press Ctrl+N.) 

Select the desired template file (icad-metric.dwt is generally recommended) and click the ▶ Open button. 

 

 

 

 

 

  



3-2. Open 

 

Loads a previously saved drawing file (dwg, dxf, etc.) into CADian. 

 

1) Menu: Select File ▶ Open. (Or type open in the command line, or press Ctrl+O.) 

2) Select the desired file ▶ Refer to the preview and description on the right, then click the 'Open' button. 

 

 

 

 

 

 

  



3-3. SheetSet Manager 

 

Allows you to create, display, and organize the layout of multiple drawing files or an entire project. It also 

provides easy access to or publishing (publishing) of the desired sheets. 

 

1) Menu: Select File ▶ Sheet Set Manager. (Or type sheetset in the command line.) 

 

2) The Sheet Set Manager window will appear on the left side of the CADian window. 

 

 

3) Click on the desired sheet from the sheet set list to open it directly. 

 

  



3-4. Start Page 

 

Displays the start page shown when the CADian program is launched. It provides easy access to drawing 

template files and recently opened drawing lists. 

 

1) Menu: Select File ▶ Start Page. 

 

2) The start page will be displayed. 

 

 

Tip: If you check 'Skip Start Page Next Time' at the bottom left, the start page will not appear when CADian 

is launched. 

 

 

 

 

  



3-5. Close 

 

Closes the currently open drawing. If the drawing is not saved, it prompts you to save it. 

 

1) Menu: Select File ▶ Close Current Drawing. (Or type close in the command line.) 

 

2) If the current drawing is saved, it will close immediately. 

 

3) If the current drawing is not saved, a save prompt will appear. Click “Yes” to save the drawing or “No” to 

close without saving. 

 

4) Click “Cancel” to cancel the close operation. 

 

Tip: Place the mouse cursor over the tab of the drawing you want to close and right-click to display the 

menu. Click 'Close *** Drawing' to close that drawing. Click 'Save All' to save all currently open drawings. 

Click 'Close All Without Saving' to close all currently open drawings without saving (use with caution). 

 

 

 

 

 

 

 

  



3-6. Import 

 

Allows you to import files other than dwg and dxf, such as dgn (MicroStation design file), wmf (metafile), 

and dae (Collada file). 

 

1) Menu: Select File ▶ Import. (Or type import in the command line.) 

2) Click on the file type ▶ Select the desired file type. 

 

3) Select the file and click the 'Open' button ▶ The selected file will be imported into the current drawing. 

 

  



3-7. Export 

 

Allows you to export drawing objects to PDF, SVG, BMP, DGN, STL, or JPG files. 

 

1) Menu: Select File ▶ Export. (Or type export in the command line.) 

2) Select the file type ▶ Choose the desired file format. 

 

 

3) Exporting a JPG File 

 

3-1) Select JPEG file (*.JPG) ▶ Click the 'Save' button ▶ When prompted to select entities for export, click 

or drag to select the objects in the drawing you want to export to JPG, then press Enter. 

 

3-2) When prompted with "Export [Active Layout(A)/Extent(E)/Block(B)/Select entities(S)] <Active 



Layout>:", press Enter. 

 

3-3) When prompted with "Generate Plot [On/Off] <On>:", press Enter. 

 

3-4) When the message "Export completed successfully" appears, check the exported JPG file. 

 

 

4) Exporting a PDF File 

 

4-1) Select Portable Document Format (*.pdf) ▶ Click the 'Save' button ▶ When prompted to specify the 

plot area [Display(D)/Extent(E)/Window(W)] <Display>:, select the area to export to PDF. 

 

⚫ Display (D): Exports the current screen layout as is. 

 

⚫ Extent (E): Exports all objects in the current drawing to fit the page. 

 

⚫ Window (W): Drag the mouse to specify the area to export. 

 

4-2) Check the settings in the Export to PDF window ▶ Click the 'Export' button. 



 

 

4-3) When the message "Export completed successfully" appears, check the exported PDF file. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



3-8. Attach 

 

Allows you to attach dwg files, dgn (MicroStation design file), PDF, and image files to your drawing. 

 

1) Menu: Select File ▶ Attach. (Or type attach in the command line.) 

2) Click on the file type ▶ Select the desired file type. 

 

 

3) Select the file and click the 'Open' button. 

 

4) Specify the insertion point, scale factor, and rotation angle, then the file will be attached to the drawing. 

 

 

 

 

  



3-9. Save 

 

Saves the current drawing to a storage device (HDD, SSD, USB, external HDD, etc.). 

 

1) Menu: Select File ▶ Save. (Or type save in the command line, or press Ctrl+S.) 

 

2) If saving for the first time after working on the drawing: The Save As window will appear. Enter the 

desired file name ▶ Set the desired file format (drawing version) ▶ Click the 'Save' button. 

 

3) If re-saving an already saved drawing: The QSAVE command will be executed in the command line, and 

the drawing will be saved immediately with the same file name. 

 

 

 

  



3-10. Save As 

 

Saves the current drawing with a different name or version to a storage device (HDD, SSD, USB, external 

HDD, etc.). 

 

1) Menu: Select File ▶ Save As. (Or type save as in the command line.) 

 

2) The Save As window will appear. Enter the desired file name ▶ Set the desired file format (drawing 

version) ▶ Click the 'Save' button. 

 

 

∎ Supported Drawing Versions: Click the file type to display the versions, which range from AutoCAD 2018 

to Release 2.5. 

 



 

∎ If you specify a name that already exists, a message will appear saying, "The file already exists. Do you 

want to replace it?" Please confirm and then proceed with the save. 

 

 

 

 

 

 

  



3-11. Etransmit 

 

The Etransmit command allows you to transmit a package of drawings via the internet. When attaching 

drawings to the package, any other drawings and text files included or referenced by the attached drawing 

will also be included in the package. 

 

1) Menu: Select File ▶ Etransmit. (Or type etransmit in the command line.) 

 

2) If the file is not saved, the Etransmit - Save Changes dialog will appear. Click the Confirm button to save 

the file first. 

 

3) The Create Transmittal dialog will appear. 

 



󰋮 File Tree Tab: Displays the list of files that will be included in the transmittal package. By default, it 

includes related items of the current drawing (plotstyle, xref, fonts). 

 

󰋮 File Table Tab: Shows the files that will be included in the transmittal package in a tabular format. You 

can add or remove files here. 

 

󰋮 Add File: Opens a dialog box where you can add files to be included in the transmittal package by clicking 

the Add File button. 

 

󰋮 Select Transmittal Setup: Choose from the list of saved transmittal setups. The default setup is named 

STANDARD. Click to select a different setup. To create a new setup or 

modify an existing one, click the Transmittal Setup button. 

 

󰋮 Transmittal Setup: Opens a dialog box where you can create, modify, or delete transmittal setups. 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-12. Printer Options 

 

Displays the Options - Print tab, where you can manage various printer settings, including the default output 

device, print style table settings, printed headers and footers, and printer configuration files (PC3 files). You 

can explore more details in the Options menu. 

 

Menu: Select File ▶ Printer Options. (Or type printoptions in the command line.) 

 

 

 

 

 

 

 

  



3-13. Page Setup Manager 

 

Manages page setups that store print settings for specific model and layout tabs. 

 

1) Menu: Select File ▶ Page Setup. (Or type pagesetup in the command line.) 

 

 

󰋮 Current Layout: Displays the name of the model tab or layout tab where the current page setup is applied. 

 

󰋮 Current Page Setup: Shows the name of the current page setup applied to the layout. 

 

󰋮 Name: Lists all the page setups for the model tab or layout tab, depending on which tab was viewed before 

opening the dialog box. 

 

󰋮 Details of Selected Page Setup: Shows detailed information about the selected page setup. 

 

󰋮 Set Current: Applies the selected page setup to the current layout. 

 



󰋮 Add: Opens the Add Page Setup dialog box to add a new page setup. 

 

󰋮 Modify: Opens the Modify Page Setup dialog box to edit the currently selected page setup. 

 

󰋮 Delete: Deletes the currently selected page setup. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-14. Print Style Manager 

 

Displays the default folder where plot style tables are stored. 

 

1) Menu: Select File ▶ Print Style Manager. (Or type stylemanager in the command line.) 

 

2) The Print Style Manager window will appear. 

 

 

3) To edit a plot style table, double-click on the table in the Print Style Manager window to open the Plot 

Style Table Editor dialog box. 

 

 

 

 

 

 

 

 

  



3-15. Print Preview 

 

Displays a print preview of the drawing you are working on. 

 

1) Menu: Select File ▶ Print Preview. (Or type preview in the command line.) 

 

2) The print preview will be displayed. 

 

 

 

 

 

 

 

 

 

  



3-16. Plot 

 

Prints the drawing to a printer (plotter) or outputs the drawing as a PDF file. 

 

1) Menu: Select File ▶ Plot. (Or type plot in the command line.) 

2) The Print - Model dialog box will appear. 

 

󰋮 Page Setup: Select a named page setup. 

 

󰋮 Printer Name: Select the printer you want to use. 

 

 



󰋮 Paper Size: Select the desired paper size for printing (usually A4 or A3). 

 

 

󰋮 Plot Scale: Specify the scale for printing. Selecting "Fit to paper" will automatically adjust the scale to fit 

the paper. 

 

 

󰋮 Plot Offset: Use this to specify the margins when printing. Checking "Center the plot" will automatically 

center the print on the paper. 

 

 



 

Plot Offset: Center the plot 

 

Plot Offset: Specify x, y as 20mm 

 

󰋮 Plot Area: Choose whether to print exactly what is displayed on the screen or to specify the print area 

manually. Select 'Window' and then click the 'Select Plot Area' button at the bottom to drag and specify 

the print area with the mouse. 

 



 

Select Plot Area by Dragging the Mouse 

 

󰋮 Printer Style Table: Choose the desired print style. For black-and-white printing, select 'monochrome.ctb'. 

If prompted with "Apply the print style table to all layouts?", click the 'Yes' button. 

 

 

 

 

 

󰋮 Shaded Printing: Specify the viewport printing method when printing. For 2D drawings, selecting "As 

displayed" will speed up the printing process. 

 

 

󰋮 Layout Tab Options: Configure the print options for the layout tab. 



 

 

󰋮 Print Options: Set options for printer style, lineweight printing, and plot stamps. 

 

 

󰋮 Drawing Orientation: Choose whether to print the paper in portrait or landscape orientation. 

 

 

   

󰋮 Preview: Provides a preview of how the print will look before printing. 



 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-17 Publish 

 

Publishes a list of sheets that can include references to layouts from one or more drawings. Sheets are printed 

on printers defined in the page setups assigned to each layout. If no page setup is assigned to a layout, it will 

use the output options saved with the layout in the Print dialog. 

 

1) Menu: Select File ▶ Publish. (Or type publish in the command line.) 

 

2) The Publish dialog box will appear. 

 

 

 

󰋮 Sheet List: Select the list of sheets to publish. This list shows the name of the previously loaded sheet list 

(.dsd file). 

 

󰋮 Load: Select and add an existing sheet list (.dsd file) to the list. 



 

󰋮 Save: Save the current list of layouts as a sheet list (.dsd file). 

 

󰋮 Automatically Load All Open Drawings: Load all layouts, including model space, from each currently open 

drawing. 

󰋮 Add: Select a drawing that includes the layout you want to add as a sheet. You can also press Insert while 

a sheet is selected in the list to select a drawing. 

 

󰋮 Remove: Delete the selected sheet from the list. Press Remove to delete the selected sheet from the list. 

 

󰋮 Change: Modify the page setup assigned to the selected sheet. You can double-click the sheet to select a 

different page setup. 

 

󰋮 Sheet Name: Shows the name of each sheet to be published, including the following information. 

 

󰋮 Selected Sheet: Displays detailed information about the selected sheet. 

 

󰋮 Number of Copies: Enter or select the number of copies to be published. 

 

󰋮 Include Plot Stamp: Include headers and footers with the published sheet. 

 

󰋮 Publish in Background: Allows you to perform other tasks while publishing in the background. 

 

 

 

 

 

 

 

  



3-18. Automatic Publish 

 

Automatically creates electronic files (.dwf/.pdf) from the current drawing and saves them to a specified 

location. 

 

1) Menu: Select File ▶ Automatic Publish. 

 

2) When prompted with "DWFx Auto Publish or Reassign [Location(L)/Settings(S)] <Auto Publish>:", press 

Enter to start the automatic publish. 

 

3) To specify a different location for saving the files, select Location and designate the folder. To customize 

various settings for automatic publishing, select Settings and configure them in the Auto Publish Settings 

dialog box. 

 

 

 

 

 

 

 

  



3-19. Audit 

 

The Audit function checks for and repairs errors within the drawing. 

 

1) Menu: Select File ▶ Audit. (Or type audit in the command line.) 

 

2) When prompted with "Fix any errors detected?", type y and press Enter. 

 

3) The audit results will be displayed, and the process will complete. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-20. Recover 

 

The Recover function checks for errors in the drawing and opens it.  

 

1) Menu: Select File ▶ Recover. (Or type recover in the command line.) 

 

2) The drawing recovery window will appear. Select the file you want to recover ▶ Click 'Open.' 

 

 

3) After the recovery is complete, a message will inform you of the results, and if there are no issues, the 

drawing will open normally. 

 

 

4) If the number of errors is too high, it is recommended to run the Recover function again or use the Audit 

command to recheck for errors in the drawing. 

  



3-21. Drawing Recovery Manager 

 

In the event of a sudden power outage or crash error that prevents saving your drawing, and CADian closes 

unexpectedly, you can recover the last worked-on drawing file and auto-saved files. 

 

1) If CADian closes due to a sudden power outage or error, when you restart CADian, a drawing recovery 

message will appear at the bottom right of the CADian window. 

 

 

2) Menu: Select File ▶ Drawing Recovery Manager. 

 

3) In the Drawing Recovery Manager window on the left, click the backup file you want to recover and check 

the details at the bottom. 

 

4) In the Details section, you can see the file name, folder location, creation date, and file size. 

 

5) In the Preview section, you can see a screenshot (preview) of the selected file. 

 

6) Double-click the file you want to recover in the Backup File section, and it will automatically be 

recovered and loaded into CADian. 



 

7) If the file name includes the string "salvaged," it is an automatically saved temporary file. 

 

 

8) Temporary files are saved in the temporary folder on the C drive (where Windows is installed). They may 

be deleted during disk cleanup or PC maintenance. Therefore, use the Save As command to save the file 

to your working folder (instead of the temporary folder) for further use. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-22. Purge 

 

Purge removes unnecessary objects that are not used in the drawing. 

 

1) Menu: Select File ▶ Purge. (Or type purge in the command line.) 

2) Select the items you want to purge ▶ Click the 'Purge' button. 

 

 

3) Click the 'Purge nested items' checkbox to enable it ▶ Click the 'Purge All' button to remove all 

unnecessary data from the drawing. 



 

4) If you click the 'Purge zero-length geometry and empty text objects' checkbox, null entities and ghost 

entities will also be purged during the process. (This option is disabled if there are no empty objects, so 

you cannot change its status to checked.) 

 

 

 

 

 

  



3-23. Drawing Properties 

 

Allows you to automatically convert the version of a drawing without opening it. 

 

1) Menu: Select File ▶ Drawing Properties. (Or type dwgprops in the command line.) 

 

2) The properties window with the drawing filename will appear. 

 

󰋮 General Tab 

∎ Name: Displays the file name. 

∎ Type: Displays the file type. 

∎ Location: Displays the file path. 

∎ Size: Displays the file size. 

∎ Created: Displays the date the file was first created. 



∎ Modified: Displays the most recent modification date. 

∎ Accessed: Displays the most recent access date. 

∎ Read-only: Indicates whether the file is read-only. If checked, the file cannot be modified or deleted. 

∎ Archive: Indicates whether the file is marked as an archive. If checked, the file contains changes that 

haven't been backed up. 

∎ Hidden: Indicates whether the file is hidden. If checked, the file cannot be accessed unless the file name 

and location are known. 

∎ System: Indicates whether the file is a system file. Drawings cannot be system files, so this option will not 

be displayed. 

 

 

 

 

 

 

 

 

 

 

  



3-24. File Conversion (Intelliconvert) 

 

Allows you to automatically convert the format or version of multiple drawings in a specified folder without 

opening them. 

 

1) Menu: Select File ▶ File Conversion ▶ The CADian Conversion window appears. (Or type 

intelliconvert in the command line.) 

 

 

2) To convert a single file: 

2-1) Click the 'Single File' checkbox ▶ Click the Next button ▶ The Single File  



 

2-2) Click the button in the Input File Name field to select the file you want to convert. 

 

2-3) The target file is automatically designated in the Output File field. To change the file name or folder, 

click the '...' button to designate the folder where the converted file will be saved. 

 

2-4) Click the Conversion Version field ▶ Select the desired file format or version (dwg or dxf) for the 

conversion. 



 

 

2-5. All settings are complete, click the 'Finish' button ▶ A message will appear confirming the conversion 

is successfully completed. 

 

2-6. If the conversion is not performed successfully due to reasons such as the file being open, an error 

message will be displayed. 

 

3) To convert multiple files: 

 

3-1) Click the 'Multiple Files' checkbox ▶ Click the 'Next' button ▶ The CADian Conversion window 



appears. 

 

3-2) Click the '...' button next to the Input Folder to select the folder containing the files you want to convert. 



 

3-3) If you want to include files from subfolders, click the 'Include Subfolders' checkbox. 

 

3-4) Select the file format you wish to convert to. 

 

 

3-5) Click the 'Next' button ▶ Confirm the list of files to be converted in the File List window ▶ Click the 

'Next' button. 



  

3-6) In the 'Convert Multiple Files' window, confirm the folder path where the converted files will be saved 

in the Output section. 

 

3-7) In the Options section, select the desired file format and version in the Conversion Version dropdown. 

 

3-8) If you want to automatically audit the files and fix any errors during conversion, click the 'Audit and Fix 

Errors' checkbox. 

3-9) If you want to replace existing files with the same name, click the 'Replace Existing Files' checkbox. If 

you want to skip over existing files, click the 'Skip If Existing' checkbox. To save the files with a 

specific string appended to their names, click the 'Add Suffix to Output Files' checkbox and enter the 



desired string. 

 

3-10) Click the 'Next' button ▶ Review the conversion results in the Convert Multiple Files window ▶ Click 

the 'Close' button to finish the command. 

  

  



3-25. Add Digital Signature 

 

Adds a digital signature to the drawing. Opens the Digital Signature dialog box, which displays information 

about the digital certificate available on your computer. 

 

1) Menu: Select File ▶ Add Digital Signature. (Or type digitalsign in the command line.) 

 

2) The Digital Signature window will appear. 

 

 

󰋮 Attach Digital Signature After Saving Drawing: Attaches the selected digital signature to the drawing. 

 

󰋮 Comment: Adds information about the selected digital certificate if needed. 

 

󰋮 Timestamp: Select the time server to add a timestamp to the drawing. 

 

 

  



3-26. Validate Digital Signatures 

 

Displays information about the status of digital signatures attached to the current drawing. 

 

1) Menu: Select File ▶ Validate Digital Signatures. (Or type sigvalidate in the command line.) 

 

2) The Digital Signature Validation window will appear. 

 

 

󰋮 View Primary Signature : Click to view detailed information about the digital signature attached to the 

current drawing. This option is not available if there is no digital signature attached. 

 

󰋮 View External Reference Drawings : Select to display a list of all external references in the current 

drawing. This option is not available if there are no external references. 

 

󰋮 View External Reference Signatures : Click to view detailed information about the digital signatures 

attached to the selected external references. This option is not available if there 

are no digital signatures attached. 

 

  



3-27. Send Mail 

 

Activates the email program, allowing you to send CADian drawing files via email. The Send Mail command 

supports all MAPI-compliant email programs (e.g., Microsoft Exchange or Outlook). For more information 

on sending drawing files via email, refer to the documentation included with your email program. 

 

To use this feature, your mail profile must be activated. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



3-28. Recent File List 

 

Displays a list of previously worked-on files, making it very useful for quickly opening and continuing work 

on the last used drawing files. 

 

1) Menu: Select File ▶ Choose the desired file name from the file list.  

 

 

2) The selected drawing will open immediately. 

 

  



3-29. Exit 

 

Exits CADian. If the drawing is not saved, you will be prompted to save it before CADian closes. 

 

1) Menu: Select File ▶ Exit. (Or type exit in the command line.) 

 

2) If the drawing is not saved, a prompt will appear asking if you want to save the drawing. Click ‘Yes’ to 

save and exit, ‘No’ to exit without saving, or ‘Cancel’ to return to CADian without exiting. 

 

 

 

 

 

 

 

  



4. CADian 2026 Menu – Edit 

 

4-1. Undo 

You can undo the last action (or more) during your work. Let's assume you have drawn a circle, a rectangle, 

and an ellipse in that order, and use the Undo function to revert the actions. 

 

1) Menu: Select Edit ▶ Undo. (Or type undo in the command line, or press Ctrl+Z.) 

2) An undo message will appear, and the last drawn ellipse will be undone and removed from the drawing. 

 

 

3) Menu: Select Edit ▶ Undo. (Or type undo in the command line, or press Ctrl+Z.) 

 

4) Another undo message will appear, and the second drawn rectangle will be undone and removed from the 

drawing. 

 

 

5) Menu: Select Edit ▶ Undo. (Or type undo in the command line, or press Ctrl+Z.) 

 

6) Another undo message will appear, and the first drawn circle will be undone and removed from the drawing. 

 

 



7) Menu: Select Edit ▶ Undo. (Or type undo in the command line, or press Ctrl+Z.) 

8) No more actions to undo, so the undo operation will not proceed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



4-2. Redo 

 

You can redo the last undone command. However, the Redo command must be used immediately after the 

Undo command. If another command is used in between, the Redo function cannot be used. Let's assume you 

have drawn a circle, a rectangle, and an ellipse, and then undone the last drawn ellipse. Now, we will use the 

Redo function. 

 

 

 

1) Menu: Select Edit ▶ Redo. (Or type redo in the command line, or press Ctrl+Y.) 

2) A redo message will appear, and the last undone ellipse will be restored and appear in the drawing. 

 

 

3) If there are no more steps to redo, the Redo option will be grayed out and will not execute when clicked. 

 

 

 

 

 

 

 

 

  



4-3. CutClip 

 

Saves the selected objects to the clipboard to be pasted into another drawing or an application that supports 

OLE (e.g., Paint, Hangeul, Excel). Note that using the Cut function immediately removes the objects from the 

drawing. 

 

 

1) Menu: Select Edit ▶ Cut. (Or type cutclip in the command line, or press Ctrl+X.) 

 

2) When prompted to "Select entities to cut to clipboard," click or drag to select the objects ▶ Press Enter. 

 

 

3) Open Paint ▶ Click the Paste button ▶ The cut objects will be pasted into Paint. 



 

 

4) To paste into another CADian drawing, switch to the target drawing ▶ Menu: Select Edit ▶ Paste ▶ 

When prompted for Insertion point, click the desired location ▶ The copied objects will be pasted into the 

drawing. (The original objects are removed.) 

 

 

 

  



4-4. CopyClip 

 

Saves the selected objects to the clipboard. Unlike CutClip, the objects remain in the drawing after copying. 

 

 

1) Menu: Select Edit ▶ Copy. (Or type copyclip in the command line, or press Ctrl+C.) 

 

2) When prompted to "Select entities to copy to clipboard," click or drag to select the objects ▶ Press Enter. 

 

 

3) Open Paint ▶ Click the Paste button ▶ The copied objects will be pasted into Paint. 



 

 

4) To paste into another CADian drawing, switch to the target drawing ▶ Menu: Select Edit ▶ Paste ▶ 

When prompted for Insertion point, click the desired location ▶ The copied objects will be pasted into the 

drawing. (The original objects remain.) 

 

 

5) Open Paint ▶ Click the Paste button to paste the copied objects from CADian into Paint. 

  



4-5. CopyBase 

 

Saves the selected objects to the clipboard with a specified base point for pasting into other applications or 

drawings. 

 

 

 

1) Menu: Select Edit ▶ Copy with Base Point. (Or type copybase in the command line.) 

 

2) When prompted for Base point, click the origin of the UCS icon (or enter 0,0 for absolute coordinates). 

 

3) When prompted to "Select entities to copy to clipboard," click or drag to select the objects ▶ Press Enter. 

 

4) Switch to the target drawing ▶ Menu: Select Edit ▶ Paste ▶ When prompted for Insertion point, click 

the origin of the UCS icon (or enter 0,0 for absolute coordinates) ▶ The copied objects will be pasted at 

the specified coordinates. 

 

 

 

 

 

 

  



4-6. CopyLink 

 

Saves the current view to the clipboard. Let's use this function to copy objects from the drawing to Paint. 

 

 

1) Menu: Select Edit ▶ Copy Link. (Or type copylink in the command line.) 

2) The copylink command appears in the command line, and the screen's objects are 3) immediately copied 

to the clipboard. 

Open Paint ▶ Click the Paste button to paste the copied objects into Paint. 

 

 

  



4-7. Paste 

 

Pastes objects from the clipboard into CADian. 

 

 

1) Open Paint ▶ Click the Select button ▶ Drag to specify the area to copy ▶ Click the Copy button to save 

to the clipboard. 

 



 

2) Menu: Select Edit ▶ Paste. (Or type pasteclip in the command line, or press Ctrl+V.) 

 

3) When prompted for Insertion point, click the desired location (or enter 0,0 for absolute coordinates) ▶ The 

objects are inserted into the drawing. 

 

 

 

 

 

 

 

  



4-8. PasteBlock 

 

Pastes objects from the clipboard into CADian as a block. 

 

 

1) Menu: Select Edit ▶ Copy. (Or type copyclip in the command line, or press Ctrl+C.) 

2) When prompted to "Select entities to copy to clipboard," click or drag to select the objects ▶ Press Enter. 

 

 

 

 

3) Menu: Select Edit ▶ Paste as Block. (Or type pasteblock in the command line, or press Ctrl+Shift+V.) 

 

4) When prompted for Insertion point, click the desired location (or enter coordinates) ▶ The objects are 

inserted as a block. 



 

 

5) When you click the pasted block, a single grip appears at the bottom-left corner, and the object is labeled 

'Block Reference' in the properties 

 

 

6) The block name is automatically generated (e.g.,A$C6778B540). 

 

 

  



4-9. PasteOrig 

 

Pastes objects from the clipboard into CADian at their original coordinates. 

 

 

1) Menu: Select Edit ▶ Copy. (Or type copyclip in the command line, or press Ctrl+C.) 

 

2) When prompted to "Select entities to copy to clipboard," click or drag to select the circle ▶ Press Enter. 

 

 

3) Switch to the target drawing ▶ Menu: Select Edit ▶ Paste to Original Coordinates. (Or type pasteorig in 

the command line.) 

 

4) The copied objects will be pasted at their original coordinates (e.g., 100,100). 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



4-10. PasteSpec 

 

Pastes objects from the clipboard into CADian in various formats. 

 

 

1) Menu: Select Edit ▶ Copy. (Or type copyclip in the command line, or press Ctrl+C.) 

 

2) When prompted to "Select entities to copy to clipboard," click or drag to select the circle ▶ Press Enter. 

 

 

3) Menu: Select Edit ▶ Paste Special. (Or type pastespec in the command line) ▶ The Paste Special dialog 

box appears. 



 

4) In the Data Type section, choose the format for pasting (e.g., Picture (Metafile), Bitmap, CADian Entities). 

 

5) Select Picture (Metafile) ▶ Click 'OK' ▶ When prompted for Insertion point, click the desired location 

(or enter coordinates) ▶ The object is inserted as an OLE image. 

 

6) Select Bitmap ▶ Click 'OK' ▶ When prompted for Insertion point, click the desired location (or enter 

coordinates) ▶ The object is inserted as an OLE image (bitmap). 



 

 

7) Select CADian Entities ▶ Click 'OK' ▶ When prompted for Insertion point, click the desired location (or 

enter coordinates) ▶ The object is inserted as a CADian entity. 

 

 

 

 

 

  



4-11. Erase 

 

Deletes objects from the drawing. 

 

 

1) Menu: Select Edit ▶ Erase. (Or type erase in the command line, or press Del.) 

 

2) When prompted to "Select entities to erase," click or drag to select the circle ▶ Press Enter. 

 

3) The object is deleted from the drawing. 

 

 

 

 

 

  



4-12. Erase, All 

 

Deletes all objects in the drawing, leaving it empty. 

 

1) Menu: Select Edit ▶ Erase All. 

2) All objects in the drawing are automatically selected and deleted. 

 

 

 

 

 

 

 

 

 

 

 

  



4-13. Select All 

 

Selects all objects in the drawing. This is useful when there are too many objects to select individually. 

 

 

1) Menu: Select Edit ▶ Select All. (Or press Ctrl+A.) 

2) All objects in the drawing will be automatically selected. 

 

 

3) After selecting the objects, you can proceed with actions such as copy, move, or delete. 

 

 

 

 

 

 

 

 

  



4-14. Find and Replace 

 

Finds specific text within the drawing and allows you to replace it with other text. Let's find a specific text 

and then use the replace function to change it. 

 

 

 

1) Menu: Select Edit ▶ Find and Replace. (Or type find in the command line.) 

2) The Find and Replace window will appear. 

 

 

3) Find Specific Text 

 

3-1) Set the search location to the entire drawing. 

⚫ Selected Objects: Searches only within the selected objects. 

⚫ Entire Drawing: Searches throughout the entire drawing. 

⚫ Current Space/Layout: Searches only within the current space or layout area. 

 

 



3-2) Enter the text to search for in the Find field ▶ Click the 'Find' button. 

 

3-3) A message will indicate that one instance of the text was found, and the text will be highlighted. 

 

 

  

4) Replace Specific Text with Another Text 

 

4-1) Set the search location to the entire drawing. 

    



4-2) Enter the text “CADian” in the Find field. 

   

4-3) Enter the replacement text “CADian” in the Replace field ▶ Click the 'Replace All' button. 

   

4-4) A message will indicate that 4 instances were found and replaced. All instances of “CADian” will be 

changed to “CADian Pro” 

 

 

5) Click the 'List Results' button for additional information. 



 

6)  When you click the button, a list of additional options will be displayed. 

 

⚫ Match Case: Searches are case-sensitive. 

 

⚫ Whole Words Only: Searches only for whole words that match the text exactly. 

 



∎Searching for “CADian” will not find “CADian2010.” 

 

∎Searching for “2010” will not find “CADian2010.” 

 

⚫ Use Wildcards: Uses wildcard characters in the search. 

 

∎Wildcard *: Represents any string of characters. 

 

∎Wildcard ?: Represents any single character. 

 

∎Searching for “CADian*” will find “CADian2010,” “CADian2014,” “CADian2017,” “CADian2020.” 

 

∎Searching for “CADian201?” will find “CADian2010,” “CADian2014,” “CADian2017.” 

 

⚫ Search Xrefs: Includes text in external reference files in the search. 

 

⚫ Search Blocks: Includes text in blocks in the search. 

 

⚫ Ignore Hidden Items: Excludes text in locked or off layers from the search. 

 

⚫ Text Types: Specifies the types of text to include in the search. By default, all types of text are 

searched. 

 

 

 

 

  



5. CADian 2026 Menu – View 

 

5-1. Redraw 

 

Redraws the screen to remove blips or reveal hidden objects after they have been deleted. 

 

 

 

1) Menu: Select View ▶ Redraw. (Or type redraw in the command line.) 

 

2) The objects in the current drawing will be redrawn, and blips or similar artifacts will be removed. 

 

 

 

 

 

 

  



5-2. Regen 

 

Recalculates and redraws all objects in the current drawing, particularly useful for smoothing circles or arcs 

that appear jagged after zooming in or out. 

 

 

 

1) Menu: Select View ▶ Regen. (Or type regen in the command line.) 

 

2) All objects in the drawing will be regenerated, and circles will appear smooth. 

 

 

 

 

 

 

 

 

  



5-3. RegenAll 

 

Recalculates and redraws all objects in all open drawings, smoothing circles or arcs that appear jagged after 

zooming in or out. 

 

 

1) Menu: Select View ▶ RegenAll. (Or type regenall in the command line.) 

2) All objects in the drawing will be regenerated, and circles will appear smooth. 

 

 

 

 

 

 

 

 

  



5-4. RtZoom 

 

Zooms in or out of the current view using mouse drag. 

 

1) Menu: Select View ▶ Zoom ▶ RtZoom. (Or type rtzoom in the command line.) 

2) Drag the mouse upward to zoom in, changing the pointer to a + magnifying glass. 

 

 

 

3) Drag the mouse downward to zoom out, changing the pointer to a - magnifying glass. 

 

 

 

4) Press ESC or Enter to exit the command. 

 

 

 

 

 

 

  



5-5. Zoom 

 

Use options to zoom in or out on the current working screen. 

 

Menu: Select View ▸ Zoom ▸ Zoom (or type 'zoom' in the command prompt). 

 

Zoom: 

[In(I)/Out(O)/All(A)/Center(C)/Dynamic(D)/Extents(E)/Left(L)/Previous(P)/Scale(S)/Right(R)/Window(W

)/Object(OB)] /<Realtime>: The message is displayed, and you can directly input options using the 

keyboard to zoom in or out in various ways. 

 

All these options are functionally identical to the View ▸ Zoom command in the menu, so we will cover the 

contents in the Zoom menu. 

 

 

 

 

 

 

 

 

 

 

 

  



5-6. Zoom In (2x) 

 

Zooms in on the current view by a factor of 2. 

 

1) Menu: Select View ▶ Zoom ▶ In. 

 

2) The objects on the screen will immediately be magnified by a factor of 2. 

 

    

Before Zooming     After Zooming 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-7. Zoom Out (0.5x) 

 

Zooms out of the current view by a factor of 0.5. 

 

1) Menu: Select View ▶ Zoom ▶ Out. 

 

2) The objects on the screen will immediately be reduced to half their size. 

    

Before Zooming out  Before zooming in  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-8. Zoom Window 

 

Zooms in on a specified area of the current view. 

 

1) Menu: Select View ▶ Zoom ▶ Window. 

 

2) When prompted for the first corner, click the desired corner point of the area to zoom into ▶ When 

prompted for the opposite corner, click the other corner point. 

 

 

3) The drawing will be zoomed into the specified area. 

 

 

 

 

 

 

 

  



5-9. Zoom Extents 

 

Zooms to show all objects in the current drawing to fit the screen. 

 

1) Menu: Select View ▶ Zoom ▶ Extents. 

 

2) The drawing will zoom to show all objects, filling the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-10. Zoom Dynamic 

 

Zooms using a rectangular view box. 

 

1) Menu: Select View ▶ Zoom ▶ Dynamic. 

2) When prompted for the first corner, click the desired corner point of the area to zoom into ▶ When 

prompted for the opposite corner, click the other corner point. 

 

 

3) The drawing will be zoomed into the specified area. 

 

 

 

 

 

 

 

 

  



5-11. Zoom Previous 

 

Returns to the previous view. 

 

1) Menu: Select View ▶ Zoom ▶ Previous. 

2) The previous view will be restored. 

 

Original view 

 

Zoom ▸ Display previous view 

 

 

 

 

 

 

 

 

 

  



5-12. Zoom All 

 

Zooms to show all objects and the drawing limits. Typically, this shows the entire limits area defined for the 

drawing. 

 

1) Menu: Select View ▶ Zoom ▶ All. 

 

2) The drawing will zoom to display the entire limits area. If the limits area is larger than the actual drawing 

area, objects may appear very small. 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-13. Zoom Left 

 

Zooms relative to the specified lower-left corner using the entered view height or zoom scale. 

 

1) Menu: Select View ▶ Zoom ▶ Left. 

 

2) When prompted for the lower-left corner, click the desired point (or enter coordinates such as 0,0). 

 

3) When prompted for the Zoom factor (nX/nXP), or view height, enter the desired value. 

 

3-1) Specify the view height with the mouse or by entering a value. This will be recognized as the y-axis value 

for zooming in or out. 

    

Before zooming                               After zooming 

 

3-2) Enter a value followed by 'x' (e.g., 5x) to zoom in by that factor. Enter a value less than 1 (e.g., 0.5x) to 

zoom out. 

    

Before zooming                               After zooming 

 

3-3) Enter a value followed by 'xp' (e.g., 5xp) to zoom in or out relative to the drawing space units. 

 

  



5-14. Zoom Center 

 

Zooms relative to the specified center point using the entered view height or zoom scale. 

 

1) Menu: Select View ▶ Zoom ▶ Center. 

 

2) When prompted for the center of the view, click the desired point (or enter coordinates such as 0,0). 

 

3) When prompted for the Zoom factor (nX/nXP), or view height, enter the desired value. 

 

3-1) Specify the view height with the mouse or by entering a value. The view will be centered on the specified 

point and zoomed accordingly. 

    

Before zooming                               After zooming 

 

3-2) Enter a value followed by 'x' (e.g., 5x) to zoom in by that factor. Enter a value less than 1 (e.g., 0.5x) to 

zoom out. 

     

Before zooming                               After zooming  

 

3-3) Enter a value followed by 'xp' (e.g., 5xp) to zoom in or out relative to the drawing space units. 

  



5-15. Zoom Object 

 

Zooms to fit the selected object(s) to the screen. 

 

1) Menu: Select View ▶ Zoom ▶ Object. 

2) When prompted to select objects, select the objects ▶ Press Enter. 

3) The view will zoom to fit the selected objects to the screen. 

    

Before Zooming                              After Zooming 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-16. Zoom Scale 

 

Zooms in or out using a specified scale factor. 

 

1) Menu: Select View ▶ Zoom ▶ Scale. 

2) When prompted for the Zoom factor (nX/nXP), enter the desired value followed by 'x' (e.g., 2x) ▶ Press 

Enter to zoom in by that factor. Enter a value less than 1 (e.g., 0.5x) to zoom out. 

    

Before Zooming        After Zooming 

 

3) Enter a value followed by 'xp' (e.g., 5xp) to zoom in or out relative to the drawing space units. 

 

 

 

 

 

 

 

 

 

 

  



5-17. RtPan 

 

Pans the view in real-time to navigate to different parts of the drawing. 

 

1) Menu: Select View ▶ Pan ▶ RtPan. 

2) When prompted with "Press ESC or ENTER to exit or right-click for shortcut menu," the mouse pointer 

changes to a hand. Drag the pointer to pan the view. 

 

 

 

3) Press ESC or Enter to exit the command. 

 

Tip: You can also perform real-time panning by dragging the mouse wheel button. 

 

 

 

 

 

 

 

 

 

 

  



5-18. Pan 

 

Moves the view by specifying two points to define the distance and direction. 

 

1) Menu: Select View ▶ Pan ▶ Pan. 

2) When prompted for the base point or displacement, click the base point (or enter coordinates such as 0,0). 

3) When prompted for the second point, click the destination point (or enter coordinates such as 0,0 for 

absolute or relative displacement). 

    

Pan to specify the second point   Pan complete 

 

Tips: Anda juga dapat menggunakan tombol gulir (scroll) pada mouse untuk melakukan pindah fokus 

secara real-time. 

 

 

 

 

 

 

 

 

 

  



5-19. Viewports 

 

Calls the Viewports window to create, name, and save layout viewports. 

 

1) Menu: Select View ▶ Viewports ▶ Viewports. (Or type viewports in the command line.) 

 

 

2) The New Viewports tab allows you to display standard viewport layouts and set up model space viewports. 

 

󰋮 New Name: Set the name for the new model space viewport layout. It is optional; if not set, the viewport 

layout will apply but not be saved. 

  

  

◼ Standard Viewport: Lists and sets standard viewport layouts and current viewport layouts.

   



  

◼ Preview: Shows a preview of the selected viewport layout and displays the default view for 

each viewport. 

 

   

  

◼ Apply To: Applies the viewport layout to the entire screen or the current viewport. 

◼ Display: Applies the viewport layout to the entire screen of the model tab. (Default setting) 

◼ Current Viewport: Applies the viewport layout only to the current viewport. 

   

◼ Settings: Set to 2D or 3D. 

◼ 2D: A new viewport layout is created for the current view of all viewports. 

◼ 3D: The standard orthogonal 3D view is applied to the current view. 



  

◼ Change View: Replaces the view in the selected viewport with the view chosen from the list.

  

 
◼ Change View: Replaces the view in the selected viewport with the view chosen from the list. 

 

   

3) Named Viewport Tab: Check the list of saved viewports through the New Name field. 

◼ Named Viewport: Applies a visual style to the viewport. 

   

  

◼ Preview: Shows a preview of the selected viewport layout and displays the default view for each 

viewport. 



   

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-20. Viewports, Single 

 

Changes the screen to a single viewport. 

 

1) Menu: Select View → Viewports → Single. 

 

2) The screen will immediately change to a single viewport. 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-21. 2 Viewports, 2 

 

Splits the screen into two viewports. 

1) Menu: Select View → Viewports → 2 Viewports. 

2) When prompted for Two Viewports: [Horizontal(H)]/<Vertical(V)>:, enter H for horizontal split or V for 

vertical split (default is vertical). 

3) The screen will immediately split into two viewports. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-22. 3 Viewports, 3 

 

Splits the screen into three viewports. 

 

1) Menu: Select View → Viewports → 3 Viewports. 

 

2) When prompted for Three Viewports: 

[Horizontal(H)/Vertical(V)/Above(A)/Below(B)/Left(L)]/<Right>:, choose the split method and enter the 

corresponding shortcut key → Press Enter. 

 

󰋮 Horizontal(H): Splits the screen into three horizontal viewports.  

 

 

󰋮 Vertical(V): Splits the screen into three vertical viewports. 

 

 

󰋮 Above(A): One viewport above and two below. 



 

 

󰋮 Below(B): One viewport below and two above. 

 

󰋮 Left(L): One viewport on the left and two on the right. 

 

 

 

 

 

 

  



5-23. Viewports, 4 

 

Splits the screen into four viewports. 

 

1) Menu: Select View → Viewports → 4 Viewports. 

 

2) The screen will immediately split into four viewports. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-24. Viewports, Object 

 

Creates a viewport in the layout space using an object's shape. 

 

1) Click on either "Layout 1" or "Layout 2" at the bottom of the screen under theModel/Layout1/Layout2 

section to navigate to the layout area. 

 

2) Select View → Viewports → Object. 

 

3) When prompted to Select object to clip viewport:, click the object to use as the viewport shape (closed 

polyline, ellipse, spline, or circle). 

 

4) A viewport will be created in the shape of the selected object. 

 

 

 

 

 

  



5-25. Garis Pandaun Terbatas (3dorbit) 

 

Rotates the view to examine the 3D object from various angles, primarily used for inspecting 3D shapes. 

 

1) Menu: Select View → 3D Orbit → Constrained Orbit. (Or type 3dorbit in the command line.) 

 

2) The mouse pointer changes to a 3D orbit icon, and a message appears indicating you can drag to rotate the 

view. Press Enter or Esc to exit the command. 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-26. Garis Panduan Bebas (3dforbit) 

 

This function allows you to rotate the view from various angles to inspect the shape of a 3D object. It is 

primarily used for checking the form of 3D objects. 

 

1) Menu: Select View → 3D Orbit → Free Orbit. (Alternatively, type 3dforbit in the command line.) 

 

2) The mouse pointer changes to a 3D Orbit icon, and unlike 3dorbit, a circular mark appears on the  

screen to aid rotation. 

 

3) To change the pivot point, type [Settings (S)] and press Enter, right-click, or press the Esc key to  

complete. A message will appear, and dragging the mouse up, down, left, or right will rotate the object  

in the corresponding direction. 

 

 

4) When you hover the mouse over the corners of the circular mark, the mouse pointer will change, 

allowing rotation only in the direction of the pointer. 

 

 

A state where rotation is only possible to the left and right. 

 



 

 

A state where rotation is only possible up and down. 

 

Tip: Holding the Shift key while dragging the mouse wheel button will enable free orbit rotation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-27. 3D Continuous Orbit 

 

This function allows continuous rotation of the view in various directions to inspect the shape of a 3D object. 

 

1) Menu: Select View → 3D Orbit → Continuous Orbit. 

 

2) The mouse pointer changes to a 3D Orbit icon. To change the pivot point, type [Settings (S)] and press 

Enter, right-click, or press the Esc key to complete. A message will appear, and dragging the mouse up, 

down, left, or right will rotate the object in the corresponding direction. 

 

 

3) Once the object starts rotating, it will continue to rotate in that direction even after releasing the mouse 

button. 

 

 

 

 

 

 

  



5-28. Restricted X Orbit (Rtrotx) 

 

This function rotates the view around the x-axis. 

 

1) Menu: Select View → 3D Orbit → Restricted X Orbit. 

 

2) The mouse pointer changes to a 3D Orbit icon (indicating rotation around the x-axis). To complete,  

press Enter, right-click, or press the Esc key. A message will appear, and dragging the mouse up, down,  

left, or right will rotate the object around the x-axis. 

 

 

 

 

 

 

 

 

 

 

 

  



5-29. Restricted Y Orbit (Rtroty) 

 

This function rotates the view around the y-axis. 

 

1) Menu: Select View → 3D Orbit → Restricted Y Orbit. 

 

2) The mouse pointer changes to a 3D Orbit icon (indicating rotation around the y-axis). To complete, press 

Enter, right-click, or press the Esc key. A message will appear, and dragging the mouse up, down, left, or 

right will rotate the object around the y-axis. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-30. Restricted Z Orbit (Rtrotz) 

 

This function rotates the view around the z-axis. 

 

1) Menu: Select View → 3D Orbit → Restricted Z Orbit. 

 

2) The mouse pointer changes to a 3D Orbit icon (indicating rotation around the z-axis). To complete, press 

Enter, right-click, or press the Esc key. A message will appear, and dragging the mouse up, down, left, or 

right will rotate the object around the z-axis. 

 

 

 

 

 

 

 

 

 

  



5-31. Top View (View, Top) 

 

This function changes the view to a top view. 

 

1) Menu: Select View → 3D View → Top. 

 

2) The current view changes to a top view. 

 

 

 

 

 

 

 

 

 

 

  



5-32. Front View (View, Front) 

 

This function changes the view to a front view. 

 

1) Menu: Select View → 3D View → Front. 

 

2) The current view changes to a front view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5-33. Right View (View, Right) 

 

This function changes the view to a right-side view. 

 

1) Menu: Select View → 3D View → Right. 

 

2) The current view changes to a right-side view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5-34. Left View (View, Left) 

 

This function changes the view to a left-side view. 

 

1) Menu: Select View → 3D View → Left. 

 

2) The current view changes to a left-side view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5-35. Back View (View, Back) 



 

This function changes the view to a back view. 

 

1) Menu: Select View → 3D View → Back. 

 

2) The current view changes to a back view. 

 

 

 

 

 

 

  



5-36. Bottom View (View, Bottom) 

 

This function changes the view to a bottom view. 

 

1) Menu: Select View → 3D View → Bottom. 

 

2) The current view changes to a bottom view. 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-37. Top-Left-Front View (View, -1, -1, 1) 

 

This function changes the view to a top-left-front view. 

 

1) Menu: Select View → 3D View → Top-Left-Front. 

 

2) The current view changes to a top-left-front view. 

 

 

 

 

 

 

 

 

 

 

  



5-38. Top-Right-Front View (View, 1, -1, 1) 

 

This function changes the view to a top-right-front view. 

 

1) Menu: Select View → 3D View → Top-Right-Front. 

 

2) The current view changes to a top-right-front view. 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-39. Top-Right-Back View (View, 1, 1, 1) 

 

This function changes the view to a top-right-back view. 

 

1) Menu: Select View → 3D View → Top-Right-Back. 

 

2) The current view changes to a top-right-back view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-40. Top-Left-Back View (View, -1, 1, 1) 

 

This function changes the view to a top-left-back view. 

 

1) Menu: Select View → 3D View → Top-Left-Back. 

 

2) The current view changes to a top-left-back view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-41. Bottom-Left-Front View (View, -1, -1, -1) 

 

This function changes the view to a bottom-left-front view. 

 

1) Menu: Select View → 3D View → Bottom-Left-Front. 

 

2) The current view changes to a bottom-left-front view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-42. Bottom-Right-Front View (View, 1, -1, -1) 

 

This function changes the view to a bottom-right-front view. 

 

1) Menu: Select View → 3D View → Bottom-Right-Front. 

 

2) The current view changes to a bottom-right-front view. 

 

 

 

 

 

 

 

 

 

 

 

  



5-43. Bottom-Right-Back View (View, 1, 1, -1) 

 

This function changes the view to a bottom-right-back view. 

 

1) Menu: Select View → 3D View → Bottom-Right-Back. 

 

2) The current view changes to a bottom-right-back view. 

 

 

 

 

 

 

 

 

 

 

 

  



5-44. Bottom-Left-Back View (View, -1, 1, -1) 

 

This function changes the view to a bottom-left-back view. 

 

1) Menu: Select View → 3D View → Bottom-Left-Back. 

 

2) The current view changes to a bottom-left-back view. 

 

 

 

 

 

 

 

 

 

 

  



5-45. Dynamic View Control (Viewctl) 

 

This function allows various adjustments through the view control window. 

 

1) Menu: Select View → Dynamic View Control. (Alternatively, type viewctl in the command line.) 

 

2) The view control window appears. 

 

 

 

3) Drag the mouse in the direction of the arrow to rotate the blue bar and set the desired angle. The changing 

angles are displayed in the X-axis and XY plane sections at the bottom. 

 

 

4) The object (viewport) appears in a preview form as you set the changing angles. 



      

 

5) Click the ‘Set to Plan View’ button to set X-axis: 270, and XY plane: 90. 

 

 

6) Click the ‘Preset’ button to bring up the viewport preset window. Select the desired preset viewport shape, 

and the angle in the view control window will change accordingly. 



 

 

7) Click the ‘Adjust’ button to open the View Control - WCS-related window, allowing fine adjustments of 

the angles. 

 

 

 

6-1) Rotation Item : 'Change' specifies the angle value to be rotated each time the rotation button at the bottom 

is clicked. Clicking the  button rotates by 10 degrees each time, and the smaller the number, the 

finer the angle adjustment. 



        

6-2) Click the rotation button to check the angle in the preview window on the left each time it rotates. 

  

  

6-3) Navigation Item : This item allows you to move the drawing's position up, down, left, or right, or to zoom 

in and out to check the drawing's objects. 

  

  

 

 

 

 

 

  



5-46. Plan View 

 

Changes the drawing to a plan view of the current UCS or WCS. 

 

1) Menu: Select View → Plan View. (Or type "plan" in the command line.) 

 

2) Prompt: [Current UCS (C)/UCS (U)/WCS (W)]/<Current>: A prompt will appear. Select one from the 

current UCS, UCS, or WCS. Press Enter to change to the plan view based on the current UCS. 

 

Before changing the planar view 

 

Change the planar view based on the current UCS 

 

 

 

 

 

  



5-47. Background 

 

Changes the drawing's background to solid, gradient, or image. 

 

1) Menu: Select View → Background. (Or type "background" in the command line.) 

 

2) When the background window appears, choose a type (solid, gradient, or image). 

 

 

3) Type - Solid: Select solid and specify a color to change the background color to a single solid color. 

 



 

 

4) Type - Gradient: Select gradient and specify the top and bottom colors in the gradient options to change 

the background to a gradient. 

 

 

5) Background - Image: Select image, click the browse button in the image options to choose an image file 

(jpg, bmp, etc.) to set as the background. 



 

 

 

 

 

 

 

 

 

 

 

  



5-48. Visual Style, 2D Wireframe (Vscurrent, 2d-wireframe) 

 

Changes the visual style of the current viewport to 2D wireframe. 

 

1) Menu: Select View → Visual Style → 2D Wireframe. 

 

2) The drawing's objects are displayed as 2D wireframes (with lines drawn on all edges of the entities to 

display them in two dimensions). 

 

 

 

 

 

 

 

 

 

 

  



5-49. Visual Style, Hidden (Vscurrent, hidden) 

 

Changes the visual style of the current viewport to hidden line (hide). 

 

1) Menu: Select View → Visual Style → Hidden. 

 

2) The drawing's objects are displayed as hidden lines (with lines drawn only on the visible edges of the 

surfaces to display them in three dimensions). 

 

 

 

 

 

 

 

 

 

 

  



5-50. Visual Style, Realistic (Vscurrent, Realistic) 

 

Changes the visual style of the current viewport to realistic. 

 

1) Menu: Select View → Visual Style → Realistic. 

 

2) The drawing's objects are displayed in a realistic view (with surfaces filled with the selected material in 

three dimensions). 

 

 

 

 

 

 

 

 

 

 

 

  



5-51. Visual Style, Conceptual (Vscurrent, Conceptual) 

 

Changes the visual style of the current viewport to conceptual. 

 

1) Menu: Select View → Visual Style → Conceptual. 

 

2) The drawing's objects are displayed in a conceptual view (with surfaces filled with the selected material 

and softened edges of polygon faces to display them in three dimensions). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



5-52. Prompt History Window 

 

Displays the prompt history window. This functions similarly to the command line but allows you to view a 

much longer list of commands. If there is no check mark () in front of the item, selecting it will turn it on, 

and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Prompt History Window. 

 

2) The prompt history window appears. 

 

 

 

 

 

 

 

  



5-53. Command Bar 

 

Turns the command bar on or off. If there is no check mark () in front of the item, selecting it will turn it 

on, and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Command Bar. 

 

2) The command bar disappears. 

 

 

3) Menu: Select View → Display → Command Bar to make the command bar reappear. 

 

Tip: Pressing Control+9 also toggles the command bar. 

 

 

 

 

  



5-54. Status Bar 

 

Turns the status bar at the bottom of the CADian window on or off. If there is no check mark () in front of 

the item, selecting it will turn it on, and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Status Bar. 

 

) The status bar disappears. 

 

 

3) Menu: Select View → Display → Status Bar to make the status bar reappear. 

 

 

 

 

 

  



5-55. Scroll Bar 

 

Turns the scroll bars on the right and bottom of the drawing area on or off. If there is no check mark () in 

front of the item, selecting it will turn it on, and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Scroll Bar. 

 

2) The scroll bars appear on the right and bottom of the drawing area. 

 

 

3) Menu: Select View → Display → Scroll Bar to make the scroll bars disappear. 

 

 

 

 

 

 

 

 

 

  



5-56. Tip of Day on Start 

 

Turns the display of the Tip of the Day on or off when starting CADian. If there is no check mark () in front 

of the item, selecting it will turn it on, and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Tip of Day on Start to uncheck it. 

 

2) The Tip of the Day will not be displayed when CADian starts. 

 

3) Menu: Select View → Display → Tip of Day on Start to check it. The Tip of the Day will be displayed on 

the left side of the start page when CADian starts. 

 

 

 

 

 

 

  



5-57. Tampilan Tab Model dan Layout (Model & Layout tab) 

 

Turns the display of the Model and Layout tabs at the bottom of the drawing area on or off. If there is no 

check mark () in front of the item, selecting it will turn it on, and if there is a check mark, selecting it will 

turn it off. 

 

1) Menu: Select View → Display → Model & Layout Tab to uncheck it. 

 

2) The Model and Layout tabs at the bottom of the drawing area disappear. 

 

 

3) Menu: Select View → Display → Model & Layout Tab to check it. The Model and Layout tabs reappear. 

 

 

 

 

 

 

 

 

  



5-58. Fill 

 

Turns fill mode on or off. If there is no check mark () in front of the item, selecting it will turn it on, and if 

there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → Fill to uncheck it. 

 

2) Prompt: FILLMODE is currently on: [ON/OFF/Toggle (T)]<ON>: A message will appear. Enter on or off 

and press Enter. 

 

    

Fill mode on      Fill mode off 

 

 

 

 

 

 

 

 

  



5-59. UCS Icon 

 

Turns the UCS icon on or off. If there is no check mark () in front of the item, selecting it will turn it on, 

and if there is a check mark, selecting it will turn it off. 

 

1) Menu: Select View → Display → UCS Icon to uncheck it. 

 

2) Prompt: [ON/OFF/All (A)/No Origin (N)/Origin (OR)]<ON>: A message will appear. Enter on or off and 

press Enter. 

    

UCS Icon on                    UCS Icon off 

 

 

 

 

 

 

  



5-60. Toolbar Configuration (Tbconfig) 

 

Sets various options related to the toolbar. Turns specific toolbar collections on or off. 

 

1) Menu: Select View → Toolbar. (Or type tbconfig in the command line.) 

 

2) The toolbar selection window appears. 

 

󰋮 Menu Group: Select the toolbar group you want to modify. 

 

 

󰋮 Toolbar Name: Check or uncheck the box in front of the item to display or hide the corresponding 

toolbar. 



 

󰋮 Large Button : Checking the box in front of an item will display the toolbar with large buttons. 

  Default size toolbar 

  Large button toolbar 

 

󰋮 Show tooltips : Checking the box in front of an item will display tooltips when the mouse cursor  

hovers over the toolbar. 

  

󰋮 Customize : Calls the 'Customization' menu, a user interface that allows you to edit the 

toolbar, toolbars, and ribbon menu.  



 

 

 

 

 

 

 

 

  



6. CADian 2026 Menu - Insert 

 

6-1. Block 

 

A block is an object or a group of objects that are combined into a single named entity for repeated use. Blocks 

can be inserted and edited freely in new or existing drawings, making tasks such as repetitive drawing or 

inserting components from a library much easier and faster. Let's explore various block-related functions 

using the block insertion feature. 

 

1) Menu: Select Insert → Block. (Or type block in the command line.) 

 

2) The insertion window appears. 

 

 

󰋮 Name: Enter the name of the block to insert, or click the button on the right to select a block from the list. 

Alternatively, click the button to select a drawing to insert. 

   

 

󰋮 Preview: Shows a preview of the selected block. 



  

 

◼ Titik Penyisipan: Masukkan koordinat lokasi tempat blok akan disisipkan. Jika centang off, An

da dapat memasukkan koordinat; jika centang on, Anda dapat mengklik lokasi penyisipan pada g

ambar. 

      

 

󰋮 Insertion Point: Enter the coordinates of the insertion point. If 'Specify on-screen' is unchecked, you can 

input coordinates; if checked, you can click the desired location in the drawing to specify the insertion 

point. 

    

 

󰋮 Scale: Specify the X, Y, and Z scale factors for the block. If 'Specify on-screen' is unchecked, you can 

input scale values; if checked, you can specify the scale when inserting the block. If 'Uniform Scale' is 

checked, the X, Y, and Z scale factors will be changed uniformly. 

     

 

󰋮 Rotation: Specify the rotation angle of the block. If 'Specify on-screen' is unchecked, you can input the 



rotation angle; if checked, you can specify the angle when inserting the block. 

  

  

󰋮 Block Unit: Check the unit and scale of the block. 

 

󰋮 Explode: If unchecked, the block will be inserted as a single entity. If checked, the block will be exploded 

upon insertion. 

 

󰋮 Multi Block: Inserts multiple instances of the block. Enter the number of columns, column spacing, number 

of rows, and row spacing to insert multiple blocks. 

   

3) After completing all settings, click the 'OK' button → In the command line, click the insertion point (or 

enter absolute or relative coordinates such as 100,100), and enter the rotation angle to insert the block. 

  

  

 

 

 

  



6-2. External Reference Manager (Xref) 

 

External references (Xrefs) are not objects within the working drawing like blocks. They exist outside the 

drawing, but you can view and work with them directly as if placing a tracing paper over the drawing. 

 

1) Menu: Select Insert → External Reference Manager. (Or type xref in the command line.) 

 

2) The External Reference Manager window appears. 

 

󰋮 External Reference File List: Displays the list of external reference files referenced in the current drawing. 

  

󰋮 External Reference Path: Click the browse button to specify the path to the external reference drawing. 

 

󰋮 Additional External Reference Search Paths: Click the browse button to add paths where external reference 

drawings might be located. You can specify multiple paths using semicolons (;), and CADian will search 

these paths in order. 



 

 

3) Attach: Selecting an External Drawing to Reference in the Current Drawing 

3-1) Click the Attach Button → Select the drawing to insert → Click the 'Open' button. 

 

 

 

3-2) The External Reference Attach window appears. 

 

 

◼ Name: Displays the name of the external reference file you want to insert, and you can change it 



by clicking the Browse button. 

 

󰋮 Reference Type: Choose whether to attach or overlay the external reference file. 

 

∎ Attach: Specifies that the external reference is attached but not overlaid. 

 

∎ Overlay: Specifies that the external reference is overlaid. It will be ignored and not included when the 

drawing is attached or overlaid in another drawing (multi-level referencing is not allowed). 

   

 

󰋮 Path Type: Choose the path type for the external reference file. 

 

∎ Full Path: The absolute path of the external reference file on the storage medium (e.g., 

d:\workfolder\project1\MrChoi\20229\cadian.dwg). 

 

∎ Relative Path: The path of the reference file relative to the location of the current file, which is very 

convenient for collaboration (e.g., .\cadian.dwg). 

 

 

󰋮 Insertion Point: Enter the coordinates of the insertion point for the external reference file. If 'Specify on-

screen' is unchecked, you can input coordinates; if checked, you can click the desired location in the 

drawing to specify the insertion point. 

      



 

󰋮 Scale: Specify the X, Y, and Z scale factors for the inserted external reference file. If 'Specify on-screen' is 

unchecked, you can input scale values; if checked, you can specify the scale when inserting the external 

reference file. If 'Uniform Scale' is checked, the X, Y, and Z scale factors will be changed uniformly. 

      

 

󰋮 Rotation: Specify the rotation angle of the external reference file. If 'Specify on-screen' is unchecked, you 

can input the rotation angle; if checked, you can specify the angle when inserting the external 

reference file. 

    

 

󰋮 Block Unit: Check the unit and scale of the external reference file. 

   

 

3-3) After completing all settings, click the 'OK' button. The external reference will be displayed as a preview 

in the drawing area. 

 

3-4) Specify Insertion Point: When prompted, click the insertion point for the external reference file (or enter 

the absolute coordinates such as 0,0, or relative coordinates). 

 

3-5) Enter X Scale Factor, Opposite Corner or [Corner (C)/XYZ] <1>: When prompted to enter the X scale 

factor, enter the value and press Enter. 

 



3-6) Enter Y Scale Factor <Use X Scale Factor (1)>: When prompted to enter the Y scale factor, enter the 

value and press Enter. 

 

3-7) Specify Rotation Angle <0.0>: When prompted to specify the rotation angle, enter the value and press 

Enter. 

3-8 ) After confirming that the external reference file is loaded in the list, click the 'Close' button. 

 

 

4) Detach : Select a file from the list of external reference files, then click the Detach button. The objects in 

the external reference file are immediately detached from the drawing. 

 

5) Reload : Select a file from the list of external reference files, then click the Reload button. This reloads the 

external reference file. 

 

6) Unload : Select a file from the list of external reference files, then click the Unload button. The objects in 

the external reference file are immediately unloaded from the drawing. Unlike detaching, this does not 

completely delete the external reference, and it can be easily reloaded. 

 

7) Bind : Select a file from the list of external reference files, then click the Bind button. Choose the binding 

type, and the objects in the external reference file are immediately bound as block objects in the drawing. 



 

 

󰋮 Bind: The layers of the external reference drawing are renamed to externalreference$0$layername. 

 

󰋮 Insert: The layers of the external reference drawing are merged with their original names. 

 

8) Open : Select a file from the list of external reference files, then click the Open button. This loads the file 

into the drawing as if using the open command. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



6-3. PDF Underlay (Pdfattach) 

 

Attach a PDF file to your drawing. 

 

1) Menu: Select Insert → PDF Underlay. (Or type pdfattach in the command line.) 

 

2) The reference file location window appears. Select the file to attach → Click the 'Open' button. 

 

 

3) Enter Page Number or [?] <1>: When prompted, enter the page number and press Enter. 

 

4) Specify Insertion Point: When prompted, click the insertion point for the PDF (or enter absolute coordinates 

such as 0,0). 

 

5) Specify Scale Factor or [Unit (U)] <1>: When prompted, enter the scale factor and press Enter. 

 

6) Specify Rotation Angle <0>: When prompted, enter the rotation angle and press Enter. 

 

7) The PDF file is attached as an underlay in the drawing. 



 

 

Tip: Using the pdfimport function allows you to convert the PDF file into drawing objects, making the 

drawing work much cleaner and more comfortable. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



6-4. DGN Underlay (Dgnattach) 

 

Attach a DGN file as an underlay in the current drawing. 

 

1) Menu: Select Insert → DGN Underlay. (Or type dgnattach in the command line.) 

 

2) The reference file selection window appears. Select the DGN file to attach → Click the 'Open' button. 

 

3) Enter Page Number or [?] <Model>: When prompted, press Enter. 

 

4) Specify Conversion Units [Master (M)/Sub (S)] <Master (M)>: When prompted, enter the conversion units 

or press Enter. 

 

5) Specify Insertion Point: When prompted, click the insertion point for the DGN or enter the coordinates via 

the keyboard. 

 

6) Specify Scale Factor or [Unit (U)] <1>: When prompted, enter the scale factor via mouse or keyboard. 

 

7) Specify Rotation Angle <0>: When prompted, enter the rotation value for the DGN file. 

 

8) The DGN file is attached to the current drawing. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



6-5. DWF Underlay (Dwfattach)                                                                                                                                             

 

Attach a DWF file as an underlay in the current drawing. 

 

1) Menu: Select Insert → DWF Underlay. (Or type dwfattach in the command line.) 

 

2) The reference file selection window appears. Select the DWF file to attach → Click the 'Open' button 

 

 

3) Enter Page Number or [?] <Model>: When prompted, press Enter. 

 

4) Specify Insertion Point: When prompted, click the insertion point for the DGN or enter the coordinates via 

the keyboard. 

 

5) Specify Scale Factor or [Unit (U)] <1>: When prompted, enter the scale factor via mouse or keyboard. 

 

6) Specify Rotation Angle <0>: When prompted, enter the rotation value for the DGN file. 

 

7) The DWF file is attached to the current drawing. 



 

 

 

 

 

 

 

 

 

  



6-6. Image Attach (Imageattach) 

 

Attach image files such as BMP, JPG, PNG, TIF to the current drawing. 

 

1) Menu: Select Insert → Image → Image Attach. (Or type imageattach in the command line.) 

 

2) The image file selection window appears. Select the image file to attach → Click the 'Open' button. 

 

3) The image attachment window appears. 



 

󰋮 Image Location: Displays the path where the image file is stored. 

 

󰋮 Image Save Path: If necessary, click the > button to choose how to save the image path 

 

∎ Full Path: Displays the full path of the image. Use this option if the attached image is stored in a folder 

different from the current drawing. 

 

∎ Relative Path: Displays the path of the image relative to the folder where the current drawing is stored. Use 

this option if the attached image is stored in a subfolder of the current drawing. 

 

∎ File Name Only: Displays only the name of the attached image. Use this option if the attached image is 

stored in the same folder as the current drawing. 

 

 

󰋮 Use Location File: Automatically attaches the image to the drawing using the settings saved in the location 

file. Enter the TWF file related to the image or select it by clicking the [...] button. 

 

󰋮 Insertion Point: Specify the coordinates where the image will be attached by clicking on the drawing or 

entering the coordinates directly. 



 

󰋮 Size: Specify the size of the attached image by clicking directly on the drawing or entering the width (X) 

and height (Y). Use the 'Maintain Aspect Ratio' option to keep the original aspect ratio of the image. 

 

󰋮 Rotation: Specify the angle to rotate the image by clicking on the drawing or entering the angle directly. 

(Counterclockwise direction is positive.) 

 

󰋮 Use Transparency: Determines whether objects beneath the image will be visible. (Images supporting alpha 

transparency can show at least one transparent color.) 

 

󰋮 Show Clipping Boundary: Choose whether to show the clipping boundary of the image. 

 

4) Click the 'OK' button to start inserting the image. When the message 'Specify insertion point <0.0,0.0,0.0>:' 

appears in the command line, click the insertion point for the image on the drawing or enter the coordinates 

via the keyboard. 

 

5) When the message 'Specify scale or [Unit (U)] <1.0>:' appears, enter the scale. 

6) The image is inserted into the drawing area. 

 

 

Tip: When sharing drawings with external parties, ensure to send the image files along with the drawing. 

If the image files are missing, the images will not be displayed, and only the paths will be shown. 



6-7. Image Manager (Image) 

 

Add, modify, detach, unload, reload, set paths, and change properties of images inserted into the current 

drawing. 

 

1) Menu: Select Insert → Image → Image Manager. (Or type image in the command line.) 

 

2) The image manager window appears. 

 

 

󰋮 Image: To modify overlapping images, click the topmost image in the list. Then select and modify each 

image individually. 

 

∎ Add: Attaches the selected image to a new location in the drawing. 

 

∎ Attach: Attaches an image to the drawing. 

 

∎ Detach: Removes the selected image from the drawing. The image file is not deleted. 

 

∎ Unload: Unloads the selected image, displaying only the path. This is useful if the attached image affects 



system performance. 

 

∎ Reload: Reloads an unloaded image or an image that contains new content. 

 

∎ Clip: Clips the selected image to the desired shape. 

 

∎ View: Opens the selected image in a viewer or editor. 

 

󰋮 Path: Enter a different image file path if necessary. Click [...] to browse for the file. Click 'Set Drawing 

Path' to set a new path. 

 

󰋮 Image Settings: Adjust the brightness, contrast, and fade using the scroll bar or by entering values. The 

fade setting cannot make entities beneath the image visible. 

 

󰋮 Reset: Resets brightness, contrast, and fade values to default settings. 

 

󰋮 Size: Enter the width (X) and height (Y). Select 'Maintain Aspect Ratio' to ensure the width and height are 

adjusted proportionally. 

 

󰋮 Rotation: Enter the angle to rotate the image to the left. 

 

󰋮 Use Transparency: Select to show entities beneath the image. 

 

󰋮 Show Clipping Boundary: Select to toggle the clipping boundary on or off. 

 

 

 

  



6-8. Image Clip (Imageclip) 

 

Clip an image to display only a portion of it. The visible part (or the non-visible part in case of an inverted 

clip) can be in the shape of a rectangle, polygon, or an existing polyline. 

 

1) Menu: Select Insert → Image → Image Clip. (Or type imageclip in the command line.) 

 

2) Select the Image to Clip: When prompted, click the image to be clipped. 

 

3) [ON/OFF/Delete (D)/New Boundary (N)] <New Boundary>: When prompted, press Enter to specify a new 

boundary. 

 

4) [Select Polyline (S)/Polygon (P)/Rectangle (R)/Invert Clip (I)] <Rectangle (R)>: When prompted, enter 'R' 

or press Enter to clip the image in a rectangular shape. 

 

5) Click the area to be clipped. 

 

 

6) The image is clipped, showing only the specified area and hiding the rest. 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



6-9. Layout Baru (Layout) 

 

Add a new layout (in the Layout tab). 

 

1) Menu: Choose Insert → Layout → New Layout. 

2) Enter Layout Name (e.g., Layout3): When prompted, enter the name of the new layout → press Enter. 

3) The layout will be newly added and displayed as a button. 

 

 

 

 

 

 

 

 

 

 

 

  



6-10. Layout Template 

 

Add a new layout (in the Layout tab) based on a template file. 

1) Menu: Choose Insert → Layout → Layout Template. 

2) A template selection window appears. Select the template file → click the 'Open' button. 

 

3) The layout insertion window appears. Select one from the list → click the 'OK' button.

 

4) The newly added layout will be displayed to the right of the existing layouts.

 

 

 

 

 



6-11. Insert Object (Insertobj) 

 

Insert various types of objects into the CADian drawing that are available on the PC being used. 

 

1) Menu: Select Insert → Object. 

 

2) The object insertion window appears. 

 

Create New (N): To insert an object, the corresponding application will open. 

Create from File (F): Select the file of the object you want to insert directly. 

Object Type: Applications that support insertable objects will be displayed. 

Display as Icon (D): The object will be displayed as an icon on the CAD drawing. Double-clicking the icon 

will display the object's information. 

3) Inserting a PDF File 

 

3-1) Select "Create New" → Object Type: Select "Adobe Acrobat Document" → Click the "OK" button. 

 

3-2) A dialog box will appear. Select the PDF file you want to insert → Click the "Open" button.   



 

3-3) Adobe Acrobat Reader will open, displaying the selected PDF file. 

 

 

 

3-4) In the menu of Adobe Acrobat Reader: Click "File" → Select "Exit and Return to Document". 



   

3-5) The selected PDF file will be inserted into the Cadian drawing. 

 

4) Inserting an XLS File 

4-1) Select "Create New" → Object Type: Select "Microsoft Excel 96-2003 Worksheet" → Click the "OK" 

button → MS Excel will launch. 

  

4-2) Enter the desired data, then in the menu: Click "File" → Click "Close". 



 

 

4-3) The Excel object will be inserted into the Cadian drawing. 

   

 

 

5) Inserting a Paint Drawing 

 

5-1) Select "Create New" → Object Type: Select "Paint Drawing" → Click the "OK" button → Paint will 

launch. 

 

5-2) Draw the desired image in Paint, then in the menu: Click "File" → Select "Exit and Return to Document". 



  

5-3) The Paint drawing will be inserted into the Cadian drawing. 

   

  

 

 

 

 

 

  



7. CADian 2026 – Menu - Format 
 

󰋮 Definition of Layers: Imagine drawing shapes on multiple transparent films and viewing them stacked 

together, making the shapes appear as one. Each of these films can be considered a layer. For example, the 

first layer contains objects, the second layer contains dimensions, and the third layer contains text. If you 

turn off the second dimension layer, only the objects and text will be visible. Layers can be turned on/off 

freely for convenience in work, locked to prevent modification/editing, or specified to be excluded from 

printing. 

 

 

 

 



 

 

 

 

 

 

 

 

 

  



7-1. Explorer Layer 

 

Check and change various settings related to layers in CADian. 

 

1) Menu: Select Format → Explorer Layer. (Or type layer in the command line.) 

 

2) The Layer Properties Manager appears. 

 

󰋮 : Displays the current layer. 

 : Shows the Layer Filter Properties window. 

 

:  Creates a new layer group filter. 

: Shows the Layer State Manager window. 

◼  



 

: Creates a new layer. 

: Creates a new layer and freezes it. 

: Deletes a layer. 

: Sets the selected layer as the current layer. 

: Displays layer usage information. 

: Displays the Layer Settings dialog box. 

 

◼ Layer List: Shows the list of layers present in the current drawing.  

 



∎ Status: Indicates the current layer with a √ mark. 

 

∎ Layer Name: Displays the name of the layer. 

 

∎ On/Off: Turns the layer on or off. Click the icon to toggle. When a layer is turned off, objects on that layer 

disappear from the drawing. 

 

∎ Freeze/Unfreeze: Freezes or unfreezes the layer. Click the icon to toggle. When a layer is frozen, objects on 

that layer disappear from the drawing. Unlike turning off a layer, unfreezing a layer regenerates the 

drawing. 

 

∎ Lock/Unlock: Locks or unlocks the layer. Click the icon to toggle. When a layer is locked, objects on that 

layer cannot be edited (deleted, copied, moved, etc.). 

 

∎ Color: Specifies the color of the layer. Click the icon to open the color window and select the desired color. 

  

∎ Linetype: Specifies the linetype of the layer. Click 'Continuous' to open the linetype selection window and 

choose the desired linetype. 



 

   

Lineweight: Specifies the lineweight of the layer. Click the default icon to open the lineweight window and 

select the desired lineweight. 

  

   

∎ Plot Style: Checks the plot style of the layer. 

∎ Plot: Specifies whether the layer will be plotted. Click the  icon to toggle the plot properties. When toggled 

off, objects on that layer will not be printed. 

∎ New VP Freeze: Sets the layer to be automatically frozen in new viewports. Click the icon to toggle the 

VP freeze property. 

 

  



7-2. Layer State Manager (Layerstate) 

 

Check, restore, create, and edit layer states in CADian. 

 

1) Menu: Select Format → Layer State Manager. (Or type layerstate in the command line.) 

 

2) The Layer State Manager appears. 

 

 

New: Displays the New Layer State window where you can enter a name and description to create a new layer 

state. The newly created layer state will be displayed in the layer state list. 

 

 



 

Edit: a layer state from the list. The Layer State Edit window appears, where you can change layer settings 

in the same way as in the Layer Properties Manager. 

 

∎ Add a layer :   button to display the layer selection window. Select the name of the layer you want to add, 

then click the OK button. 

  

∎ Delete a layer: Select the layer you want to delete, then click the  button to immediately delete that layer. 

 

󰋮 Save : Save the layer state. When the overwrite layer state window appears, click the 'Yes' button. 

 



󰋮 Rename : Rename the layer state. The rename layer state window appears. After modifying the name and 

description, click the 'OK' button to change the layer state name. 

 

 

  

󰋮 Delete : Delete a layer state. Select the layer state from the list → Click the 'Delete' button, and a deletion 

confirmation message will appear. Click 'YES' to immediately delete the layer state, which will then 

disappear from the list.  

 

󰋮 Import : Import layer state settings exported to a storage device (HDD, USB, etc.). When the import layer 

state window appears, select a folder → Click the ‘Open’ button to import the layer settings file. 

 

󰋮Export : Export layer state settings to a storage device (HDD, USB, etc.). Specify the folder and click the 



'Save' button.   

 

  

󰋮 Restoring layer properties: You can select the items you want to restore from the layer properties. Items 

with a  will not be excluded from the restoration. 

 

  

∎ Select All : Change all items to display . 

 

∎ Clear All : Change all items to display . 

 



󰋮 Restore : Restore the layer state settings to the current CADian drawing. Saved layer state settings can be used in 

other drawings. 

 

 

 

 

 

 

 

 

  



7-3. Set Layer by Entity (Laymcur) 

 

Change the current layer in CADian to the layer of a selected entity. 

 

1) Menu: Select Format → Layer Tools → Set Layer by Entity. (Or type laymcur in the command line.) 

 

2) Select entity to set as current layer: When prompted, click the entity whose layer you want to set as the 

current layer. 

 

 

3) If you select the red circle, which belongs to Layer 1, the current layer will immediately change to Layer 

1, and a √ mark will appear in front of Layer 1. 

 

  



7-4. Layer Walk (Laywalk) 

 

View objects on specific layers in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer Walk. (Or type laywalk in the command line.) 

 

2) The Layer Walk window appears. Click the layer you want to inspect. 

 

 

3) Only objects on the selected layer will be displayed. 

 

 

  



7-5. Set to ByLayer (Setbylayer) 

 

Change the properties of selected objects in CADian to ByLayer. 

 

1) Menu: Select Format → Layer Tools → Set to ByLayer. (Or type setbylayer in the command line.) 

 

2) Press Enter to set properties or select entities to set to ByLayer: When prompted, select the entities to 

change and press Enter. 

 

 

3) Change from ByBlock to ByLayer? [Yes(Y)/No(N)] <Yes>: When prompted, press Enter. 

 

4) Include blocks? [Yes(Y)/No(N)] <Yes>: When prompted, press Enter. 

 

5) The color of the selected objects will change to the ByLayer color, becoming yellow. 

 

 

  



7-6. Match Layer (Laymch) 

 

Change the layer of a selected entity to match another layer in CADian. 

 

1) Menu: Select Format → Layer Tools → Match Layer. (Or type laymch in the command line.) 

 

2) Select object to change: When prompted, select the entities to change the layer and press Enter (e.g., select 

the yellow circle on Layer 2). 

 

 

3) Select object on destination layer or [Last(L)/Name(N)]: When prompted, select the source entity (e.g., the 

red circle on Layer 1) and press Enter. 

 

4) The object on Layer 2 will change to Layer 1, and its color will change to red. 

 

 

 

 

 

  



7-7. Copy to Layer (Copytolayer) 

 

Copy selected entities to a new layer in CADian. 

 

1) Menu: Select Format → Layer Tools → Copy to Layer. (Or type copytolayer in the command line.) 

 

2) Select objects to copy: When prompted, select the entities to copy and press Enter (e.g., select the yellow 

circle on Layer 2). 

 

 

 

3) Select object on destination layer or [Last(L)/Input(T)/Name(N)] <Name>: When prompted, select the 

source entity (e.g., the red circle on Layer 1) and press Enter. 

 

4) Specify base point or [Displacement(D)/Exit(X)] <Exit(X)>: When prompted, select the base point for the 

copy. 

 

5) Specify second point of displacement or <use first point as displacement>: When prompted, click the 

location for the copy. 

 

  



7-8. Layer Isolate (Layiso) 

 

Display only the selected layer in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer Isolate. (Or type layiso in the command line.) 

 

2) Select objects on the layer to isolate or [Settings(S)]: When prompted, select the entities on the layer to 

isolate and press Enter (e.g., select the red circle on Layer 1). 

   

Before separating the drawing layers   After separating the drawing layers 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



7-9. Layuniso 

 

Turn off layer isolation in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer Unisolate. (Or type layuniso in the command line.) 

 

2) All objects will be displayed immediately as layer isolation is turned off. 

    

Before ungrouping the drawing layers      After ungrouping the drawing layers 

 

 

 

 

 

 

 

 

 

 

 

 

  



7-10. Layer Off (Layoff) 

 

Turn off a specific layer in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer Off. (Or type layoff in the command line.) 

 

2) Click to select the object on the layer to turn off (e.g., click the yellow circle on Layer  

 

 

 

3) The objects on the selected layer will be turned off and disappear from the screen. 

 

 

 

 

 

  



7-11. Layer On (Layon) 

 

Turn on all layers that were turned off in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer On. (Or type layon in the command line.) 

 

2) All layers will be turned on immediately. 

 

 

 

 

 

 

 

 

 

 

 

 

  



7-12. Layer Freeze (Layfrz) 

 

Freeze the selected layer in CADian. When a layer is frozen, objects on that layer disappear from the drawing. 

Unfreezing requires regenerating the drawing. 

 

1) Menu: Select Format → Layer Tools → Layer Freeze. (Or type layfrz in the command line.) 

 

2) Select objects on the layer to freeze in all viewports: When prompted, click the entities on the layer to 

freeze. 

    

Before freezing the drawing layer   After freezing the second drawing layer 

 

 

 

 

 

 

  



7-13. Layer Thaw (Laythw) 

 

Thaw all frozen layers in the drawing. 

 

1) Menu: Select Format → Layer Tools → Layer Thaw. (Or type laythw in the command line.) 

 

2) All frozen layers will be thawed immediately, and all objects will be displayed. 

 

   

Before thawing the drawing layer       After thawing the drawing layer 

 

 

 

 

 

 

 

 

 

  



7-14. Layer Lock (Laylck) 

 

Lock the selected layer in CADian. When a layer is locked, objects on that layer cannot be edited (deleted, 

copied, moved, etc.). 

 

1) Menu: Select Format → Layer Tools → Layer Lock. (Or type laylck in the command line.) 

 

2) Select objects on the layer to lock: When prompted, select the entities on the layer to lock. 

 

3) The selected layer will be locked immediately, and objects on that layer will be displayed in a faded color. 

 

 

 

 

 

 

 

 

 

 

 

  



7-15. Layer Unlock (Layulk) 

 

Unlock the selected layer in CADian. 

 

1) Menu: Select Format → Layer Tools → Layer Unlock. (Or type layulk in the command line.) 

 

2) Select objects on the layer to unlock: When prompted, select the entities on the layer to unlock. 

 

3) The selected layer will be unlocked immediately, and objects will be displayed in their original color. 

 

 

 

 

 

 

 

 

 

 

  



7-16. Layer Merge (Laymrg) 

 

Merge selected layers in CADian. The current layer cannot be merged. 

 

1) Menu: Select Format → Layer Tools → Layer Merge. (Or type laymrg in the command line.) 

 

2) Select objects on the layers to merge or [Name(N)]: When prompted, select the entities on the layers to 

merge and press Enter (e.g., select objects on Layers 1 and 2). 

 

 

3) Select object on destination layer or [Name(N)]: When prompted, select the entity on the destination layer 

(e.g., select an object on Layer 0). 

 

4) Do you want to continue? [Yes(Y)/No(N)] <Yes>: When prompted, type "Yes" and press Enter. 

 

 

5) The selected layers will be merged, and the objects will change to the destination layer with its color. 

 

 

  



7-17. Layer Delete (Laydel) 

 

Delete the layer of selected entities in CADian. The current layer cannot be deleted. 

 

1) Menu: Select Format → Layer Tools → Layer Delete. (Or type laydel in the command line.) 

 

2) Select objects on the layers to delete: When prompted, click the entities on the layers to delete. The objects 

on the selected layers will be deleted immediately. Press Enter or ESC to complete the deletion. 

 

 

3) If you select an object on the current layer, a message will appear saying it cannot be deleted. Select an 

object on another layer to delete. 

 

 

 

 

 

  



7-18. Color 

 

Specify the color to be used for new objects in the drawing. 

 

1) Menu: Select Format → Color → Select Color. (Or type color in the command line.) 

 

2) The color window appears. 

 

 

󰋮 Standard Colors: Basic CAD colors like red, yellow, green, etc., are available. Click the desired color, 

which will be displayed at the bottom. 

 

 

 

󰋮 Grayscale: Various shades of gray are available. Click the desired shade, which will be displayed at the 

bottom. 

 

   

󰋮 Logical Colors: Bylayer and Byblock colors are supported. Click the desired color, which will be displayed 

at the bottom. 



 

  

󰋮 Full Color Palette: The full color palette is available. Click the desired color, which will be displayed at the 

bottom. 

 

  

󰋮 True Color Tab: Up to 65,536 true colors are supported. Click the desired color, and its color code will be 

displayed in the lower-right corner. Adjust the numbers to fine-tune the color. 

 

 

  

 

 

 



󰋮 Color Book Tab: Choose colors from the color book. 

 

󰋮 Color Book Editor: Click the 'Color Book Editor' button to open the editor window, where you can save 

your desired color with a specified name. 

 

 

3) Select cyan in the color window and click 'OK.' The current color will change, and the selected color will 

be reflected in the Properties window. 



 

4) Draw objects in the specified color. 

 

 

 

 

 

 

 

 

  



7-19. Color, White 

 

Change the color to white for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → White. 

 

2) The color changes to white. 

 

 

 

 

 

 

 

 

 

 

  



7-20. Color, Blue 

 

Change the color to blue for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Blue. 

 

2) The color changes to blue. 

 

 

 

7-21. Color, Cyan 

 

Change the color to cyan for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Cyan. 

2) The color changes to cyan. 

 

 

  



7-22. Color, Green 

 

Change the color to green for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Green. 

2) The color changes to green. 

 

 

7-23. Color, Yellow 

 

Change the color to yellow for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Yellow. 

2) The color changes to yellow. 

 

 

  



7-24. Color, Red 

 

Change the color to red for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Red. 

2) The color changes to red. 

 

 

7-25. Color, Magenta 

 

Change the color to magenta for new objects in the drawing. 

 

1) Select the objects first, then go to Menu: Format → Color → Magenta. 

2) The color changes to magenta. 

 

 

  



7-26. Color, Bylayer 

 

Change the color for new objects in the drawing to Bylayer. The color will automatically change to the color 

assigned to the layer. 

 

1) Select the objects first, then go to Menu: Format → Color → Bylayer. 

2) The color changes to Bylayer. 

3) When drawing a circle on Layer 0 with color white, on Layer 1 with color red, and on Layer 2 with color 

yellow, the objects will be drawn accordingly. 

 

 

 

7-27. Color, Byblock 

 

Change the color for new objects in the drawing to Byblock. 

 

1) Select the objects first, then go to Menu: Format → Color → Byblock. 

 

2) The color changes to Byblock. 

 

  



7-28. Linetype 

 

Set the type of line to be used when drawing lines. 

 

1) Menu: Select Format → Linetype. (Or type linetype in the command line.) 

 

2) In the Linetype Manager, select the desired linetype → Click the 'Set Current' button and then click 'OK' 

to change the linetype. 

 

 

󰋮 Load: The Linetype Load or Reload window appears. Click the File button at the top left → Select the 

linetype file *.lin to load → Select the desired linetype → Click 'OK' to add the selected linetype to the 

list. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



7-29. Lineweight 

 

Set the lineweight (thickness) to be used when drawing lines. 

 

1) Menu: Select Format → Lineweight. (Or type lineweight in the command line.) 

 

2) In the Lineweight Settings window, select the desired lineweight → Click 'Apply and Close' to change the 

lineweight. 

 

󰋮 Units: Specify the units for lineweight. 

 

󰋮 Display Lineweight : Check 'Display Lineweight' to reflect the lineweight in the drawing. (Note: This may 

make the drawing look cluttered as it displays the same thickness regardless of zoom level, so it is not 

recommended.) 

 

󰋮 Adjust Display Scale: Change the display scale of the lineweight. 

 

 

 

 

 

  



7-30. Text Style Manager (Style) 

 

Set text styles, including size, font, and slant, in CADian. 

 

1) Menu: Select Format → Text Style Manager. (Or type style in the command line.) 

 

2) The Text Style Manager window appears. 

 

 

󰋮 Current Text Style: Shows the name of the style currently used for text. 

 

󰋮 Style: Displays a list of text styles, allowing you to select the style to modify. 

 

󰋮 Preview: Shows a preview of the current text style. 

 

  

  

 

 

 



󰋮 Font: Select from various fonts installed on your computer (e.g., Dotum, Gulim, Barun Gothic). 

       

Arial              Bahnschrift        Forte              David 

 

󰋮 Size: Predefine the height (size) of the text. Setting it to 0 allows the size to adjust dynamically according 

to the drawing settings. 

 

󰋮 Effects: Modify text properties such as shape, width ratio, and slant angle. 

 

∎ Backward: Displays the text backward. 

  

∎ Upside Down: Displays the text upside down. 

  

∎ Width Factor: Adjusts the width ratio of the text. 

     

Width ratio: 1     Width ratio: 2 

∎ Oblique Angle: Sets the slant angle of the text. 

 

    

Obliquing Angle: 0  Obliquing Angle: 30 

󰋮 Set Current: Sets the selected text style from the list as the current text style. 

󰋮 New: Click the 'New' button → Enter the name for the new style → Click 'OK' to create a new text style. 

 

󰋮 Delete: Deletes the selected text style from the list. 

 

󰋮 Rename: Click the 'Rename' button → Enter a new name for the style → Click 'OK' to change the text style 

name. 



 

  

  



7-31. Dimension Style Manager (Dimstyle) 

 

Set dimension styles, including color, arrow shape, text size, and font. 

 

1) Menu: Select Format → Dimension Style. (Or type dimstyle in the command line.) 

 

2) The Dimension Style Manager window appears. 

 

 

󰋮 Current Dimension Style: Displays the currently used dimension style. 

 

󰋮 Preview: Shows a preview of the dimension with the current style settings. 

 

󰋮 Show Style View Options: Choose to display only the current dimension style or all styles. 

 

󰋮 Set Current: Sets the selected dimension style from the list as the current style. 

 

󰋮 New: Click the 'New' button → Enter a new style name → Select a starting style → Click 'Continue' → 

The New Dimension Style window appears, where you can modify various settings. Click 'OK' to add 

the new dimension style. 



 

  

󰋮 Rename: Renames the dimension style. 

 

󰋮 Modify: Edits the details of the selected dimension style from the list. 

 

󰋮 Override: Shows the Override dialog box to set temporary overrides for the dimension style. 

 

3) Modify Dimension Style 

 

3-1) Select the dimension style to modify from the list → Click 'Modify' → The Modify Dimension Style 

window appears. 



 

󰋮 Lines Tab: Modify settings related to dimension lines and extension lines. 

 

∎ Dimension Lines: Modify dimension line settings. 

 

⋄ Color: Change the color of the dimension lines. 

 

⋄ Linetype: Change the linetype of the dimension lines. 

 

⋄ Lineweight: Change the lineweight of the dimension lines. 

 

⋄ Extend beyond ticks: Change the length that dimension lines extend beyond the ticks. 

 

⋄ Baseline spacing: Change the spacing between baseline dimensions. 

 



⋄ Suppress: Suppress the dimension lines to make them invisible. 

 

∎ Preview: Preview the dimension settings. 

  

  

∎ Extension Lines: Modify extension line settings. 

 

⋄ Color**: Change the color of the extension lines. 

 

⋄ Linetype Ext. Line 1: Change the linetype of the first extension line. 

 

⋄ Linetype Ext. Line 2: Change the linetype of the second extension line. 

 

⋄ Lineweight: Change the lineweight of the extension lines. 

 

⋄ Extend beyond dim lines: Change the length that extension lines extend beyond the dimension lines. 

 

⋄ Offset from origin: Change the offset distance from the origin for extension lines. 

 

⋄ Suppress: Suppress the extension lines to make them invisible. 

 

󰋮 Symbols and Arrows Tab: Modify settings related to symbols and arrows. 

 

∎ Arrowheads: Modify arrowhead settings. 

⋄ First: Change the shape of the first arrowhead. 



  

  

⋄ Second: Change the shape of the second arrowhead. 

 

⋄ Leader: Change the shape of the leader arrowhead. 

 

⋄ Arrow size: Change the size of the arrowheads. 

 

∎ Center Marks: Modify center mark settings. 

 

∎ Arc Length Symbol: Set the placement of the arc length symbol. 

 

󰋮 Text Tab: Modify settings related to dimension text. 

 

∎ Text Appearance: Set the appearance of dimension text. 

⋄ Text Style: Select a text style for dimension text from existing text styles. 

 

⋄ Text Color: Change the color of the dimension text. 

 

⋄ Fill Color: Change the background color of the dimension text. 

 

⋄ Text Height: Specify the height (size) of the dimension text. Note that the text size will change only if the 

text size in the text style is set to 0. 



 

⋄ Draw Frame Around Text: Display a frame (rectangle) around the dimension text. 

 

∎ Text Placement: Set the placement of dimension text. 

 

⋄ Vertical: Set the vertical placement of dimension text. 

  

  

⋄ Horizontal: Set the horizontal placement of dimension text. 

  

  

⋄ View Direction: Set the view direction for dimension text. 

 

⋄ Offset From Dim Line: Set the distance of the dimension text from the dimension line. 

∎ Text Alignment: Set the alignment method for dimension text. 

  

  

󰋮 Fit tab  

 

∎ Fit Options: Set how text and arrows are placed between extension lines. 



  

  

∎ Text Placement: Set the placement of text when it is not in the default position. 

  

  

∎ Scale for Dimension Features: Set the scale for dimension features. 

  

  

∎ Fine Tune: Set additional options for the placement of dimensions. 

  

󰋮 Primary Units Tab 

∎ Linear Dimensions: Set the units for linear dimensions. 

⋄ Unit Format: Change the unit format for linear dimensions. 

  

⋄ Precision: Change the precision for linear dimensions. The unit of precision changes depending on the unit 

format. 



         

⋄ Decimal Separator: Set the decimal separator. 

  

⋄ Rounding: Set the rounding value. 

⋄ Prefix: Set the prefix for linear dimensions. 

⋄ Suffix: Set the suffix for linear dimensions. 

 

∎ Measurement Scale: Set the scale factor for measurement values used in linear dimensions. 

∎ Zero Suppression: Set whether to suppress zero values in linear dimensions. 

  

∎ Angular Dimensions: Set the units and precision for angular dimensions. 

 

  

∎ Zero Suppression: Set whether to suppress zero values in angular dimensions.  

 

  

󰋮 Alternate Units Tab 

 

Alternative unit display: Alternative unit display is checked on, alternate units will be displayed when 



creating dimensions. (This option must be checked on to activate the items below.) 

 

∎ Alternate Units: Set the format, precision, prefix, and suffix for alternate units in dimensions. 

 

  

∎ Zero Suppression: Set whether to suppress zero values in alternate unit dimensions. 

 

  

∎ Placement: Set the placement position of the alternate units. 

 

 

 

󰋮 Tolerances Tab 

∎ Tolerance Format: Set the method of displaying tolerances, precision, upper value, lower value, etc. 



 

  

∎ Alternate Unit Tolerances: Set the method of displaying tolerances, precision, upper value, lower 

value, etc. for alternate units. 

 

  

Reset page values to default: You can reset the settings of the current tab. 

Reset all values to default: You can reset all values in the dimension settings. 

 

 

 

 

 

  



7-32. Point Style (Ddptype) 

 

Set the style, size, and other attributes of points. 

 

1) Menu: Select Format → Point Style. (Or type ddptype in the command line.) 

 

2) The Point Style window appears. After specifying the desired point style and size, click the 'OK' button to 

draw points with the selected style and size. 

 

 

󰋮 Select Point Style: Click to select the desired point style from the list of point styles below. 

 

󰋮 Point Size: Specify the size of the point to be displayed on the screen. 

- Selecting 'Set size relative to the screen ' creates points with relative size. When regenerated, the points will 

be resized. 

- Selecting 'Set size in absolute units' sets the size in absolute units, and the size will not change upon 

regeneration. 

 



  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



7-33. Drawing Units (Ddunits) 

 

Set the units, precision, etc., for the drawing. 

 

1) Menu: Select Format → Drawing Units. (Or type ddunits in the command line.) 

 

2) The Drawing Units window appears. After setting the units, precision, and insertion units for objects, click 

the 'OK' button to apply the specified units and precision to the drawing. 

 

 

󰋮 Length: Set the format for measuring units, with precision varying by unit. 

 

∎ Architectural: Displays in inches and feet. 

  

  

∎ Engineering: Displays in millimeters, centimeters, etc. 



  

  

∎ Scientific: Displays using exponents (powers of ten). 

  

 

∎ Fractional: Displays in feet and fractional inches. 

  

 

∎ Decimal: Displays length in decimal format. 

   

 

󰋮 Angle: Set the current angle format and precision, with precision varying by unit. 

 

 

 

 

 



 

∎ Grads: Displays in grad units. 

  

 

∎ Degrees/Minutes/Seconds: Displays in degrees, minutes, and seconds. 

  

  

∎ Radians: Displays in radian units. 

  

  

∎ Decimal Degrees: Displays in decimal degree units. 

  

 

∎ Surveyor's Units: Displays in a mix of bearings (E, W, S, N) and degrees, minutes, seconds. 

  



∎ Clockwise: Sets the angle to be measured clockwise. The default is counterclockwise. 

        

  Counterclockwise (default)   Clockwise 

 

󰋮 Insertion Scale: Adjusts the dimension units for blocks and images inserted into the current drawing.  

 

 

 

󰋮 Sample Output: Provides a preview of the current unit and angle settings. 

 

 

 

 

󰋮 Lighting: Adjusts the intensity units for lighting in the current drawing. 



 

 

  

󰋮 Direction: Displays the direction adjustment window, allowing you to specify the base angle. 

 

  

 

 

 

 

 

  



8. CADian 2026 Menu - Tools 

 

8-1. Quick Select (Qselect) 

 

Quickly select desired objects in the drawing. 

 

1) Menu: Select Tools → Quick Select. (Or type qselect in the command line.) 

 

2) The Quick Select window appears. 

 

 

 

󰋮 Object Type: Select the type of object you want to select (e.g., lines, circles, text). 

 

󰋮 Properties: Further specify the object's properties (e.g., white lines, circles on Layer 0, text in the standard 

style). 

 

󰋮 Operator: Use operators to filter the properties. 

 

󰋮 Value: Specify the value corresponding to the property you want to select. 



 

Select only polylines. 

 

Select lines that are on the same layer as layer 0. 

 

Select only circles with a diameter of 10. 

 

 

 

 

  



8-2. Draw Order, Bring to Front (Draworder, Front) 

 

Bring selected objects to the front when objects overlap so they are not obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Bring to Front. 

 

2) Select objects to bring to front: When prompted, select the objects to bring to the front and press Enter. 

 

3) The previously obscured objects are brought to the front and are no longer obscured by other objects. 

 

The text is hidden by the object.  

 

Set the text to come to the front. 

 

 

 

 

  



8-3. Draw Order, Send to Back (Draworder, Back) 

 

Send selected objects to the back when objects overlap so they are obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Send to Back. 

 

2) Select objects to send to back: When prompted, select the objects to send to the back and press Enter. 

 

3) The previously front objects are sent to the back and are obscured by other objects. 

 

 

The text is hidden by the object.  

 

Set the blue ellipse to go to the back. 

 

 

 

 

  



8-4. Draw Order, Bring Above (Draworder, Above) 

 

Bring selected objects above a specific object so they are not obscured by it. 

 

1) Menu: Select Tools → Draw Order → Bring Above. 

 

2) Select objects to bring above: When prompted, select the objects to bring above and press Enter. 

 

3) Select reference object: When prompted, select the reference object and press Enter. 

 

4) The selected objects are brought above the reference object. 

 

 

The text is hidden by the object.  

 

The text is above the blue ellipse. 

 

 

 

  



8-5. Draw Order, Send Under (Draworder, Under) 

 

Send selected objects under a specific object so they are obscured by it. 

 

1) Menu: Select Tools → Draw Order → Send Under. 

 

2) Select objects to send under: When prompted, select the objects to send under and press Enter. 

 

3) Select reference object: When prompted, select the reference object and press Enter. 

 

4) The selected objects are sent under the reference object. 

. 

 

The text is displayed above the object.  

 

The text is under the blue ellipse. 

 

 

 

  



8-6. Draw Order, Send Hatches to Back (Hatchtoback) 

 

Send all hatches to the back so they do not obscure other objects. 

 

1) Menu: Select Tools → Draw Order → Send Hatches to Back. 

 

2) All hatches are immediately sent to the back. 

 

The text is hidden by the object.  

 

 

The text appears as the hatch is sent to the back. 

 

 

 

 

 

  



8-7. Draw Order, Bring Text to Front (Texttofront) 

 

Bring all text to the front so it is not obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Bring Text to Front. 

 

2) All text is immediately brought to the front. 

 

The text is hidden by the object.  

 

The text appears as it is brought to the front. 

 

 

 

 

 

  



8-8. Draw Order, Bring Leaders to Front (Texttofront, Leaders) 

 

Bring all leaders to the front so they are not obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Bring Leaders to Front. 

 

2) All leaders are immediately brought to the front. 

 

The leader is hidden by the object.  

 

The leader appears as it is brought to the front. 

 

 

 

 

 

 

 

  



8-9. Draw Order, Bring Dimensions to Front (Texttofront, Dimension) 

 

Bring all dimensions to the front so they are not obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Bring Dimensions to Front. 

 

2) All dimensions are immediately brought to the front. 

 

The dimension is hidden by the object. 

 

The dimension appears as it is brought to the front. 

 

 

 

 

 

 

 

  



8-10. Draw Order, Bring All Annotations to Front (Texttofront, All) 

 

Bring all text, leaders, and dimensions to the front so annotations are not obscured by other objects. 

 

1) Menu: Select Tools → Draw Order → Bring All Annotations to Front. 

 

2) All annotations (text, leaders, dimensions) are immediately brought to the front. 

 

The annotation is hidden by the object.  

 

All annotations are brought to the front, making them visible. 

 

 

 

 

 

  



8-11. Distance (Dist) 

 

Check the distance between two points on objects. 

 

1) Menu: Select Tools → Inquiry → Distance. (Or type dist in the command line.).) 

 

2) Specify first point: When prompted, click the first point for distance measurement. 

 

 

3) Specify second point: When prompted, click the second point for distance measurement. 

 

 

4) The distance between the two points is displayed in the command bar. 

 

  



8-12. Area 

 

Check the area of objects like circles, rectangles, and closed polylines. 

 

1) Menu: Select Tools → Inquiry → Area. (Or type area in the command line.) 

 

2) [Entity(E)/Add(A)/Subtract(S)]/<Specify first point>: When prompted, type e to select an entity and then 

click the object to check its area. 

 

3) The area of the object is displayed in the command bar. 

 

 

 

 

 

 

 

 

 

 

  



8-13. ID Point (Idpoint) 

 

Check the coordinates of a specified point. 

 

1) Menu: Select Tools → Inquiry → ID Point. (Or type idpoint in the command line.) 

 

2) Specify point: When prompted, click the point to check its coordinates. 

 

 

3) The coordinates of the point are displayed in the command bar. 

 

 

 

 

 

 

 

 

 

 

 

  



8-14. List  

 

Check the properties of an object. 

 

1) Menu: Select Tools → Inquiry → List. (Or type list in the command line.) 

 

2) [Scroll(SC)/Sort(SO)/Trace(T)]/<Select objects to list>: When prompted, click the object to check its 

properties and press Enter. 

 

 

3) The properties of the object are displayed in the command bar. 

 

 

  



8-15. Drawing Status (Status) 

 

Check the properties of the drawing. 

 

1) Menu: Select Tools → Inquiry → Drawing Status. (Or type status in the command line.) 

 

2) The properties of the drawing are displayed in the command bar. 

 

 

  



8-16. Time 

 

Check the date and time of the current drawing. 

 

1) Menu: Select Tools → Inquiry → Time. (Or type time in the command line.) 

2) The time-related information of the drawing is displayed in the command bar. 

 

  



8-17. Recscript 

 

Record a script to automate repetitive tasks. 

 

1) Menu: Select Tools → Action Recorder → Record Script. (Or type recscript in the command line.) 

2) The Script Recording window appears. Enter the script file name and click 'Save.' 

 

 

3) Perform the tasks to be recorded (e.g., draw two circles). 

 

4) To stop recording, select Stop Script Recording. 

 

  



8-18. Stop script 

 

Stop recording the script and save the recorded actions to disk. 

 

1) Menu: Select Tools → Action Recorder → Stop Script. (Or type stopscript in the command line.) 

2) Script recording stops immediately, and the recorded actions are saved to the specified ‘file name.scr.’ 

  



8-19. Script 

 

Load and run a saved script. 

 

1) Menu: Select Tools → Action Recorder → Run Script. (Or type script in the command line.) 

 

2) The Run Script window appears. Select the script (scr) file to run and click 'Open.' 

   

3) The saved script is executed immediately, and the recorded tasks are carried out. 

 

  



8-20. Menu load 

 

Load or unload menu (cui, mns, mnu files). 

 

1) Menu: Select Tools → Load Menu. (Or type menuload in the command line.) 

 

2) The Customize Load/Unload window appears. 

 

 

3) Search: Select the menu file to load. Click the ‘Search' button to open the file selection window. Choose 

the file type (cui, mns, mnu files) → Click the menu file to select it → Click the 'Open' button. 

   

 

4) Confirm the file name and click 'Load.' 

 

5) The 'Technical Support Team' item is added to the menu. 



 

  



8-21. UCS Explorer (Expucs) 

 

Use the UCS Explorer to configure various settings related to the coordinate system. 

 

1) Menu: Select Tools → User Coordinate System → UCS Explorer. (Or type expucs in the command line.) 

 

2) The CADian Explorer - Coordinate System window appears. 

 

3) Double-click the desired coordinate system to set it as the current coordinate system. A checkmark (√) will 

appear next to it. 

 

 

 

 

  



8-22. Select Predefined UCS (Setucs) 

 

Select a predefined UCS in the User Coordinate System. 

 

1) Menu: Select Tools → User Coordinate System → Select Predefined UCS. 

 

2) The User Coordinate System window appears. Select the UCS you want to change to. 

 

 

 

 

 

 

  



8-23. UCS World (Ucs, World) 

 

Change to the standard (world) UCS coordinate system. 

 

1) Menu: Select Tools → User Coordinate System → UCS World. 

 

2) The coordinate system changes to the standard UCS immediately. 

 

 

 

8-24. UCS Previous (Ucs, Previous) 

 

Change to the previous UCS coordinate system. 

 

1) Menu: Select Tools → User Coordinate System → UCS Previous. 

 

2) The coordinate system changes to the previous UCS immediately. 

 

 

 

 

 

 

 

 

 

 



8-25. UCS Entity (Ucs, Entity) 

 

Change the UCS based on a selected entity. 

 

1) Menu: Select Tools → User Coordinate System → UCS Entity. 

2) Select entity for UCS definition: When prompted, select the entity to base the UCS on. The UCS changes 

to align with the selected entity. 

     

 

 

8-26. UCS View (Ucs, View) 

 

Change the UCS based on the current view. 

 

1) Menu: Select Tools → User Coordinate System → UCS View. 

2) The UCS changes immediately based on the current view. 

 

 

  



8-27. UCS Origin (Ucs, Origin) 

 

Change the origin of the UCS. 

 

1) Menu: Select Tools → User Coordinate System → UCS Origin. 

2) [World(W)]/Origin <1549.5737,31.7175,0>: When prompted, click to specify the UCS origin, or specify 

the coordinates manually using absolute or relative coordinates. 

3) The origin of the UCS is changed, and the UCS icon is displayed at the new origin. 

 

 

 

8-28. UCS Z Axis Vector (Ucs, Zaxis) 

 

Change the Z axis of the UCS. 

 

1) Menu: Select Tools → User Coordinate System → UCS Z Axis Vector. 

2) Origin <0,0,0>: When prompted, click to specify the UCS origin. 

3) Point on positive Z axis <10.6078,16.1813,1>: When prompted, click to specify a point on the positive Z 

axis. The UCS is changed immediately. 

 

  



8-29. UCS 3 Point (Ucs, 3p) 

 

Change the UCS using three points. 

 

1) Menu: Select Tools → User Coordinate System → UCS 3 Point. 

 

2) New origin <0,0,0>: When prompted, click to specify the UCS origin. 

 

3) Point on positive X axis <-1,0,0>: When prompted, click to specify a point on the X axis. 

 

4) Point on positive Y axis <0,0,1>: When prompted, click to specify a point on the Y axis. The UCS is 

changed immediately. 

 

 

 

  



8-30. UCS X (Ucs, X) 

 

Rotate the UCS around the X axis. 

 

1) Menu: Select Tools → User Coordinate System → UCS X. 

2) Enter rotation angle about X axis <90>: When prompted, enter the angle to rotate the UCS around the X 

axis. The UCS rotates immediately. 

 

     

Before Rotation on X-axis           Rotate 90 degrees about the X-axis 

 

8-31. UCS Y (Ucs, Y) 

 

Rotate the UCS around the Y axis. 

 

1) Menu: Select Tools → User Coordinate System → UCS Y. 

2) Enter rotation angle about Y axis <90>: When prompted, enter the angle to rotate the UCS around the Y 

axis. The UCS rotates immediately. 

   

Before Rotation on Y-axis                   Rotate 90 degrees about the Y-axis 

  



8-32. UCS Z (Ucs, Z) 

 

Rotate the UCS around the Z axis. 

 

1) Menu: Select Tools → User Coordinate System → UCS Z. 

 

2) Enter rotation angle about Z axis <90>: When prompted, enter the angle to rotate the UCS around the Z 

axis. The UCS rotates immediately. 

      

Before Rotation on Z-axis                      Rotate 90 degrees about the Z-axis 

 

  



8-33. Write Block to Disk (Wblock) 

 

Save a block to disk. 

 

1) Menu: Select Tools → Write Block to Disk. (Or type wblock in the command line.) 

 

2) The Write Block window appears. 

 

 

󰋮 Source: Select the source of the objects to save as a block (Block, Entire Drawing, Objects). 

 

  

󰋮 Object Item: Click the ' ' object selection button to select the objects to save as a block on the disk. 

 

󰋮 Object Item: Click the ' ' quick select button to use the quick select function. 



 

󰋮 Choose whether to convert the objects after saving them to disk as a block. 

 

∎ Retain: Keeps the objects unchanged after saving. 

∎ Convert to Block: Converts the objects to a block after saving. 

 

∎ Delete from Drawing: Deletes the objects after saving. 

 

󰋮 Base Point Item: Click the ' ' point selection button to specify the base point when saving as a block on 

the disk. Alternatively, enter the coordinates directly below. 

 

󰋮 Specify the file name when saving a block to disk in the Destination section. 

 

∎ Click the button to specify the file name and version. 

 

󰋮 Insertion Unit: Specify the unit when saving as a block on the disk. Units include millimeters, meters, 



kilometers, inches, etc. 

 

  

  

  

  



8-34. Reference Edit (Refedit) 

 

Edit a block. 

 

1) Menu: Select Tools → Edit Block or Xref → In-place Edit. (Or type refedit in the command line.) 

2) The Reference Edit window appears. 

 

 

󰋮 Reference Identification tab: Provides a list of blocks and a preview window. 

 

∎ Reference Name: Lists block names, allowing you to click and select the block you want to edit. 

 

∎ Preview: Displays a preview of the selected block. 

 

󰋮 Settings tab: Configure detailed settings for reference editing. 

  

3) Click the desired block in the list and then click 'OK.' 

 

4) You enter the reference edit mode, where non-block objects appear dimmed. 



 

  



8-35. Add to Workset (Refset, Add) 

 

Add objects to the block's work set during block editing. 

 

1) Menu: Select Tools → Edit Block or Xref → Add to Workset. 

 

2) Select objects to add to the work set: When prompted, click the objects to add to the block's work set and 

press Enter. 

 

3) The selected objects are added to the block's work set, and the previously dimmed objects become visible. 

 

Ellipse on the right: Before adding to work set  

 

Added to the work set 

  



8-36. Remove from Workset (Refset, Remove) 

 

Remove objects from the block's work set during block editing. 

 

1) Menu: Select Tools → Edit Block or Xref → Remove from Workset. 

 

2) Select objects to remove from the work set: When prompted, click the objects to remove from the block's 

work set and press Enter. 

 

3) The selected objects are removed from the block's work set and appear dimmed. 

         

Right ellipse: Before adding to work set            Removed from the work set 

 

  



8-37. Close Reference Edit (Refclose) 

 

Finish editing a block. 

 

1) Menu: Select Tools → User Coordinate System → Close Reference Edit. (Or type refclose in the 

command line.) 

 

2) Enter option [Save(S)/Discard Changes(D)] <Save>: When prompted, type 'S' to save or press Enter to 

attempt saving. 

 

3) Save All Reference Edits: A message appears. Click 'Save' to complete the save operation. 

 

4) Once the block editing is saved, you return to the original CAD drawing. 

 

  



8-38. Prompt History Window (F2) 

 

Toggle the prompt history window. 

 

1) Menu: Select Tools → Function Keys → Prompt History Window. (Or press F2 on the keyboard.) 

 

2) The CADian Prompt History window appears. 

 

 

 

 

 

 

 

  



8-39. Entity Snap (F3) 

 

Toggle entity snap. 

 

1) Menu: Select Tools → Function Keys → Entity Snap. (Or press F3 on the keyboard.) 

 

2) Entity snap is toggled immediately, and the icon in the status bar for entity snap settings is also toggled. 

Select 'Entity Snap F3' again to toggle entity snap, and the icon in the status bar for entity snap settings 

is also toggled. 

 

 

8-40. Isometric Cursor (F5) 

 

Toggle the isometric cursor. 

 

1) Menu: Select Tools → Function Keys → Isometric Cursor. (Or press the F5 key on the keyboard.) 

 

2) The isoplane will cycle through Top, Right, and Left views. 

 

 

 

 

 

 

  



8-41. Coordinates (F6) 

 

Toggle the coordinate display in the status bar. When no command is active, only absolute coordinates and 

off states are available. When a command is active, it toggles between absolute, relative, and off states. 

 

1) Menu: Select Tools → Function Keys → Coordinates. (Or press the F6 key on the keyboard.) 

 

2) The coordinate display in the status bar will toggle between absolute coordinates, relative coordinates, and 

off. 

 

 

Absolute coordinates 

 

Relative coordinates 

 

 

  



8-42. Grid Display (F7) 

 

Toggle the grid display in the drawing area. 

 

1) Menu: Select Tools → Function Keys → Grid Display. (Or press the F7 key on the keyboard.) 

 

2) The grid display in the drawing area will toggle. 

 

Grid on  

 

Grid off 

 

 

 

 

 

 

 

  



8-43. Ortho Mode (F8) 

 

Toggle Ortho mode, which restricts cursor movement to vertical and horizontal directions during drawing. 

 

1) Menu: Select Tools → Function Keys → Ortho Mode. (Or press the F8 key on the keyboard.) 

 

2) Ortho mode will toggle. 

 

Orthogonal Mode Off  

 

Orthogonal Mode On 

 

 

 

 

 

 

  



8-44. Snap Mode (F9) 

 

Toggle Snap mode, which restricts cursor movement to specified intervals during drawing. 

 

1) Menu: Select Tools → Function Keys → Snap Mode. (Or press the F9 key on the keyboard.) 

 

2) Snap mode will toggle. 

 

Snap Mode Off  

 

Snap Mode On (Moves only at specified intervals) 

 

 

 

 

 

 

 

 

  



8-45. Polar Tracking (F10) 

 

Toggle Polar Tracking, which constrains cursor movement to specified angles during drawing. 

 

1) Menu: Select Tools → Function Keys → Polar Tracking. (Or press the F10 key on the keyboard.) 

 

2) Polar Tracking will toggle. 

 

 

 

 

 

 

 

 

 

 

 

 

  



8-46. Object Snap Tracking (F11) 

 

Toggle Object Snap Tracking, which tracks and aligns to object snap points during drawing. 

 

1) Menu: Select Tools → Function Keys → Object Snap Tracking. (Or press the F11 key on the keyboard.) 

 

2) Object Snap Tracking will toggle. 

 

 

 

 

 

 

 

 

 

 

  



8-47. Drafting Settings (Dsettings) 

 

Configure drafting-related settings. 

 

1) Menu: Select Tools → Drafting Settings. (Or type dsettings in the command line.) 

 

2) The Drafting Settings dialog box appears. 

 

󰋮 Snap and Grid tab: Configure snap and grid settings. 

 

∎Turun on Snap (F9): Turn Snap On/Off 

 

∎ Snap Spacing: Specify the snap interval. 



 

  

∎ Snap Type: Specify the type of snap. 

 

∎ Turn on Grid: Turn Grid On/Off 

 

∎ Grid Spacing: Specify the grid interval. 

  

∎ Grid Behavior: Configure grid behavior. 

   

󰋮 Polar Tracking tab: Configure polar tracking settings. 

∎Turn on Polar Tracking: Turn Polar Tracking On/Off 

∎ Polar Angle Settings: Specify angles for polar tracking. 



   

Create New : Add a new angle for polar tracking. 

Delete: Remove an angle for polar tracking. 

 

∎ Object Snap Tracking Settings: Configure tracking angles for object snap. 

  

∎ Measure Polar Angle: Set the polar angle. 

 

󰋮 Object Snap tab: Configure object snap settings. 



 

∎Object Snap On: Toggle object snap. 

 

∎Object Snap Tracking On: Toggle object snap tracking. 

 

∎Object Snap Modes: Toggle specific object snap modes. 

 

∎Select All: Enable all object snaps. 

 

∎Clear All: Disable all object snaps. 

 

∎ Endpoint (END): Toggle endpoint snap. 



    

∎ Midpoint (MID): Toggle midpoint snap. 

   

∎ Center (CEN): Toggle center snap. 

 

∎ Node (NOD): Toggle node snap. 

   

 

 



∎ Quadrant (QUA): Toggle quadrant snap. 

  

∎ Intersection (INT): Toggle intersection snap. 

 

  

∎ Extension (EXT): Toggle extension snap. 

  

  



∎ Insertion (INS): Toggle insertion snap. 

   

 

∎ Perpendicular (PER): Toggle perpendicular snap. 

 

 

∎ Tangent (TAN): Toggle tangent snap. 

 

 

∎ Nearest (NEA): Toggle nearest snap. 

    

 



∎ Apparent Intersection (APP): Toggle apparent intersection snap. 

 

 

 

◼ ∎ Parallel (PAR): Toggle parallel snap. 

   

 

 

 

 

  

  



8-48. Options (Config) 

 

Configure overall CADian options. 

 

1) Menu: Select Tools → Options. (Or type options in the command line.) 

 

2) The Options dialog box appears. 

 

󰋮 Files tab 

 

∎ Search Paths: Set support file search paths. 



  

∎ Clicking the '+' button in front of each item will expand the list of sub-items. 

  

∎ Browse, Add: Browse and add search paths. 



  

󰋮 Display tab 

 

∎ Windows Elements: Configure window elements. 

  

  

⋄Color Scheme: Set the color scheme. 

 

⋄Display Scroll Bars: Show scroll bars in drawing windows. 

 

⋄Show Status Bar: Display the status bar. 

 

⋄Use Large Buttons for Toolbars: Use large buttons for toolbars. 

⋄Show Tooltips: Display tooltips. 



 

⋄Show Rollover Tooltips: Display rollover tooltips. 

 

⋄Show File Tabs: Display file tabs. 

 

⋄Colors: Set the colors for file tabs. 

 

⋄ Font: Set the font for the 

command line. 

  

∎ Layout Elements: Configure layout tab elements. 

  

∎ Language: Set the current language and change the language. 



  

 ⋄ Language Settings: Open the Language Settings dialog. 

 

 

∎ Display Resolution: Set display resolution settings. 



  

∎ Display Performance: Configure display performance settings. 

  

∎ Crosshair Size: Set the size of the crosshair. 

 

∎ Fade Controls: Set the fade controls for external references and in-place editing. 

󰋮 Open and Save tab: Configure settings for opening and saving drawings. 

 

 

 

 

 

 



∎ File Save 

   

⋄ Save As: Specify the version for saving drawings. 

 

⋄ Maintain Visual Fidelity: Set visual fidelity for annotative objects. 

 

⋄ Thumbnail Preview Settings: Set thumbnail preview settings. 

 

 

⋄ Incremental Save Percentage: Set the percentage for incremental saves. 



 

∎ File Safety Precautions: Configure file safety settings. 

 

⋄ Automatic Save: Set automatic save intervals. 

⋄ Create Backup Copy: Create a backup copy when saving. 

⋄ Always Perform CRC Validation: Perform CRC validation when saving. 

⋄ Maintain a Log File: Maintain a log file of the text window contents. 

⋄ Security Options: Open the Security Options dialog. 

  

⋄ Display Digital Signatures: Show digital signature information. 

∎ File Open: Set file open options. 

 



  

⋄ Number of Recently Used Files: Set the number of recently used files. 

⋄ Display Full Path in Title: Display the full path and file name in the title. 

 

∎ External References: Configure settings for external references. 

  

∎ ObjectARX Applications: Configure ObjectARX application settings. 

  

󰋮 Plot tab: Configure plot settings. 

 

∎ Default Plot Settings for New Drawings: Set default plot settings. 

   

⋄ Default Output Device: Set the default output device. 

 



⋄ Plot Style Table Settings: Open the Plot Style Table Settings dialog. 

  

⋄ Plot Stamp Settings: Open the Plot Stamp Settings dialog. 

  

⋄ Add or Configure Plotters: Open the Plotter Configuration Manager. 



   

󰋮 User Preferences tab: Configure user preferences. 

∎ Windows Standard Behavior 

 

   

⋄ Double Click Editing: Enable double-click editing. 

⋄ Shortcut Menus in Drawing Area: Display shortcut menus in the drawing area. 



⋄ Right-click Customization: Customize the right-click behavior. 

  

∎ Insertion Scale: Set the insertion scale for blocks. 

 

 ∎ Fields: Display fields in a light background. 

 

⋄ Field Update Settings: Open the Field Update Settings dialog. 

  



∎ Lineweight Settings: Open the Lineweight Settings dialog. 

 

∎ Edit Scale List: Open the Edit Scale List dialog. 

   

∎ Edit Scale List: Open the Edit Scale List dialog. 



  

∎ Associative Dimensioning: Set associative dimensioning. 

 

∎ Hyperlinks: Configure hyperlink display settings. 

  

  

∎ Undo/Redo: Configure undo/redo settings. 

   

∎ Plot/Publish: Configure plot settings. 

   

⋄ Plot Stamp Settings: Open the Plot Stamp Settings dialog. 



   

⋄ Plot Style Table Settings: Open the Plot Style Table Settings dialog. 

   

󰋮 Drafting tab: Configure drafting-related settings. 

 

∎ Autosnap Settings 



   

⋄ Marker: Display the autosnap marker. 

 

⋄ Magnet: Enable the magnet function for autosnap. 

 

⋄ Display Autosnap Tooltips: Display tooltips for autosnap. 

 

⋄ Display Autosnap Aperture Box: Display the autosnap aperture box 

 

⋄ Colors: Open the Drawing Window Colors dialog. 

   

∎ Autosnap Marker Size: Set the size of the autosnap marker. 



  

 ∎ Object Snap Options: Configure object snap options. 

   

 ∎ Autotrack Settings: Configure autotrack settings. 

  

∎ Alignment Point Acquisition: Configure alignment point acquisition. 

  

∎ Aperture Size: Set the aperture size. 

  

󰋮 3D Modeling tab: Configure 3D modeling settings. 

 

∎ 3D Crosshair: Configure 3D crosshair settings. 



  

∎ 3D Objects: Configure settings for the visual style of 3D objects. 

  

∎ 3D Navigation: Invert the zoom direction of the mouse wheel. 

  

󰋮 Selection tab: Configure selection settings. 

∎ Pickbox Size: Set the size of the pickbox for selecting objects. 



 

 

∎ Selection Preview: Configure the selection preview settings. 

   

⋄ Visual Effect Settings: Open the Visual Effect Settings dialog. 

   

 

 

 

 

 

 

∎ Selection Mode: Configure selection mode settings. 



  

∎ Grip Size: Set the size of the grips. 

   

∎ Grips: Configure grip settings. 

   



 󰋮 Profiles tab: Configure profile settings. 

 

∎ Available Profiles: Display a list of available profiles. 

 

⋄ Set Current: Set the selected profile as current. 

 

⋄ Add to List: Add the current settings to the profile list. 

 

⋄ Rename: Rename the selected profile. 

 

⋄ Delete: Delete the selected profile. 

 

⋄ Export: Export the selected profile to disk. 

 

⋄ Import: Import a profile from disk. 

 

󰋮 Clipboard tab: Configure clipboard settings. 

 

∎ Create Autodesk DWG: Set the format for copying and pasting Autodesk DWG objects. 



  

∎ Automatic-Detect: Automatically detect the installed version and create DWG format. 

  

 ∎ Create Other Formats: Create other formats of OLE objects. 

 

 󰋮 Selection Cycling tab: Configure selection cycling settings. 

∎ Selection Cycling Methods: Set methods for cycling through overlapping objects. 

 

∎ Create Autodesk DWG: Set visual aids for selection cycling. 

 

  



9. CADian 2026 Menu - Drawing 

 

9-1. Line 

 

Draw a line. 

 

1) Menu: Select the Drawing → Line item. (Or type line in the command prompt.) 

 

2) To use the last point, press Enter. / Continue drawing (F) / <Specify start point of line>: When prompted, 

click to specify the start point of the line (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Angle (A) / Length (L) / <Specify endpoint>: When prompted, click to specify the next point (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

 

4) Angle (A) / Length (L) / Continue drawing (F) / Undo (U) / <Specify endpoint>: When prompted, continue 

to click to specify the next point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) To end the command, press the ESC key. 

 

 

 

 

  



9-2. Polyline 

 

Draw a polyline. Unlike a line, a polyline can be drawn continuously and can include curves or have thickness 

properties. 

 

1) Menu: Select the Drawing → Polyline item. (Or type pline in the command prompt.) 

 

2) To use the last point, press Enter. / Continue drawing (F) / <Specify start point of polyline>: When 

prompted, click to specify the start point of the polyline (or enter absolute coordinates, such as 10,10, or 

relative coordinates). 

 

3) Arc (A) / Distance (D) / Continue drawing (F) / Half-width (H) / Width (W) / <Specify next point>: When 

prompted, click to specify the next point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

4) Arc (A) / Distance (D) / Continue drawing (F) / Half-width (H) / Width (W) / Undo (U) / <Specify next 

point>: When prompted, continue to click to specify the next point (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

5) To end the command, press the ESC key. 

 

 

 

 

  



9-3. Spline 

 

Draw a spline. Unlike a line, at least 3 points must be connected to create a smooth curve passing through 3 

or more points. 

 

1) Menu: Select the Drawing → Spline item. (Or type spline in the command prompt.) 

 

2) Object (O) / <Specify first point of spline>: When prompted, click to specify the start point of the spline 

(or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify second point: When prompted, click to specify the next point (or enter absolute coordinates, such 

as 10,10, or relative coordinates). 

 

4) Close (C) / Fit tolerance (F) / Undo (U) / <Specify next point>: When prompted, continue to click to specify 

the next point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) To end the command, press Enter. / Select start tangent: When prompted, select the tangent at the start 

point. / Select end tangent: When prompted, select the tangent at the end point. 

 

 

 

 

 

 

  



9-4. Arc, 3-Point 

 

Draw an arc by specifying 3 points. 

 

1) Menu: Select the Drawing → Arc → 3-Point Arc item. 

 

2) Center (C) / <Specify start point of arc>: When prompted, click to specify the start point of the arc (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Angle (A) / Center (C) / Direction (D) / End (E) / Radius (R) / <Specify second point>: When prompted, 

click to specify the second point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

4) Specify endpoint: When prompted, click to specify the endpoint (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

5) An arc passing through the three points is drawn. 

 

 

 

 

 

 

 

  



9-5. Arc, Center-Start-End 

 

Draw an arc by specifying the center point, start point, and endpoint. 

 

1) Menu: Select the Drawing → Arc → Arc Center-Start-End item. 

 

2) Specify center point of arc: When prompted, click to specify the center point of the arc (or enter absolute 

coordinates, such as 10,10, or relative coordinates). 

 

3) Specify start point: When prompted, click to specify the start point (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

4) Specify endpoint of arc (hold Ctrl to switch direction) or [Angle (A) / Chord length (L)]: When 

prompted, click to specify the endpoint (or enter absolute coordinates, such as 10,10, or relative 

coordinates). 

 

5) An arc passing through the start point and endpoint, centered on the specified point,  

 

 

 

 

 

 

 

  



9-6. Arc, Start-Center-End 

 

Draw an arc by specifying the start point, center point, and endpoint. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Center-End item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point of the arc (or enter absolute coordinates, such as 10,10, or relative 

coordinates). 

 

3) Specify center point: When prompted, click to specify the center point (or enter absolute coordinates, such 

as 10,10, or relative coordinates). 

 

4) Specify endpoint of arc (hold Ctrl to switch direction) or [Angle (A) / Chord length (L)]: When prompted, 

click to specify the endpoint (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) An arc passing through the start point and endpoint, centered on the specified point, is drawn.. 

 

 

 

 

 

  



9-7. Arc, Start-End-Center 

 

Draw an arc by specifying the start point, endpoint, and center point. 

 

1) Menu: Select the Drawing → Arc → Arc Start-End-Center item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point of the arc (or enter absolute coordinates, such as 10,10, or relative 

coordinates). 

 

3) Specify endpoint: When prompted, click to specify the endpoint (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

4) Specify center point of arc (hold Ctrl to switch direction) or [Angle (A) / Direction (D) / Radius (R)]: When 

prompted, click to specify the center point (or enter absolute coordinates, such as 10,10, or relative 

coordinates). 

 

5) An arc passing through the start point and endpoint, centered on the specified point, is drawn. 

 

 

 

 

 

 

  



9-8. Arc, Tangent 

 

Draw an arc using tangents. 

 

1) Menu: Select the Drawing → Arc → Tangent Arc item. 

 

2) Specify endpoint: (hold Ctrl to switch direction) When prompted, click to specify the endpoint (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

 

3) An arc tangent to the end of the last drawn object is created. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-9. Arc, Center-Start-Angle 

 

Draw an arc by specifying the center point, start point, and angle. 

 

1) Menu: Select the Drawing → Arc → Arc Center-Start-Angle item. 

 

2) Specify center point of arc: When prompted, click to specify the center point of the arc (or enter absolute 

coordinates, such as 10,10, or relative coordinates). 

 

3) Specify start point: When prompted, click to specify the start point (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

4) Included angle: (hold Ctrl to switch direction) When prompted, move the mouse to specify the angle or 

enter the angle value. 

 

5) An arc passing through the start point with the specified angle is drawn, centered on the specified point. 

 

 

 

 

 

 

 

 

  



9-10. Arc, Start-Center-Angle 

 

Draw an arc by specifying the start point, center point, and angle. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Center-Angle item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify center point of arc: When prompted, click to specify the center point (or enter absolute coordinates, 

such as 10,10, or relative coordinates). 

 

4) Included angle: (hold Ctrl to switch direction) When prompted, move the mouse to specify the angle or 

enter the angle value. 

 

5) An arc passing through the start point with the specified angle is drawn, centered on the specified point. 

 

 

 

 

 

 

  



9-11. Arc, Start-Angle-Center 

 

Draw an arc by specifying the start point, angle, and center point. 

 

1) Menu: Select the Drawing → Arc, Start-Angle-Center item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Included angle: When prompted, move the mouse to specify the angle or enter the angle value. 

 

4) Specify center point of arc: (hold Ctrl to switch direction) When prompted, click to specify the center point 

(or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) An arc passing through the start point with the specified angle is drawn, centered on the specified point. 

 

 

 

 

 

 

 

 

  



9-12. Arc, Start-End-Angle 

 

Draw an arc by specifying the start point, endpoint, and angle. 

 

1) Menu: Select the Drawing → Arc → Arc Start-End-Angle item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify endpoint: When prompted, click to specify the endpoint (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

4) Included angle: (hold Ctrl to switch direction) When prompted, move the mouse to specify the angle or 

enter the angle value. 

 

5) An arc passing through the start point and endpoint with the specified angle is drawn. 

 

 

 

 

 

 

 

 

  



9-13. Arc, Start-Angle-End 

 

Draw an arc by specifying the start point, angle, and endpoint. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Angle-End item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Included angle: When prompted, move the mouse to specify the angle or enter the angle value. 

 

4) Specify endpoint of arc (hold Ctrl to switch direction) or [Center (C)]: When prompted, click to specify the 

endpoint (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) An arc passing through the start point and endpoint with the specified angle is drawn. 

 

 

 

 

 

 

 

  



9-14. Arc, Center-Start-Length 

 

Draw an arc by specifying the center point, start point, and length. 

 

1) Menu: Select the Drawing → Arc → Arc Center-Start-Length item. 

 

2) Specify center point of arc: When prompted, click to specify the center point of the arc (or enter absolute 

coordinates, such as 10,10, or relative coordinates). 

 

3) Specify start point: When prompted, click to specify the start point (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

4) Chord length: (hold Ctrl to switch direction) When prompted, move the mouse to specify the length or 

enter the length value. 

 

5) An arc passing through the start point with the specified length is drawn, centered on the specified point. 

 

 

 

 

 

 

 

  



9-15. Arc, Start-Center-Length 

 

Draw an arc by specifying the start point, center point, and length. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Center-Length item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify center point of arc: When prompted, click to specify the center point (or enter absolute coordinates, 

such as 10,10, or relative coordinates). 

 

4) Chord length: (hold Ctrl to switch direction) When prompted, move the mouse to specify the length or 

enter the length value. 

 

5) An arc passing through the start point with the specified length is drawn, centered on the specified point. 

 

 

 

 

 

 

 

  



9-16. Arc, Start-Direction-End 

 

Draw an arc by specifying the start point, direction, and endpoint. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Direction-End item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

Initial direction angle of arc: When prompted, move the mouse to specify the direction or enter the angle 

value. 

Specify endpoint: (hold Ctrl to switch direction) When prompted, click to specify the endpoint (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

An arc passing through the start point in the specified direction to the endpoint is drawn. 

 

 

 

 

 

 

 

 

  



9-17. Arc, Start-End-Direction 

 

Draw an arc by specifying the start point, endpoint, and direction. 

 

1) Menu: Select the Drawing → Arc → Arc Start-End-Direction item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative 

coordinates). 

 

3) Specify endpoint: (hold Ctrl to switch direction) When prompted, click to specify the endpoint (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

 

4) Direction from start: (hold Ctrl to switch direction) When prompted, move the mouse to specify the 

direction. 

 

5) An arc passing through the start point and endpoint in the specified direction is drawn. 

 

 

 

 

 

 

 

  



9-18. Arc, Start-Radius-End 

 

Draw an arc by specifying the start point, radius, and endpoint. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Radius-End item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify radius of arc: When prompted, move the mouse to specify the radius or enter the radius value. 

 

4)Specify endpoint of arc (hold Ctrl to switch direction) or [Included angle (A)]: When prompted, click to 

specify the endpoint (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

5) An arc passing through the start point and endpoint with the specified radius is drawn. 

 

 

 

 

 

 

 

  



9-19. Arc, Start-End-Radius 

 

Draw an arc by specifying the start point, endpoint, and radius. 

 

1) Menu: Select the Drawing → Arc → Arc Start-End-Radius item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify endpoint: (hold Ctrl to switch direction) When prompted, click to specify the endpoint (or enter 

absolute coordinates, such as 10,10, or relative coordinates). 

 

4) Specify radius of arc: (hold Ctrl to switch direction) When prompted, move the mouse to specify the radius 

or enter the radius value. 

 

5) An arc passing through the start point and endpoint with the specified radius is drawn. 

 

 

 

 

 

 

 

  



9-20. Arc, Start-Radius-Angle 

 

Draw an arc by specifying the start point, radius, and angle. 

 

1) Menu: Select the Drawing → Arc → Arc Start-Radius-Angle item. 

 

2) To use the last point, press Enter. / Center (C) / Continue drawing (F) / <Specify start point of arc>: When 

prompted, click to specify the start point (or enter absolute coordinates, such as 10,10, or relative coordinates). 

 

3) Specify radius of arc: When prompted, move the mouse to specify the radius or enter the radius value. 

 

4) Included angle: (hold Ctrl to switch direction) When prompted, move the mouse to specify the angle or 

enter the angle value. 

 

5) Direction of chord: When prompted, move the mouse to specify the direction. 

 

6) An arc passing through the start point with the specified radius, angle, and direction is drawn. 

 

 

 

 

 

 

  



9-21. Circle, Center-Radius 

 

Draw a circle by specifying the center point and radius. 

 

1) Menu: Select the Drawing → Circle → Circle Center-Radius item. 

 

2) 2 Point (2P) / 3 Point (3P) / Tan Tan Radius (TTR) / Tan Tan Tan (TTT) / Arc (A) / Multiple (M) / <Specify 

center point of circle>: When prompted, click to specify the center point (or enter absolute coordinates, such 

as 10,10, or relative coordinates). 

 

3) Diameter (D) / <Specify radius>: When prompted, move the mouse to specify the radius or enter the radius 

value. 

 

4) A circle with the specified center point and radius is drawn. 

 

 

 

 

 

 

 

 

 

 

  



9-22. Circle, Center-Diameter 

 

Draw a circle by specifying the center point and diameter. 

 

1) Menu: Select the Drawing → Circle → Circle Center-Diameter item. 

 

2) 2 Point (2P) / 3 Point (3P) / Tan Tan Radius (TTR) / Tan Tan Tan (TTT) / Arc (A) / Multiple (M) / <Specify 

center point of circle>: When prompted, click to specify the center point (or enter absolute coordinates, such 

as 10,10, or relative coordinates). 

 

3) Enter diameter of circle <71.692>: When prompted, move the mouse to specify the diameter or enter the 

diameter value. 

 

4) A circle with the specified center point and diameter is drawn. 

 

 

 

 

 

 

 

 

  



9-23. Circle, 2-Point 

 

Draw a circle by specifying 2 points. 

 

1) Menu: Select the Drawing → Circle → Circle 2-Point item. 

 

2) Specify first point on diameter: When prompted, click to specify the first point (or enter absolute 

coordinates, such as 10,10, or relative coordinates). 

 

3) Specify second point on diameter: When prompted, click to specify the second point (or enter absolute 

coordinates, such as 10,10, or relative coordinates). 

 

4) A circle with the specified first and second points is drawn. 

 

 

 

 

 

 

 

 

 

 

  



9-24. Circle, 3-Point 

 

Draw a circle by specifying 3 points. 

 

1) Menu: Select the Drawing → Circle → Circle 3-Point item. 

 

2) Specify first point of circle: When prompted, click to specify the first point (or enter absolute coordinates, 

such as 10,10, or relative coordinates). 

 

3) Specify second point: When prompted, click to specify the second point (or enter absolute coordinates, 

such as 10,10, or relative coordinates). 

 

4) Specify third point: When prompted, click to specify the third point (or enter absolute coordinates, such as 

10,10, or relative coordinates). 

 

5) A circle passing through the three points is drawn. 

 

 

 

 

 

 

 

 

  



9-25. Circle, Tan Tan Radius 

 

Draw a circle by specifying 2 tangents and a radius. 

 

1) Menu: Select the Drawing → Circle → Circle Tan Tan Radius item. 

 

2) Select first tangent point: When prompted, click to specify the first tangent point (Tangent Osnap appears). 

 

3) Select second tangent point: When prompted, click to specify the second tangent point (Tangent Osnap 

appears). 

 

4) Specify radius of circle <17.8818>: When prompted, move the mouse to specify the radius (click after 

moving to specify the radius) or enter the radius value. 

 

5) A circle passing through the two tangent points with the specified radius is drawn. 

   

 

 

 

 

 

 

 

 

  



9-26. Circle, Tan Tan Tan 

 

Draw a circle by specifying 3 tangents. 

 

1) Menu: Select the Drawing → Circle → Circle Tan Tan Tan item. 

2) Specify first point of circle: When prompted, click to specify the first tangent point (Tangent Osnap 

appears). 

3) Specify second point: When prompted, click to specify the second tangent point (Tangent Osnap appears). 

4) Specify third point: When prompted, click to specify the third tangent point (Tangent Osnap appears). 

5) A circle fitting the three tangent points is drawn. 

 

 

 

 

 

 

 

 

 

 

  



9-27. Convert Arc to Circle 

 

Convert an existing arc to a circle with the same diameter. 

 

1) Menu: Select the Drawing → Circle → Convert Arc to Circle item. 

 

2) Select arc to convert to circle: When prompted, click to select the arc to convert. 

 

3) The arc is converted to a circle. 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-28. Ellipse, Axis-Axis 

 

Draw an ellipse by specifying two axes. 

 

1) Menu: Select the Drawing → Ellipse → Ellipse Axis-Axis item. 

 

2) Arc (A) / Center (C) / <Specify end point of ellipse axis>: When prompted, click to specify the first point 

of the axis. 

 

3) Specify other end point of axis: When prompted, click to specify the second point of the axis. 

 

4) Rotation (R) / <Specify end point of other axis>: When prompted, click to specify the end point of the other 

axis. 

 

5) An ellipse with the specified axes is drawn. 

 

 

 

 

 

 

 

 

 

  



9-29. Ellipse, Axis-Rotation 

 

Draw an ellipse by specifying one axis and a rotation value. 

 

1) Menu: Select the Drawing → Ellipse → Ellipse Axis-Rotation item. 

 

2) Arc (A) / Center (C) / <Specify end point of ellipse axis>: When prompted, click to specify the first point 

of the axis. 

 

3) Specify other end point of axis: When prompted, click to specify the second point of the axis. 

 

4) Rotate around major axis: When prompted, click to specify the rotation point. 

 

5) An ellipse with the specified axis and rotation is drawn. 

 

 

 

 

 

 

 

 

 

 

  



9-30. Ellipse, Center-Axis 

Draw an ellipse by specifying the center point and axes. 

 

1) Menu: Select the Drawing → Ellipse → Ellipse Center-Axis item. 

 

2) Specify center of ellipse: When prompted, click to specify the center point of the ellipse. 

 

3) Specify end point of axis: When prompted, click to specify the end point of the axis. 

 

4) Rotation (R) / <Specify end point of other axis>: When prompted, click to specify the end point of the other 

axis. 

 

5) An ellipse with the specified center and axes is drawn. 

 

 

 

 

 

 

 

 

 

  



9-31. Ellipse, Center-Rotation 

 

Draw an ellipse by specifying the center point and a rotation value. 

 

1) Menu: Select the Drawing → Ellipse → Ellipse Center-Rotation item. 

 

2) Specify center of ellipse: When prompted, click to specify the center point of the ellipse. 

 

3) Specify end point of axis: When prompted, click to specify the end point of the axis. 

 

4) Rotate around major axis: When prompted, click to specify the rotation point. 

 

5) An ellipse with the specified center and rotation is drawn. 

 

 

 

 

 

 

 

 

 

 

  



9-32. Elliptical Arc, Axis-Axis 

 

Draw an elliptical arc by specifying two axes. 

 

1) Menu: Select the Drawing → Elliptical Arc → Elliptical Arc Axis-Axis item. 

 

2) Arc (A) / Center (C) / <Specify end point of ellipse axis>: When prompted, click to specify the first point 

of the axis. 

 

3) Specify other end point of axis: When prompted, click to specify the second point of the axis. 

 

4) Rotation (R) / <Specify end point of other axis>: When prompted, click to specify the end point of the other 

axis. 

 

5) Parameters (P) / <Specify start angle of arc>: When prompted, move the mouse to specify the start angle 

of the arc. 

 

6) Parameters (P) / Included angle (I) / <Specify end angle>: When prompted, move the mouse to specify the 

end angle of the arc. 

 

7) An elliptical arc with the specified axes, start angle, and end angle is drawn. 

    

 

 

  



9-33. Elliptical Arc, Axis-Rotation 

 

Draw an elliptical arc by specifying an axis and a rotation value. 

 

1) Menu: Select the Drawing → Elliptical Arc → Elliptical Arc Axis-Rotation item. 

 

2) Arc (A) / Center (C) / <Specify end point of ellipse axis>: When prompted, click to specify the first point 

of the axis. 

 

3) Specify other end point of axis: When prompted, click to specify the second point of the axis. 

 

4) Rotate around major axis: When prompted, click to specify the rotation point. 

 

5) Parameters (P) / <Specify start angle of arc>: When prompted, move the mouse to specify the start angle 

of the arc. 

 

6) Parameters (P) / Included angle (I) / <Specify end angle>: When prompted, move the mouse to specify the 

end angle of the arc. 

 

7) An elliptical arc with the specified axis, rotation, start angle, and end angle is drawn. 

 

   

 

 

  



9-34. Elliptical Arc, Center-Axis 

 

Draw an elliptical arc by specifying the center point and axes. 

 

1) Menu: Select the Drawing → Elliptical Arc → Elliptical Arc Center-Axis item. 

 

2) Specify center of ellipse: When prompted, click to specify the center point of the ellipse. 

 

3) Specify end point of axis: When prompted, click to specify the end point of the axis. 

 

4) Rotation (R) / <Specify end point of other axis>: When prompted, click to specify the end point of the other 

axis. 

 

5) Parameters (P) / <Specify start angle of arc>: When prompted, move the mouse to specify the start angle 

of the arc. 

 

6) Parameters (P) / Included angle (I) / <Specify end angle>: When prompted, move the mouse to specify the 

end angle of the arc. 

 

7) An elliptical arc with the specified center, axes, start angle, and end angle is drawn. 

   

 

 

 

  



9-35. Elliptical Arc, Center-Rotation 

 

Draw an elliptical arc by specifying the center point and a rotation value. 

 

1) Menu: Select the Drawing → Elliptical Arc → Elliptical Arc Center-Rotation item. 

 

2) Specify center of ellipse: When prompted, click to specify the center point of the ellipse. 

 

3) Specify end point of axis: When prompted, click to specify the end point of the axis. 

 

4) Rotate around major axis: When prompted, click to specify the rotation point. 

 

5) Parameters (P) / <Specify start angle of arc>: When prompted, move the mouse to specify the start angle 

of the arc. 

 

6) Parameters (P) / Included angle (I) / <Specify end angle>: When prompted, move the mouse to specify the 

end angle of the arc. 

 

7) An elliptical arc with the specified center, rotation, start angle, and end angle is drawn. 

 

   

 

 

  



9-36. Block 

 

A block is an object or group of objects that are frequently used, defined with a unique name and grouped 

together. It can be freely inserted and edited in new or current drawings, making repetitive tasks or inserting 

parts libraries very easy and fast. 

 

1) Menu: Select the Drawing → Block → Create Block item. (Or type block in the command prompt.) 

 

󰋮 Name: Specify the name of the block. 

  

󰋮 Preview: The selected objects are shown in the preview. 

  

󰋮 Base point: Specify the base point of the block. 



   

󰋮 Objects: Select the objects to include in the block and specify how to handle the objects after creating the 

block. 

 

∎ Click the  icon and then click or drag in the drawing to select the objects to be converted into a block. 

 

∎ Clicking the  icon allows you to use the quick select function to choose objects to be converted into a 

block. 

 

󰋮 Action: Set options related to block conversion. 

 

󰋮 Settings: Set the units for the block. 

 



 

󰋮 Description: Enter a simple comment for the block.

 

2) Enter the block name → Select the objects to convert to a block → Specify the base point → Set the units 

→ Click the OK button to create the block. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-37. Point 

 

Draw a point. 

 

1) Menu: Select the Drawing → Point → Point item. (Or type point in the command prompt.) 

 

2) Settings (S) / Multiple (M) / <Specify point location>: When prompted, click the desired location with the 

mouse. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-38. Measure 

 

Draw points at specified length intervals on an object. 

 

1) Menu: Select the Drawing → Point → Measure item. (Or type measure in the command prompt.) 

 

2) Select object to measure: When prompted, click to select the object to measure. 

 

3) Specify segment length or [Block (B)]: When prompted, specify the segment length with the mouse or 

enter the length value. 

 

4) Points are drawn at the specified length intervals on the selected object. 

 

 

 

 

 

 

 

 

 

 

 

  



9-39. Divide 

 

Divide an object into a specified number of segments and draw points at those locations. 

 

1) Menu: Select the Drawing → Point → Divide item. (Or type divide in the command prompt.) 

 

2) Select object to divide: When prompted, click to select the object to divide. 

 

3) Specify number of segments or [Block (B)]: When prompted, enter the number of segments. 

 

4) The object is divided into the specified number of segments, and points are drawn at the division points. 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-40. Rectangle 

 

Draw a rectangle. 

 

1) Menu: Select the Drawing → Rectangle item. (Or type rectangle in the command prompt.) 

 

2) Chamfer (C) / Elevation (E) / Fillet (F) / Rotation (R) / Square (S) / Thickness (T) / Width (W) / <Specify 

first corner point of rectangle>: When prompted, click to specify the first corner point of the rectangle. 

 

3) Specify other corner point or [Area (A) / Dimensions (D) / Rotation (R)]: When prompted, click to 

specify the other corner point. 

 

4) A rectangle is drawn based on the two specified points. 

 

 

 

 

 

 

 

 

 

 

  



9-41. Polygon, Center-Vertex 

 

Draw a polygon by specifying the center point and a vertex. 

 

1) Menu: Select the Drawing → Polygon → Polygon Center-Vertex item. 

 

2) Polygon: Multiple (M) / Width (W) / <Specify number of sides> <4>: When prompted, enter the number 

of sides for the polygon. (3 = Triangle, 5 = Pentagon, 10 = Decagon) 

 

3) Specify center of polygon or [Edge (E)]: When prompted, click to specify the center point of the polygon. 

 

4) Specify radius of circle: When prompted, click to specify the radius of the polygon (distance to vertex). 

 

5) A polygon is drawn based on the specified center point and radius. 

 

 

 

 

 

 

 

  



9-42. Polygon, Center-Edge 

 

Draw a polygon by specifying the center point and an edge. 

 

1) Menu: Select the Drawing → Polygon → Polygon Center-Edge item. 

 

2) Polygon: Multiple (M) / Width (W) / <Specify number of sides> <4>: When prompted, enter the number 

of sides for the polygon. (3 = Triangle, 5 = Pentagon, 10 = Decagon) 

 

3) Specify center of polygon or [Edge (E)]: When prompted, click to specify the center point of the polygon. 

 

4) Specify radius of circle: When prompted, click to specify the radius of the polygon (distance to edge). 

 

5) A polygon is drawn based on the specified center point and radius. 

 

 

 

 

 

 

 

  



9-43. Polygon, Edge 

 

Draw a polygon by specifying the edges. 

 

1) Menu: Select the Drawing → Polygon → Polygon Edge item. (Or type polygon in the command prompt.) 

 

2) Polygon: Multiple (M) / Width (W) / <Specify number of sides> <4>: When prompted, enter the number 

of sides for the polygon. (3 = Triangle, 5 = Pentagon, 10 = Decagon) 

 

3) Specify first end point of edge: When prompted, click to specify the first end point of the polygon edge. 

 

4) Specify second end point of edge: When prompted, click to specify the second end point of the polygon 

edge. 

 

5) A polygon is drawn based on the two specified edge points. 

 

 

 

 

 

 

 

  



9-44. Wipeout 

 

Create an area that hides objects beneath it. 

 

1) Menu: Select the Drawing → Wipeout item. (Or type wipeout in the command prompt.) 

 

2) Specify first point or [Frame (F) / Polyline (P)] <Polyline>: When prompted, click to specify the first point 

for the wipeout object. 

 

3) Specify next point: When prompted, click to specify the second point for the wipeout object. 

 

4) Specify next point or [Undo (U)]: When prompted, click to specify the third point for the wipeout object. 

 

5) Specify next point or [Close (C) / Undo (U)]: When prompted, click to specify the fourth point for the 

wipeout object or type "c" to close or press Enter to finish the command. 

 

6) The objects beneath the wipeout object are hidden. 

   

 

 

 

 

  



9-45. Boundary Polyline (Bpoly) 

 

Draw a boundary polyline. 

 

1) Menu: Select the Drawing → Boundary Polyline item. (Or type bpoly in the command prompt.) 

 

2) The Boundary Creation dialog box appears. 

 

3) Click the Point Selection button → Click inside the object where you want to create the boundary 

polyline → Press Enter. 

 

 

4) BOUNDARY creates a polyline. A message will appear, and the boundary polyline will be created. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-46. Donut 

 

Draw a donut. 

 

1) Menu: Select the Drawing → Donut item. (Or type donut in the command prompt.) 

 

2) Specify inside diameter <0.5>: When prompted, enter the inside diameter of the donut or click to specify 

it with the mouse. 

 

3) Specify outside diameter <1>: When prompted, enter the outside diameter of the donut or click to specify 

it with the mouse. 

 

4) A donut is drawn based on the specified inside and outside diameters. 

 

 

 

 

 

 

 

 

 

 

 

  



9-47. Solid 

 

Draw a solid. 

 

1) Menu: Select the Drawing → Solid item. (Or type solid in the command prompt.) 

 

2) Rectangle (R) / Square (S) / Triangle (T) / <Specify first point of solid>: When prompted, click to specify 

the first point of the solid. 

 

3) Specify second point: When prompted, click to specify the second point of the solid. 

 

4) Specify third point: When prompted, click to specify the third point of the solid. 

 

5) Specify fourth point or <Exit (X)>: When prompted, click to specify the fourth point of the solid or enter 

"x" to exit or press Enter to finish. 

 

6) A solid is drawn based on the specified points. 

 

 

 

 

 

 

  



9-48. Trace 

 

Draw a trace. 

 

1) Menu: Select the Drawing → Trace item. (Or type trace in the command prompt.) 

 

2) Specify trace width <1>: When prompted, enter the width of the trace or click to specify it with the mouse. 

 

3) Specify start point of trace: When prompted, click to specify the start point of the trace. 

 

4) Specify next point: When prompted, click to specify the second point of the trace. 

 

5) Specify next point: When prompted, click to specify the third point of the trace. 

 

6) Specify next point: When prompted, click to specify the next point of the trace. Press Enter to finish the 

command. 

 

7) A trace is drawn based on the specified points. 

 

 

 

 

 

  



9-49. Bhatch 

 

Draw a hatch. 

 

1) Menu: Select the Drawing → Hatch → Hatch item. (Or type bhatch in the command prompt.) 

 

2) The Hatch and Gradient dialog box appears. 

 

󰋮 Hatch tab: Set hatch-related options. 

 

 

󰋮 Hatch tab: Set items related to hatching. 

 

∎ Type and Pattern: Set the hatch type, pattern, and color. 

 

⋄ Pattern: Select the hatch pattern. Click the "..." button to display the hatch pattern selection dialog box. 

Select the desired pattern and click OK to apply it. 

 

 

 



 

⋄ Preview: Display a preview of the selected hatch pattern. 

 

⋄ Color: Set the color of the selected hatch pattern. 

 

∎ Angle and Scale: Set the angle and scale of the hatch pattern. 

⋄ Angle: Set the angle of the selected hatch pattern. 

   

Angle: 0°                              Angle: 30° 

 



⋄ Scale: Set the scale of the selected hatch pattern. 

     

Scale: 1                                Scale: 5 

 

◼ Hatch Options: Set additional options for the hatch. 

  

∎ Boundary: Set the boundary for the hatch. 

⋄ Add: Pick Points: Click inside a closed object to specify the boundary. Note that you cannot specify the 

boundary for an open object using this method. 

   

Points can be selected.  

 

Cannot select points for an open object. 



⋄ Add: Select Objects: Click an object to specify its interior as the boundary.  

 

 

⋄ Remove Boundaries: Remove unwanted boundaries for the hatch. 

 

⋄ View Boundaries: Display the currently defined boundaries. 

 

∎ Options: Set options for hatch annotations, draw order, layer, transparency, etc. 

  

∎ Island Detection: Set whether to detect isolated areas (closed boundaries inside the hatch). 

  

∎ Retain Boundaries: Create and add boundary objects to the drawing from temporary hatch boundaries. 



  

∎ Gap Tolerance: Set the gap tolerance for the hatch. 

   

∎ Inherit Options: Set whether to inherit the hatch origin when creating a hatch. 

  

󰋮 Gradient tab: Set options related to gradient hatching. 

∎ Color: Select the colors (single or two colors) to use for the gradient hatch. 

   

∎ Pattern: Select the gradient hatch pattern to apply using the selected colors. 

  

  

∎ Direction: Set the direction of the gradient hatch pattern. 



   

3) Select hatch pattern → Set angle and scale → Specify hatch boundary → Click the OK button to create the 

hatch. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-50. Dtext 

 

Create single-line text. 

 

1) Menu: Select the Drawing → Text item. (Or type dtext in the command prompt.) 

 

2) Specify start point of text or [Justify (J) / Style (S)]: When prompted, click to specify the start point of the 

text. 

 

3) Specify text height <2.5>: When prompted, specify the text height by clicking or entering a value and 

pressing Enter. 

 

4) Specify text rotation angle <0>: When prompted, specify the text rotation angle by clicking or entering a 

value and pressing Enter. 

 

5) When the text cursor blinks, type the desired text string. 

 

 

 

6) Press Enter to finish the text input. 

 

 



9-51. Mtext 

 

Create multi-line text. 

 

1) Menu: Select the Drawing → Mtext item. (Or type mtext in the command prompt.) 

 

2) Specify first corner of text block: When prompted, drag to specify the area for the multi-line text. 

 

3) The text cursor blinks, and you can type the desired text string. 

 

 

4) When text input is complete, click the "Close Text Editor" button on the ribbon menu to finish the command. 

 

󰋮 Options for multi-line text input 

 

∎ Style: Change the text style and size. 



  

∎ Format: Change the text to bold, italic, underline, or overline. 

  

∎ Font and Color: Change the text font and color. 

  

∎ Angle and Width Factor: Specify the text slant angle and width factor. 

  

∎ Paragraph: Use alignment functions such as left, center, or right alignment. 

  

∎ Tools: Insert special characters (±, ∅, etc.), find and replace text, and import text. 

   

󰋮 Stacked Text: To display fractions like 1/10, enter the numbers in the numerator/denominator form and 

select by dragging → Click the Stacked Text button to convert it to a fraction. 



   

Write 1/10 and select the text.  

   

Click "Stack" to convert to a fraction. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



9-52. Wall 

 

Create a wall as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Wall item. 

 

2) Choose the type of wall you want to draw from the options: interior wall, exterior wall, fire wall, foundation 

wall, interior wallboard wall, exterior brick veneer wall, curtain wall, etc. 

 

3) Specify the start point of the wall: When prompted, click to specify the start point of the wall. 

 

4) Specify the end point of the wall: When prompted, click to specify the end point of the wall. 

 

5) Continue specifying points to draw the wall continuously. 

 

  



9-53. Door 

 

Create a door as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Door item. 

 

2) Choose the type of door you want to draw from the options: single door, double door, unequal double 

door, opposite swing door, etc. 

 

3) When prompted to select the parent wall, click the wall where you want to insert the door. 

 

4) The door is displayed in the wall. Click to specify the location where you want to place the door. 

 

5) Press Esc or Enter to finish the door drawing. 

 

 

  



9-54. Window 

 

Create a window as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Window item. 

 

2) Choose the type of window you want to draw from the options: window, sliding window, unequal double 

hung window, unequal single hung window, etc. 

 

3) When prompted to select the parent wall, click the wall where you want to insert the window. 

 

4) The window is displayed in the wall. Click to specify the location where you want to place the window. 

 

5) Press Esc or Enter to finish the window drawing. 

 

  



9-55. Stair 

 

Create stairs as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Stair item. 

 

2) Choose the type of stair you want to draw from the options: standard stair, cantilevered stair, half-turn stair, 

U-shaped stair, etc. 

 

3) When prompted to specify the start point of the stair, click to specify the start point. 

 

4) When prompted to specify the end point or length of the stair segment, click to specify the end point or 

enter the length. 

 

 

5) The stair drawing is completed. 

 

  



9-56. Handrail 

 

Create a handrail as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Handrail item. 

 

2) Choose the type of handrail you want to draw from the options: standard handrail, post handrail, horizontal 

cable handrail, vertical cable handrail, guard handrail, partition handrail, industrial handrail, cribbing 

handrail, etc. 

 

3) When prompted to specify the start point of the handrail, click to specify the start point. 

 

4) When prompted to specify the end point of the handrail, click to specify the end point. 

 

5) Press Enter to complete the handrail drawing. 

 

 

  



9-57. Steel Shape 

 

Create steel shapes as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Detailing → Steel item. 

 

2) Choose the type of steel shape you want to draw from the options: L-shaped steel, C-shaped steel, beams, 

tracks, etc. The steel shape dialog box appears. 

 

3) Select the desired steel shape item and click OK. 



 

4) When prompted to specify the insertion point, click to specify the location where you want to insert  

the steel shape. 

 

5) When prompted to specify the rotation angle, enter the rotation angle. 

 

6) When prompted to specify the length, enter the length value with the mouse or keyboard. 

 

7) The steel shape is drawn in the drawing. 

 



9-58. Timber 

 

Create timber as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Detailing → Timber item. 

 

2) Choose the type of timber you want to draw from the options: timber, TJI joists, etc. The timber dialog box 

appears. 

 

3) Select the desired timber item and click OK. 



   

4) When prompted to specify the insertion point, click to specify the location where you want to insert the 

timber. 

 

5) When prompted to specify the rotation angle, enter the rotation angle. 

 

6) When prompted to specify the length, enter the length value with the mouse or keyboard. 

 

7) The timber is drawn in the drawing. 

 



9-59. Slab 

 

Create slabs as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Slab item. 

 

2) When prompted to specify the slab outline or modify the thickness, press Enter. 

 

3) When prompted to specify the start point of the polyline, draw the slab area sequentially like a polyline. 

Enter "c" to close or press Enter to finish. 

 

4) The slab drawing is completed. 

 

 

 

 

 

 

 

 

 

  



9-60. Roof 

 

Create roofs as an AEC object. 

 

1) Menu: Select the Drawing → AEC Object → Roof item. 

 

2) Specify roof points: Click or enter coordinates to specify the first point of the roof. 

 

3) Continue specifying points: Click or enter coordinates to specify the next points. 

 

4) When four points are specified, the shape of the roof is displayed. Press Enter to complete the roof 

drawing. 

 

 

 

 

 

 

 

 

 

  



9-61. Mline 

 

Draw multiple parallel lines as a single entity. 

 

1) Menu: Select the Drawing → Mline item. (Or type mline in the command prompt.) 

 

2) Specify start point or [Style Load (L) / Justify (J) / Scale (S) / Style (ST)]: When prompted, click to 

specify the start point of the mline or enter coordinates. 

 

3) Specify next point: When prompted, click to specify the next point or enter coordinates. 

 

4) Specify next point: When prompted, continue to specify the next points. 

 

5) Press Esc or Enter to finish the mline drawing. 

 

 

 

 

 

 

 

  



9-62. Freehand 

 

Draw a freehand line by moving the mouse like sketching. 

 

1) Menu: Select the Drawing → Freehand item. (Or type freehand in the command prompt.) 

 

2) Specify segment length <1>: When prompted, enter the segment length (interval of the line). The smaller 

the segment length value, the denser the line appears. 

 

3) Press Enter to stop/[Exit (Q) / Pen Down (P) / Erase (E) / Write on Drawing (W) / Connect (C) / Straight 

Cursor (S)] /: (Pause...) When prompted, click to specify the start point of the freehand line and move the 

mouse freely like sketching. The freehand line is drawn continuously following the mouse movement. 

 

4) Press Enter or click to stop the freehand drawing. 

 

 

 

 

 

 

  



9-63. Ray 

 

Draw a ray that extends infinitely in one direction from a specified point. 

 

1) Menu: Select the Drawing → Ray item. (Or type ray in the command prompt.) 

 

2) Specify start point or [Bisect (B) / Horizontal (H) / Vertical (V) / Angle (A) / Offset (O)] / <Specify start 

point of ray>: When prompted, click to specify the start point or enter coordinates. 

 

3) Specify direction or pass-through point: When prompted, click to specify the direction of the ray. 

 

 

 

 

 

 

 

 

 

 

  



9-64. Infline 

 

Draw an infinite line that extends infinitely in both directions from a specified point. 

 

1) Menu: Select the Drawing → Infline item. (Or type infline in the command prompt.) 

 

2) Specify start point or [Bisect (B) / Horizontal (H) / Vertical (V) / Angle (A) / Offset (O)] / <Specify start 

point of infinite line>: When prompted, click to specify the start point or enter coordinates. 

 

3) Specify direction or pass-through point: When prompted, click to specify the direction of the infinite line. 

 

 

 

 

 

 

 

 

  



9-65. Helix 

 

Draw a helical shape like a spring. 

 

1) Menu: Select the Drawing → Helix item. (Or type helix in the command prompt.) 

 

2) Specify base center point: When prompted, click to specify the base point or enter coordinates. 

 

3) Specify base radius or [Diameter (D)] <1.000000>: When prompted, specify the base radius by clicking 

or entering a value. 

 

4) Specify top radius or [Diameter (D)] <63.329119>: When prompted, specify the top radius by clicking or 

entering a value. 

 

5) Specify helix height or [Axis endpoint (A) / Turns (T) / Turn height (H) / Twist (W)] <1.000000>: When 

prompted, specify the height by clicking or entering a value. 

 

The helix drawing is completed. 

 

 

 

  



9-66. Table 

 

Draw a table. You can enter text or numeric values and perform simple calculations (e.g., sum, average) in 

the table, similar to Microsoft Excel. 

 

1) Menu: Select the Drawing → Table item. (Or type table in the command prompt.) 

 

2) The Table Insertion dialog box appears. 

 

󰋮 Table Style: The current table style in use is displayed. 

 

󰋮 Insertion Options: Choose whether to start with an empty table or link data (Excel link). 

 

󰋮 Preview: View a preview of the current table style. 

 

󰋮 Insertion Behavior: Specify how to insert the table. 

 

󰋮 Column and Row Settings: Specify the width and height of columns and rows. 



 

󰋮 Cell Style Settings: Specify the cell style for each row (title, header, data). 

 

3) Insertion Behavior: Select the insertion point, then click OK. Click to specify the insertion point of the 

table or enter coordinates with the keyboard. 

 

4) Once the table is inserted, the cursor appears in the first row, allowing you to immediately start entering 

content. 

 

 

 

 

 

  



10. CADian 2026 Menu - Dimension 

 

10-1. Linear (Dimlinear) 

 

Draw a linear dimension. 

 

1) Menu: Select the Dimension → Linear item. (Or type dimlinear in the command prompt.) 

 

2) Select objects or <Specify first extension line origin>: When prompted, click to specify the first point to 

dimension. 

 

3) Specify second extension line origin: When prompted, click to specify the second point to dimension. 

  

4) Specify dimension line location or [Multi-line Text (M) / Text (T) / Angle (A) / Horizontal (H) / Vertical 

(V) / Rotation (R)]: When prompted, click to specify the location of the dimension text. 

 

5) The linear dimension is drawn. 

 

 

 

 

 

 

 

  



10-2. Aligned (Dimaligned) 

 

Draw an aligned dimension. 

 

1) Menu: Select the Dimension → Aligned item. (Or type dimaligned in the command prompt.) 

 

2) Select objects or <Specify first extension line origin>: When prompted, click to specify the first point to 

dimension. 

 

3) Specify second extension line origin: When prompted, click to specify the second point to dimension. 

 

4) Specify dimension line location or [Angle (A) / Multi-line Text (M) / Text (T)]: When prompted, click to 

specify the location of the dimension text. 

 

5) The aligned dimension is drawn. 

 

 

 

 

 

 

 

  



10-3. Arc Length (Dimarc) 

 

Draw an arc length dimension. 

 

1) Menu: Select the Dimension → Arc Length item. (Or type dimarc in the command prompt.) 

 

2) Select arc or polyline arc segment: When prompted, click the arc to dimension. 

 

3) Specify dimension arc location or [Partial (P) / Leader (L) / Angle (A) / Text (T)]: When prompted, click 

to specify the location of the arc length dimension. 

 

4) The arc length dimension is drawn. 

 

 

 

 

 

 

 

 

 

  



10-4. Ordinate (Dimordinate) 

 

Draw an ordinate dimension. Note that unless the UCS origin is changed, the dimension will be based on the 

absolute coordinates 0,0, which may result in incorrect values. To change the origin, type UCS in the 

command prompt, then type O and click the desired location (usually the lower-left point of the object). The 

UCS icon will move to the specified origin. 

 

1) Menu: Select the Dimension → Ordinate item. (Or type dimordinate in the command prompt.) 

 

2) Select point for ordinate dimension: When prompted, click to specify the point to dimension. 

 

3) Specify leader endpoint or [Text (T) / Angle (A) / X Datum (X) / Y Datum (Y)]: When prompted, click to 

specify the endpoint of the leader. 

 

4) Continue specifying points and leader endpoints as needed to complete the ordinate dimensions. 

 



 

 

  



10-5. Radius (Dimradius) 

 

Draw a radius dimension. 

 

1) Menu: Select the Dimension → Radius item. (Or type dimradius in the command prompt.) 

 

2) Select arc or circle: When prompted, click the arc or circle to dimension. 

 

3) Specify dimension line location or [Angle (A) / Multi-line Text (M) / Text (T)]: When prompted, click to 

specify the location of the radius dimension. 

 

4) The radius dimension is drawn. 

 

 

 

 

  



10-6. Diameter (Dimdiameter) 

 

Draw a diameter dimension. 

 

1) Menu: Select the Dimension → Diameter item. (Or type dimdiameter in the command prompt.) 

 

2) Select arc or circle: When prompted, click the arc or circle to dimension. 

 

3) Specify dimension line location or [Angle (A) / Multi-line Text (M) / Text (T)]: When prompted, click to 

specify the location of the diameter dimension. 

 

4) The diameter dimension is drawn. 

 

 

 

 

 

 

 

 

 

 

 

  



10-7. Angular (Dimangular) 

 

Draw an angular dimension. 

 

1) Menu: Select the Dimension → Angular item. (Or type dimangular in the command prompt.) 

 

2) Select objects or <Specify first line>: When prompted, click to specify the first line to dimension. 

 

3) Specify second line: When prompted, click to specify the second line to dimension. 

 

4) Specify dimension arc location or [Angle (A) / Text (T)]: When prompted, click to specify the location of 

the angular dimension. 

 

5) The angular dimension is drawn. 

 

 

 

 

 

 

 

 

 

 

  



10-8. Baseline (Dimbaseline) 

 

Draw a baseline dimension. 

 

1) Menu: Select the Dimension → Baseline item. (Or type dimbaseline in the command prompt.) 

 

2) Select dimension: When prompted, click to select the base dimension. 

 

3) Specify next extension line origin or [Undo (U)]: When prompted, click to specify the next extension line 

origin. 

 

4) Continue specifying extension line origins as needed to complete the baseline dimensions. 

 

5) Press Enter to finish the baseline dimension command. 

 

 

  



10-9. Continue (Dimcontinue) 

 

Draw a continued dimension. 

 

1) Menu: Select the Dimension → Continue item. (Or type dimcontinue in the command prompt.) 

 

2) Select dimension: When prompted, click to select the base dimension. 

 

3) Specify next extension line origin or [Undo (U)]: When prompted, click to specify the next extension line 

origin. 

 

4) Continue specifying extension line origins as needed to complete the continued dimensions. 

 

5) Press Enter to finish the continued dimension command. 

 

 

 

 

 

 

 

 

 

  



10-10. Center Mark (Dimcenter) 

 

Draw a center mark. 

 

1) Menu: Select the Dimension → Center Mark item. (Or type dimcenter in the command prompt.) 

 

2) Select arc or circle: When prompted, click the arc or circle to place the center mark. 

 

3) The center mark is drawn at the center of the selected arc or circle. 

 

 

 

 

 

 

 

 

 

 

 

 

  



10-11. Dimension Style (Dimstyle) 

 

The Dimension Style Manager allows you to configure the appearance of dimensions (e.g., dimension lines, 

extension lines, spacing), dimension text, tolerances, and more. You can create, modify, or override dimension 

styles. 

 

1) Menu: Select the Dimension → Dimension Style item. (Or type dimstyle in the command prompt.) 

 

2) The Dimension Style Manager dialog box appears. 

 

󰋮 Current Dimension Style: The currently active dimension style is displayed. 

 

󰋮 Preview: Display a preview of how dimensions will look with the current style. 

 

󰋮 Style List Options: Choose to display only the current dimension style or all styles. 

 

󰋮 Set Current: Set the selected dimension style as the current style. 

 

󰋮 New: Click the New button to create a new dimension style. Enter a name for the new style, choose a 

starting style, click Continue, then configure the new style settings and click OK to add the new 

dimension style. 



   

 

󰋮 Rename: Rename the selected dimension style. 

 

󰋮 Modify: Modify the selected dimension style settings. 

 

󰋮 Override: Display the Override dialog box to temporarily override dimension style settings. 

 

3) Modify Dimension Style 

 

3-1) Select the dimension style you want to modify from the list and click the Modify button. The 

Dimension Style Modify dialog box appears. 



 

  

󰋮 Lines tab: Change settings related to dimension lines and extension lines. 

 

∎ Dimension Lines: Change settings related to dimension lines. 

 

⋄ Color: Change the color of dimension lines. 

 

⋄ Line Type: Change the line type of dimension lines. 

 

⋄ Line Weight: Change the line weight of dimension lines. 

 

⋄ Extend Beyond Ticks: Extend the dimension lines beyond the tick marks. 

⋄ Baseline Spacing: Change the spacing for baseline dimensions. 

 



⋄ Suppress: Suppress the dimension lines to hide them. 

 

∎ Preview: Display a preview of the dimension settings. 

   

 

∎ Extension Lines: Change settings related to extension lines. 

 

⋄ Color: Change the color of extension lines. 

 

⋄ Line Type Extension Line 1: Change the line type of Extension Line 1. 

 

⋄ Line Type Extension Line 2: Change the line type of Extension Line 2. 

 

⋄ Line Weight: Change the line weight of extension lines. 

 

⋄ Extend Beyond Dim Lines: Change the length of extension lines beyond the dimension lines. 

 

⋄ Offset From Origin: Change the offset of extension lines from the dimension points. 

 

⋄ Suppress: Suppress the extension lines to hide them. 

 

󰋮 Symbols and Arrows tab: Change settings related to dimension symbols and arrows. 

 

∎ Arrowheads: Change the settings for dimension arrowheads. 

 



⋄ First: Change the shape of the first arrowhead. 

   

⋄ Second: Change the shape of the second arrowhead. 

 

⋄ Leader: Change the shape of the leader arrowhead. 

 

⋄ Arrow Size: Change the size of the arrows. 

 

∎ Center Marks: Change the settings for center marks. 

 

∎ Arc Length Symbols: Set the location of arc length symbols. 

 

󰋮 Text tab: Change settings related to dimension text. 

 

∎ Text Appearance: Set the appearance of dimension text. 

 

⋄ Text Style: Choose a text style for dimension text. 

 

⋄ Text Color: Change the color of dimension text. 

 

⋄ Fill Color: Change the background color of dimension text. 

 



⋄ Text Height: Set the height (size) of dimension text. Note that this only applies if the text height in the text 

style is set to 0. 

 

⋄ Draw Frame Around Text: Draw a frame (rectangle) around the dimension text. 

 

∎ Text Placement: Set the placement of dimension text. 

 

⋄ Vertical: Set the vertical placement of dimension text. 

   

⋄ Horizontal: Set the horizontal placement of dimension text. 

   

 

⋄ View Direction: Set the view direction of dimension text. 

 

⋄ Offset From Dim Line: Set the distance around dimension text. 

∎ Text Alignment: Set the alignment of dimension text. 

 

󰋮 Fit tab: Change settings related to the placement and scaling of dimensions. 

 



∎ Fit Options: Set how text and arrows are placed between extension lines. 

  

 

 

∎ Text Placement: Set how text is placed when it cannot be placed in its default position. 

   

∎ Scale for Dimension Features: Set the scale for dimension features. 

   

∎ Fine Tuning: Set additional options for dimension placement. 

   

󰋮 Primary Units tab: Change settings related to primary dimension units. 

 

∎ Linear Dimensions: Set the units for linear dimensions. 

⋄ Unit Format: Change the unit format for linear dimensions. 



   

⋄ Precision: Change the precision for linear dimensions. The available options depend on the unit format. 

   

⋄ Decimal Separator: Set the decimal separator. 

   

⋄ Round Off: Set the rounding precision. 

 

⋄ Prefix: Set a prefix for linear dimensions. 

 

⋄ Suffix: Set a suffix for linear dimensions. 

 

∎ Measurement Scale: Set the scale factor for dimension measurements. 

 

∎ Zero Suppression: Set whether to suppress leading or trailing zeros for linear dimensions. 

   



∎ Angular Dimensions: Set the units and precision for angular dimensions. 

   

∎ Zero Suppression: Set whether to suppress leading or trailing zeros for angular dimensions. 

   

󰋮 Alternate Units tab: Change settings related to alternate dimension units. 

 

∎ Show alternate units: If Display alternative units is checked on, alternate units will be displayed when 

creating dimensions. (This option must be checked on to activate the items below.) 

∎ Alternate Units: Set the format, precision, prefix, suffix, etc., for alternate units. 

  

∎ Zero Suppression: Set whether to suppress leading or trailing zeros for alternate units. 

   

∎ Placement: Set the placement of alternate units. 



   

󰋮 Tolerances tab: Change settings related to dimension tolerances. 

 

∎ Tolerance Format: Set the tolerance method, precision, upper and lower values, etc. 

   

∎ Alternate Unit Tolerances: Set the tolerance method, precision, upper and lower values, etc., for alternate 

units. 

 

 

 



󰋮 Reset the settings for the current tab. 

 

󰋮 Reset all dimension settings. 

 

 

  



10-12. Update (Dimstyle, Apply) 

 

Update existing dimensions to the current dimension style. 

 

1) Menu: Select the Dimension → Dimension Style item. 

 

2) Select objects to apply the current style: When prompted, click to select the dimensions to update and press 

Enter. 

 

3) The selected dimensions are updated to the current dimension style. 

     

Previous dimension style       Update dimensions after changing dimscale=3 

 

 

 

 

 

 

 

 

  



11. CADian 2026 Menu - Modify  

 

11-1. Properties Switch (Propertiesswitch) 

 

Toggle the Properties window. 

 

1) Menu: Select the Modify → Properties item. 

 

2) The Properties window is toggled on if it is currently off, and toggled off if it is currently on. 

 Properties window on 

 Properties window off 

 

Tip: Pressing Ctrl+1 also toggles the Properties window. 

 

  



11-2. Text Edit (Textedit) 

 

Edit text. 

 

1) Menu: Select the Modify → Entity → Text item. (Or type textedit in the command prompt.) 

 

2) Select annotation object or [Undo (U) / Mode (M)]: When prompted, click to select the text to edit. 

 

3) The text enters edit mode. 

 

 

4) Enter the new text. Use the Del or BS key to delete characters. 

 

 

5) When finished, press Enter. If prompted again, press Enter to end the command. 

 

 

  



11-3. Hatch Edit (Hatchedit) 

 

Edit a hatch. 

 

1) Menu: Select the Modify → Entity → Hatch item. (Or type hatchedit in the command prompt.) 

 

2) Select hatch object: When prompted, click to select the hatch to edit. 

 

 

3) The Hatch and Gradient dialog box appears, allowing you to change the hatch pattern, color, angle, scale, etc. 

Click OK when finished. 

 

  



11-4. Polyline Edit (Editpline) 

 

Edit a polyline. 

 

1) Menu: Select the Modify → Entity → Polyline item. (Or type pedit in the command prompt.) 

 

2) Multiple (M) / Select polyline to edit: When prompted, click to select the polyline to edit. 

 

 

3) Polyline Edit: Vertex Edit (E) / Close (C) / Decurve (D) / Fit (F) / Join (J) / Linetype Mode (L) / Reverse 

(R) / Spline (S) / Taper (T) / Width (W) / Undo (U) / <Exit (X)>: When prompted, enter the desired option. 

 

󰋮 Vertex Edit: Edit the position of polyline vertices. 

   

 

󰋮 Close: Close the polyline by connecting the end point to the start point. 



   

 

󰋮 Decurve: Convert a curved polyline back to its original straight segments. 

   

 

󰋮 Fit: Convert to a smooth curve composed of arcs. 

   

 

󰋮 Spline: Convert to a smooth curve composed of spline curves. 

   

 



󰋮 Taper: Set the taper for the polyline. Specify starting width <0>: When prompted, enter the starting width 

→ Specify ending width <0>: When prompted, enter the ending width. 

   

󰋮 Width: Set the overall width for the polyline. Enter new width for all segments: When prompted, enter the 

new width. 

   

 

󰋮 Undo: Undo the polyline edit and return to the previous state. 

 

 

 

  



11-5. Open External Reference (Xopen) 

 

Open an external reference file. 

 

1) Menu: Select the Modify → Entity → External Reference → Open External Reference item. (Or type 

xopen in the command prompt.) 

 

2) Select external reference: When prompted, click to select the external reference file to open. 

 

3) The selected external reference file opens in a new drawing window. 

 

 

 

 

 

 

  



11-6. Clip External Reference (Xclip) 

 

Clip an external reference file to a desired shape. 

 

1) Menu: Select the Modify → Entity → External Reference → Clip External Reference item. (Or type xclip 

in the command prompt.) 

 

2) Select object: When prompted, click to select the external reference file to clip → Press Enter. 

 

3) On (ON) / Off (OFF) / Clip depth (C) / Delete (D) / Generate Polyline (P) / New boundary (N) / <Create new 

boundary (N)>: When prompted, press Enter to create a new boundary. 

 

4) [Select polyline (S) / Polygon (P) / Rectangle (R) / Invert Clip (I)] <Rectangle (R)>: When prompted, press Enter 

to select the rectangle option. 

 

5) Specify first corner: When prompted, click to specify the first corner of the clipping area → Specify opposite 

corner: When prompted, click to specify the opposite corner. 

 

6) The external reference object is clipped to the specified shape. 

 

 

  



11-7. Xclip Frame (Xclipframe) 

 

Set the frame for an external reference clip. 

 

1) Menu: Select the Modify → Entity → External Reference → Xclip Frame item. 

 

2) Enter new value for XCLIPFRAME <2>: When prompted, enter the desired value. 

 

󰋮 0: Frame is not displayed and not printed. 

󰋮 1: Frame is displayed and printed. 

󰋮 2: Frame is displayed but not printed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-8. Refedit 

 

Edit an external reference object (xref) or block. 

 

1) Menu: Select the Modify → Entity → External Reference → Refedit item. (Or type refedit in the command 

prompt.) 

 

2) Select reference object: When prompted, click to select the external reference or block to edit. 

 

3) The Reference Edit dialog box appears. Select the item to edit from the list on the left → Check the preview 

on the right → Click OK. 

 

 

4) Use REFCLOSE to end the reference edit session. The selected external reference or block can now be edited. 

 

 

 

  



11-9. Add to Workset (Refedit, Add) 

 

Add objects to the workset while editing an external reference (xref) or block. 

 

1) Menu: Select the Modify → Entity → External Reference → Add to Workset item. 

 

2) Select objects to add: When prompted, click to select the objects to add to the workset → Press Enter. 

 

3) A message confirms that the selected objects have been added to the workset. 

 

 

 

 

 

 

 

 

 

 

 

  



11-10. Remove from Workset (Refedit, Remove) 

 

Remove objects from the workset while editing an external reference (xref) or block. 

 

1) Menu: Select the Modify → Entity → External Reference → Remove from Workset item. 

 

2) Select objects to remove: When prompted, click to select the objects to remove from the workset → Press 

Enter. 

 

3) A message confirms that the selected objects have been removed from the workset. 

 

 

 

 

 

 

 

  



11-11. Close Reference (Refclose) 

 

Ends editing of external reference objects (xrefs) and blocks. 

 

1) Menu: Select Modify → Entities → External Reference → Close Reference. (Or type refclose in the 

command prompt.) 

 

2) Enter option [Save (S)/Discard reference changes (D)] <Save>: When prompted, press Enter. 

 

3) Save all reference edits: When the dialog box appears, click Save. 

 

4) The reference edit command ends after saving the edited block. 

 

 

 

 

 

 

 

  



11-12. Erase 

 

Erase objects from the drawing. 

 

1) Menu: Select the Modify → Erase item. (Or type erase in the command prompt.) 

 

2) Select objects to erase: When prompted, click or drag to select the objects to erase → Press Enter. 

 

3) The selected objects are erased. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-13. Copy 

 

Press Enter to finish the command. 

 

1) Menu: Select the Modify → Copy item. (Or type copy in the command prompt.) 

 

2) Select objects to copy: When prompted, click to select the objects to copy → Press Enter. 

 

3) Specify base point or [Displacement (D) / Mode (O)] <Displacement>: When prompted, click to specify the base 

point of the copy. 

 

4) Specify second point or [Array (A)] <Use first point as displacement>: When prompted, click to specify the 

location of the copy or enter coordinates. 

 

 

5) Continue specifying additional points for the copies. Press Enter to finish the command. 

 

 

  



11-14. Mirror 

 

Mirror and copy objects in the drawing. 

 

1) Menu: Select the Modify → Mirror item. (Or type mirror in the command prompt.) 

 

2) Select objects to mirror: When prompted, click to select the objects to mirror → Press Enter. 

 

3) Specify first point of mirror line: When prompted, click to specify the start point of the mirror line → 

Specify second point: When prompted, click to specify the end point of the mirror line. 

. 

 

 

4) Delete source objects? <N>: When prompted, press Enter to keep the original objects. 

 

5) The selected objects are mirrored and copied. 

 

 

  



11-15. Offset 

 

Copy objects at a specified offset distance. 

 

1) Menu: Select the Modify → Offset item. (Or type offset in the command prompt.) 

 

2) Specify offset distance or [Through (T)] <Through>: When prompted, enter the offset distance or click to 

specify it with the mouse. 

 

3) Select object to offset: When prompted, click to select the object to offset. 

 

4) Specify point on side to offset or [Exit (E) / Multiple (M)] <Exit>: When prompted, click to specify the 

side to offset the object. 

 

5) The selected object is offset to the specified distance. 

 

 

6) Press Enter to finish the command. 

 

 

 

  



11-16. Array (Arrayclassic) 

 

Create an array of objects in a specified pattern (rectangular or polar). 

 

1) Type arrayclassic in the command prompt. 

 

2) The Array dialog box appears. 

 

 

󰋮 : Choose the array method (Rectangular or Polar). 

 

󰋮 : Click to select the objects to array. 

 

󰋮 Preview: Preview the array. 

 

 

 

 



   

 

󰋮 Rectangular Array: Set the spacing and direction for the rows and columns. 

    

 

∎ Row Spacing: Set the spacing between rows. 

 

∎ Column Spacing: Set the spacing between columns. 

 

∎ Angle of Array: Set the angle of the array. 

 

󰋮 Polar Array: Set the method and values for the polar array. 

 



    

 

∎ Method: Choose the method for the polar array (Total number of items and fill angle, or item angle and fill angle). 

 

∎ Total Number of Items: Set the total number of items in the polar array. 

 

∎ Fill Angle: Set the fill angle for the polar array. 

 

∎ Angle Between Items: Set the angle between items in the polar array. 

 

 

 

 

 

  



11-17. Align 

 

Align objects with other objects. 

 

1) Menu: Select the Modify → Align item. (Or type align in the command prompt.) 

 

2) Select objects: When prompted, click to select the objects to align → Press Enter. 

 

3) Specify first source point: When prompted, click to specify the first source point. 

 

4) Specify first destination point: When prompted, click to specify the first destination point. 

 

 

5) Specify second source point: When prompted, click to specify the second source point. 

 

6) Specify second destination point: When prompted, click to specify the second destination point. 

 

 

 

7) Enter to finish: Press Enter to complete the alignment. 

8) Scale objects based on alignment points? [Yes/No] <No>: When prompted, press Enter. 



 

9) The selected objects are aligned and scaled based on the destination points. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-18. Move 

 

Move objects in the drawing. 

 

1) Menu: Select the Modify → Move item. (Or type move in the command prompt.) 

 

2) Select objects to move: When prompted, click to select the objects to move → Press Enter. 

 

3) Specify base point or [Displacement (D)] <Displacement>: When prompted, click to specify the base point of 

the move. 

 

4) Specify second point or <Use base point as displacement>: When prompted, click to specify the new location for 

the objects or enter coordinates. 

 

5) The selected objects are moved to the specified location. 

 

 

  



11-19. Rotate 

 

Rotate objects in the drawing. 

 

1) Menu: Select the Modify → Rotate item. (Or type rotate in the command prompt.) 

 

2) Select objects to rotate: When prompted, click to select the objects to rotate → Press Enter. 

 

3) Specify base point of rotation: When prompted, click to specify the base point for rotation. 

 

 

4) Specify rotation angle or [Copy (C) / Reference (R)] <0>: When prompted, specify the rotation angle by clicking 

or entering a value and pressing Enter. 

 

 

5) The selected objects are rotated. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-20. Scale 

 

Scale objects in the drawing. 

 

1) Menu: Select the Modify → Scale item. (Or type scale in the command prompt.) 

 

2) Select objects to scale: When prompted, click to select the objects to scale → Press Enter. 

 

3) Specify base point: When prompted, click to specify the base point for scaling. 

 

 

4) Scale objects based on reference length or scale factor [Copy (C) / Reference (R)] <Scale factor>: When 

prompted, specify the scale factor by entering a value or clicking to specify it with the mouse. 

 

5) The selected objects are scaled based on the specified factor. 

 

 

  



11-21. Stretch 

 

Stretch objects in the drawing. 

 

1) Menu: Select the Modify → Stretch item. (Or type stretch in the command prompt.) 

 

2) Select objects to stretch by crossing-window or crossing-polygon: When prompted, drag a crossing window 

or crossing polygon to select the objects to stretch → Press Enter. 

 

 

3) Specify base point or [Displacement (D)] <Displacement>: When prompted, click to specify the base point for 

stretching. 

 

4) Specify second point or <Use base point as displacement>: When prompted, click to specify the new location 

for the objects or enter coordinates. 

 

5) The selected objects are stretched. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-22. Lengthen 

 

Change the length of objects or the included angle of arcs. 

 

1) Menu: Select the Modify → Lengthen item. (Or type lengthen in the command prompt.) 

 

2) Lengthen: Dynamic (DY) / Delta (DE) / Percent (P) / Total (T) / <Select object to list length>: When 

prompted, type DE and press Enter. 

 

3) Angle (A) / <Enter delta length (10)>: When prompted, enter the delta length value. 

 

4) Mode (M) / Undo (U) / <Select object to change length>: When prompted, click to select the object to 

change length. The selected object is lengthened by the specified amount. 

 

Line object with length 10 

 

Line lengthened by 10 

 

  



11-23. Trim 

 

Trim parts of objects. 

 

1) Menu: Select the Modify → Trim item. (Or type trim in the command prompt.) 

 

2) Select cutting edges <Press Enter to select all objects>: When prompted, press Enter to select all objects as 

cutting edges. 

 

3) [Fence (F) / Crossing (C) / Projection (P) / Edge (E) / Erase (R) / Undo (U)] <Select object to trim or shift-

select to extend>: When prompted, click or drag to select the objects to trim. 

 

4) The selected parts of the objects are trimmed. 

 

 

 

 

  



11-24. Extend 

 

Extend objects to meet the edges of other objects. 

 

1) Menu: Select the Modify → Extend item. (Or type extend in the command prompt.) 

 

2) Select boundary edges <Press Enter to select all objects>: When prompted, click to select the boundary 

edges or press Enter to select all objects. 

 

 

3) [Fence (F) / Crossing (C) / Projection (P) / Edge (E) / Erase (R) / Undo (U)] <Select object to extend or shift-

select to trim>: When prompted, click or drag to select the objects to extend. 

 

 

4) The selected objects are extended to the specified boundary edges. 



 

 

5) Press Enter to finish the command. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-25. Break 

 

Break objects between two points. 

 

1) Menu: Select the Modify → Break item. (Or type break in the command prompt.) 

 

2) Select object to break: When prompted, click to select the object to break → Press Enter. 

 

 

3) When prompted, click to specify the first break point or [First (F)], then click again to specify the second break 

point. 

 

 

4) The object is broken between the specified points. 

 

 

 

 

 

 

  



11-26. Chamfer 

 

Chamfer the corners of objects with straight lines, as if cut by a knife. 

 

1) Menu: Select Modify → Chamfer. (Or type chamfer in the command prompt.) 

 

2) Select the first line or [Undo (U)/Polyline (P)/Distance (D)/Angle (A)/Trim (T)/Method (E)/Multiple (M)]: When 

prompted, type D and press Enter → Chamfer distance for the first line <0>: Enter the distance for the first 

chamfer → Chamfer distance for the second line <10>: Enter the distance for the second chamfer → Press Enter. 

 

3) Select the first line or [Undo (U)/Polyline (P)/Distance (D)/Angle (A)/Trim (T)/Method (E)/Multiple (M)]: When 

prompted, click to select the first line to chamfer. 

 

4) Select the second line or shift-select to apply corner: When prompted, click to select the second line to chamfer. 

 

5) The two lines will be chamfered by the specified distances. 

 

  



11-27. Fillet 

 

Fillet the corners of objects with curves. 

 

1) Menu: Select Modify → Fillet. (Or type fillet in the command prompt.) 

 

2) Fillet: [Undo (U)/Polyline (P)/Radius (R)/Trim (T)/Multiple (M)]/<Select first entity>: When prompted, type R 

and press Enter → Enter fillet radius <0>: Enter the fillet radius → Press Enter. 

 

3) Fillet: [Undo (U)/Polyline (P)/Radius (R)/Trim (T)/Multiple (M)]/<Select first entity>: When prompted, click to 

select the first line to fillet. 

 

 

4) Select the second line or shift-select to apply corner: When prompted, click to select the second line to fillet. 

 

 

5) The two lines will be filleted with the specified radius. 

 

 

 

 

  



11-28. Explode 

 

Explode a block object into its individual components. 

 

1) Menu: Select Modify → Explode. (Or type explode in the command prompt.) 

 

2) Select object to explode: When prompted, click to select the block object to explode → Press Enter. 

 

3) The block is immediately exploded into its individual components. 

 

Before Exploding the Block                      After Exploding the Block  

 

 

 

 

 

 

 

  



11-29. Change 

 

Change the properties of an object. 

 

1) Menu: Select Modify → Change. 

 

2) Select object to change: When prompted, click to select the object whose properties you want to change → Press 

Enter. 

 

3) Specify change point or [Properties (P)]: When prompted, click to specify the point to change → Specify new 

rotation angle for block <0.000000>: Enter the rotation angle or specify an angle value → Press Enter. 

 

 

4) Specify change point or [Properties (P)]: When prompted, type P and press Enter → Enter new properties [Color 

(C)/Elevation (E)/Layer (LA)/Linetype (LT)/Linetype scale (S)/Lineweight (LW)/Thickness (T)/Material 

(M)/Annotation (A)]: When prompted, you can change various properties such as color, layer, linetype, and 

more. 

 

 

 

 

  



11-30. Draw Order, Bring to Front 

 

Bring selected objects to the front to ensure they are not obscured by other objects. 

 

1) Menu: Select Modify → Draw Order → Bring to Front. 

 

2) Select entities for draw order: When prompted, select the objects to bring to the front → Press Enter. 

 

3) The selected objects are brought to the front and are no longer obscured by other objects. 

 

 

The text is hidden by the object.         Set the text to come to the front.  

 

 

 

 

 

 

 

 

 

 

  



11-31. Draw Order, Send to Back 

 

Send selected objects to the back to ensure they are obscured by other objects. 

 

1) Menu: Select Modify → Draw Order → Send to Back. 

 

2) Select entities for draw order: When prompted, select the objects to send to the back → Press Enter. 

 

3) The selected objects are sent to the back, making them obscured by other objects. 

     

The text is hidden by the object.       Set the blue ellipse to go to the back. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-32. Draw Order, Bring Above Object 

 

Bring selected objects one level up to ensure they are not obscured by a specific object. 

 

1) Menu: Select Modify → Draw Order → Bring Above Object. 

 

2) Select entities for draw order: When prompted, select the objects to bring above → Press Enter. 

 

3) Select reference object: When prompted, select the reference object → Press Enter. 

 

4) The selected objects are brought above the reference object. 

 

    

The text is hidden by the object.       The text is brought above the blue ellipse,  

which is the reference object. 

 

 

 

 

 

 

 

 

 

  



11-33. Draw Order, Send Under Object 

 

Send selected objects one level down to ensure they are obscured by a specific object. 

 

1) Menu: Select Modify → Draw Order → Send Under Object. 

 

2) Select entities for draw order: When prompted, select the objects to send under → Press Enter. 

 

3) Select reference object: When prompted, select the reference object → Press Enter. 

 

4) The selected objects are sent under the reference object. 

   

The text is displayed above the object.  The text is sent under the blue ellipse,  

which is the reference object. 

 

 

 

 

 

 

 

 

 

 

  



11-34. Draw Order, Send Hatches to Back 

 

Send all hatches to the back to ensure they do not obscure other objects. 

 

1) Menu: Select Modify → Draw Order → Send Hatches to Back. 

 

2) All hatches are immediately sent to the back. 

 

    

The text is hidden by the object.         The text appears as the hatch is sent to the back. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-35. Draw Order, Bring Text to Front 

 

Bring all text to the front to ensure it is not obscured by other objects. 

 

1) Menu: Select Modify → Draw Order → Bring Text to Front. 

 

2) All text is immediately brought to the front. 

    

Teks terhalang oleh objek.       Ketika teks dipindahkan ke depan, teks menjadi terlihat. 

 

 

 

 

 

 

 

 

 

 

 

  



11-36. Draw Order, Bring Leaders to Front 

 

Bring all leaders to the front to ensure they are not obscured by other objects. 

 

1) Menu: Select Modify → Draw Order → Bring Leaders to Front. 

 

2) All leaders are immediately brought to the front. 

   

The leader is hidden by the object.  The leader appears as it is brought to the front. 

 

 

 

 

 

 

 

 

 

 

 

  



11-37. Draw Order, Bring Dimensions to Front 

 

Bring all dimensions to the front to ensure they are not obscured by other objects. 

 

1) Menu: Select Modify → Draw Order → Bring Dimensions to Front. 

 

2) All dimensions are immediately brought to the front. 

    

The dimension is hidden by the object. The dimension appears as it is brought to the front. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



11-38. Draw Order, Bring All Annotations to Front 

 

Bring all annotations (text, leaders, dimensions) to the front to ensure they are not obscured by other 

objects. 

 

1) Menu: Select Modify → Draw Order → Bring All Annotations to Front. 

 

2) All annotations are immediately brought to the front. 

   

The annotation is hidden by the object.    All annotations are brought to the front,  

making them visible. 

 

 

 

 

 

 

 

 

 

 

  



11-39. Rectangular Array 

 

Create an array of objects in a rectangular pattern. 

 

1) Menu: Select Modify → Array → Rectangular Array. (Or type arrayrect in the command prompt.) 

 

2) Select entities: When prompted, click or drag to select the objects to array. 

 

3) The objects are displayed in a 3x4 preview array. Press Enter to complete the array. 

 

 

4) Click the array and use the grips to adjust the number of rows and columns. 

 

 

 

  



11-40. Polar Array 

 

Create an array of objects in a circular pattern with specified spacing and angle. 

 

1) Menu: Select Modify → Array → Polar Array. (Or type arraypolar in the command prompt.) 

 

2) Select entities: When prompted, click or drag to select the objects to array. 

 

3) Specify center point of array: When prompted, click to specify the center point of the array or enter 

coordinates. 

 

4) The objects are displayed in a 5-item preview array with 60-degree spacing. Press Enter to complete the 

array. 

 

5) Click the array and use the grips to adjust the spacing (angle) of the objects. 

 

 

 

 

  



11-41. Path Array 

 

Create an array of objects along a specified path. 

 

1) Menu: Select Modify → Array → Path Array. (Or type arraypath in the command prompt.) 

 

2) Select entities: When prompted, click or drag to select the objects to array. 

 

3) Select path curve: When prompted, click to select the path object. 

 

 

4) The objects are arrayed along the specified path. Press Enter to complete the array. 

 

 

5) Click the array and use the grip to adjust the spacing of the objects. 

 

 

  



11-42. Array Edit 

 

Edit the properties of an array (e.g., number of items, spacing, angle). 

 

1) Menu: Select Modify → Array → Array Edit. (Or type arrayedit in the command prompt.) 

 

2) Select array object: When prompted, click to select the array to edit. 

 

3) Choose an option [Source (S)/Replace (REP)/Method (M)/Base Point (B)/Items (I)/Rows (R)/Levels 

(L)/Align Items (A)/Z Direction (Z)/Reset (RES)/Exit (X)] <Exit>: When prompted, select the desired 

option to edit the array properties. 

 

 

 

 

 

 

  



12. CADian 2026 Menu - Utility 

 

12-1. Super Purge 

 

This command removes unused objects (blocks, line styles, text styles, dimension styles, etc.), empty objects, 

and unused scale lists from the drawing. 

 

1) Menu: Select Utility → Super Purge. 

 

2) Super purge is performed automatically. 

 

3) When prompted "Remove unused scale list? (Y/N)<Y>:", type 'y' to remove the unused scale list. 

 

 

  



· Command: DRECT 

· Dialog(D)/<Start Point>: Enter "D". (This calls the dialog box.) 

 

12-2. Drawing - Rectangle 

 

This command draws rectangles and diamonds, automatically rounding corners and adding chamfers and 

scallops. 

 

 

 

 

 

❏ Drawing Method: In the dialog box illustration, select the shape and drawing method. The top row allows drawing 

both rectangles and squares, while the bottom row is for drawing squares only. 

 

❏ Fillet: Set the fillet shape and radius value. 

 

 

❏ Chamfer: Enter the horizontal and vertical distance values for the chamfer. 



· Dialog(D)/<Start Point>: Click point ⓐ. 

· Dialog(D)/<Start Point>: Click point ⓑ. 

· Dialog(D)/<Start Point>: Click point ⓒ. 

 

 

 

❏ Dimension Input: Enter the width and height of the box to be drawn numerically. 

 

• Width: Set the thickness of the line drawing the box. 

• Height: Set the 3D thickness of the box. 

 

 

 

 

 

         

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

· Command: DRECT 

· Dialog(D)/<Start Point>: Enter "D". (This calls the dialog box.) 

 

        

 

· Dialog(D)/<Start Point>: Click point ⓐ. 

· Dialog(D)/<Start Point>: Click point ⓑ. 

     

 

 

 

 

 



 

· Command: DRECT 

· Dialog(D)/<Start Point>: Enter "D". (This calls the dialog box.) 

 

 

     

 

· Dialog(D)/<Start Point>: Click point ⓐ. 

· Dialog(D)/<Start Point>: Click point ⓑ. 

· Dialog(D)/<Start Point>: Click point ⓒ. 

 

 

 

  



12-3. Drawing – Polygon 

 

This command draws polygons, allowing automatic rounding and chamfering of each vertex. 

 

· Command: PGON 

· Enter number of sides <5>: Enter "5" or press Enter. (Enter the number of sides for the polygon to be 

drawn.) 

· Polygon start point or [Fillet(F)/Chamfer(C)]: Enter "F". 

· Specify fillet radius for polygon <0.0000>: Enter "5". (Enter the radius for filleting.) 

· Polygon start point or [Fillet(F)/Chamfer(C)]: Click point ⓐ. 

· Polygon [Inscribed(I)/Circumscribed(C)/Edge(E)/Fixed Angle(A)]/<Circumscribed radius>: 

Enter "I". 

· Polygon [Inscribed(I)/Circumscribed(C)/Edge(E)/Fixed Angle(A)]/<Inscribed radius>: Click 

point ⓑ. (If you know the radius of the inscribed circle, you can enter the radius value directly.) 

 

 

 

 

            

 

 

  



12-4. Drawing - Slot 

 

Automatically draws a slot hole. 

 

❏ Slot Hole Drawing 1 

 

 

· Command: DSLOT 

· Slot Hole[Slot/Flange] / <Start Point>: Click point ⓐ. 

· Slot Radial: Enter "20". (Enter the radius of the slot hole.) 

 

 

 

· Slot Length: Click point ⓑ. (Enter the distance between points.) 

 

 

❏ Slot Hole Drawing 2 

 

· Command: DSLOT 

· Slot Hole[Slot(S)/Flange(F)/One Side(I)/Center(C)] / <Start Point>: Enter "C". 

· Slot Hole[Slot(S)/Flange(F)/One Side(I)/Center(C)] / <Start Point>: Click point ⓐ. 

· Slot Radial: Enter "20". (Enter the radius of the slot hole.) 



 

 

 

· Slot Length: Enter "40". (Enter the distance from point ⓐ to the center of the arc.) 

 

 

❏ Flange Drawing 

 

· Command: DSLOT 

· Slot Hole[Slot/Flange] / <Start Point>: Enter "F". 

· Slot Hole[Slot/Flange] / <Start Point>: Click point ⓐ. 

· Slot Radial: Enter "20". 

 

 

 

· Slot Length: Click point ⓑ. 

 



 

 

· Slot Radius: Click point ⓒ. 

 

 

 

 

 

 

 

 

 

 

  



12-5. Drawing - Break Line 

 

Draws break lines in the drawing. 

 

 

· Command: BKLINE 

· Break Line [Size(S)(5)]/<Start Point>: Enter "S". (Enter the spacing for the break line.) 

· Size (5): Enter "10". 

· Break Line [Size(S)(10)]/<Start Point>: Click a point. 

· Break Line [Size(S)(10)]/<Start Point>: Click a point.  

· Cut point <Midpoint>: Press Enter. (Draws the break line in the middle of the selected line. If 

you want to draw the break line at a different location, click near the desired position.) 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-6. Drawing - Cylindrical Section 

 

Draws circular cross-sections for round bars and pipes. 

 

 

· Command: BKSEC 

· Cylindrical Section [One Side(S)/Both Sides(D)]: Click point ⓐ. (If you enter D, the cross-section 

lines will be drawn on both sides centered on the two selected points.) 

· End Point: Click point ⓑ. 

 

 

 

 

 

 

 

 

 

 

 

  



12-7. Curve - Show Curve Direction 

 

Shows the direction of the curve. The symbol used for indicating direction will disappear automatically. 

 

· Command: CURVEDIR 

· Select curve [Show at Vertex(V)/Show at Distance(D)]: Click point ⓐ to select the curve. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-8. Curve - Convert to Polyline 

 

Select objects like lines, arcs, and circles to convert them to polylines. 

 

· Command: CURVEPOLY 

 

 

 

12-13. Curve - Change Polyline Width 

 

Select a polyline, line, or arc to automatically change the width of the polyline. If lines and arcs are selected, 

their properties will be changed to polylines. 

 

· Command: POLYWIDTH 

· Select entities: Click point ⓐ to select the curve. 

· Select entities: Press Enter to end the selection. 

 

 

 

· Polyline width <1>: Enter "2". 

 

 

 

 

  



12-9. Curve - Edit Polyline 

 

Vertices and lines of the drawn polyline can be modified into curves, and curves into lines. New objects can 

be inserted between objects, and objects between them can be deleted. For smooth editing of polylines, 

ORTHOMODE should be off. 

 

· Command: POLYEDIT 

· Select object: Click point ⓐ to select the polyline. 

 

 

 

· Polyline vertex insert 

[Remove(R)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Insert 

Point>: After selecting the polyline, dragging allows object insertion at the cursor's 

position. 

 

 

 



 

· Polyline vertex insert 

[Remove(R)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Insert 

Point>: Click point ⓑ. 

 

      

 

· Polyline vertex insert 

[Remove(R)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Insert 

Point>: Enter "R". 

 

· Polyline vertex insert 

[Add(A)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Remove 

Point>: Click point ⓒ. (Removes objects between objects.) 

 

 



Polyline vertex insert [Add(A)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] 

<Remove Point>: Enter "M". 

· Polyline vertex insert 

[Add(A)/Remove(R)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Move 

Point>: Click point ⓓ. 

 

 

 

 

 

   

· Polyline vertex insert 

[Add(A)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Move Point>: 

Enter "S". 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Stretch 

Point>: Click point ⓓ. 

 



    

 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] 

<Stretch Point>: Enter "C". 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(M)/Stretch(S)/Arc(c)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] 

<Arc Point>: Click point ⓔ. 

 

 

       

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Stretch(S)/Tangent(T)/Line(L)/Fixed(F)/Exit(X)] <Arc 

Point>: Enter "T". 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Stretch(S)/Arc(C)/Line(L)/Fixed(F)/Exit(X)] <Tangent>: 

Click point ⓕ. (Draws a tangent to the closest object to the cursor position.) 



 

 

      

 

·Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Stretch(S)/Arc(C)/Tangent(T )/Fixed(F)/Exit(X)] <Tangent>: 

Enter "L". 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Stretch(S)/Arc(C)/Tangent(T )/Fixed(F)/Exit(X)] <Line>: 

Click point ⓖ. (Moves the cursor over an arc object to change it to a line.) 

 

     

 

 

· Polyline vertex insert 

[Add(A)/Remove(R)/Move(S)/Stretch(S)/Arc(C)/Tangent(T )/Fixed(F)/Exit(X)] <Line>: 

Enter "A". 

 

· Polyline vertex insert 

[Remove(R)/Move(S)/Stretch(S)/Arc(C)/Line(L)/Tangent(T )/Fixed(F)/Exit(X)] <Insert 



· Polyline vertex insert 

[Remove(R)/Move(S)/Stretch(S)/Arc(C)/Line(L)/Tangent(T )/Fixed(F)/Exit(X)

] <Insert Point>: Enter "X" to end the command. 

 

Point>: Enter "F". (Each time the cursor moves, the insert operation occurs automatically 

at the cursor's new location. The fixed option locks the insert function at the cursor's 

current location.) 

 

· Polyline vertex insert 

[Remove(R)/Move(S)/Stretch(S)/Arc(C)/Line(L)/Tangent(T )/Fixed(F)/Exit(X)] <Insert 

Point>: Click point ⓗ. 

 

      

 

 

 

 

  



12-10. Curve - Change Object Z Value 

 

Select an object and enter a 3D coordinate value (Z value) to change the object's 3D coordinate value. 

 

· Command: CURVEZ 

 

 

12-11. Curve - Join Lines 

 

Join objects such as lines and arcs with connected endpoints into polylines. 

 

· Command: LINEJOIN 

 

  



12-12. Modify - XY Scale 

 

Change the horizontal and vertical scales of the selected object differently. Once the scale is changed, the 

selected polyline object is exploded into lines or arcs. 

 

· Command: XYSCALE 

· Select object: Click points ⓐ and ⓑ to select the object. 

 

    

 

 

· Base point: Click point ⓒ. 

· X Scale Factor or Point [Reference(R)/Copy Original(C)/ <2>]: Enter "1". 

· Y Scale Factor <3>: Enter "2". 

 

   

 

· XY Scale Factor <2,1>: (Informs the final applied scale factor.) 

 

  



12-13. Modify - Offset Both Sides 

 

Select an object to automatically offset it in both directions. 

 

· Command: DOST 

· Specify Offset Distance <100>: Enter "1000". 

· Select Offset Object: Click point ⓐ to select the object. 

 

      

 

· Select Offset Object: Press Enter to end the command. 

 

 

 

 

 

 

 

 

  



12-14. Modify - Repeat Offset 

 

Automatically draw selected objects repeatedly at a specified interval. 

 

· Command: RPOST 

· Specify Repeat Offset Distance :<10> Enter "1000". 

· Select Offset Object: Click point ⓐ to select the object. 

· Specify Offset Direction: Click point ⓑ to select the direction. 

 

       

 

· Enter Number of Repeats: Enter "3". 

 

       

 

· Select Offset Object: Press Enter to end the command. 

 

 

 

  



12-15. Modify - Incremental Offset 

 

This command continuously offsets the selected objects incrementally. 

 

 

· Command: INCOST 

· Select Offset Object: Click point ⓐ to select the object. 

· Specify Offset Direction: Click point ⓑ to select the direction. 

 

 

 

· Specify Incremental Offset Distance: Enter "1000". 

 

 

 

· Specify Incremental Offset Distance: Enter "2000".   

 

 



· Specify Incremental Offset Distance: Press Enter to end the command. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-16. Modify - Incremental Offset Both Sides 

 

This command takes user input to continuously offset both sides incrementally. 

 

· Command: INCDOST 

· Select Offset Object Both Sides: Click point ⓐ to select the object. 

 

       

 

· Specify Incremental Offset Distance: Enter "1000". 

· Specify Incremental Offset Distance: Enter "2000". 

      

     

 

· Specify Incremental Offset Distance: Press Enter to end the command. 

 

 

 

 

 

 

  



12-17. Modify - Remove Empty Objects 

 

This command removes empty objects such as lines, polylines, arcs, circles (objects with identical start and 

end points), and empty strings. (Points will be handled as an option.) 

 

· Command: ERASEEMPTYENT 

 

 

  



12-18. Text - Modify Text 

 

This command allows easy modification of selected text properties (height, color, angle, etc.), text editing, and 

insertion or deletion of text at specific positions. When an object is selected, the dialog box below is activated. 

Using the functions in the dialog box makes text modification easy and convenient. 

 

 

❏ Change Properties 

· Command: TEXTMODIFY 

· Select text: Click points ⓐ and ⓑ to select the text objects. 

 

 

· Select objects: Press Enter to end the selection, and the dialog box below will be activated. 



 

 

 

• Text Box: The selected text is listed in a cell format, and the text on the right can be individually edited directly 

by clicking with the mouse. 

• Text Height: When the dialog box is activated, it displays the current text size in the system. Changing the text 

height will change the height of all selected text. Clicking the toggle box (modify selected items only) at the 

bottom right will change the height property of only the selected text in the text box. 

• Rotation Angle: When the dialog box is activated, it displays the current text rotation angle in the system. 

Changing the text rotation angle will change the rotation angle of all selected text. Clicking the toggle box 

(modify selected items only) at the bottom right will change the rotation angle of only the selected text in the text 

box. 

• Width Factor: When the dialog box is activated, it displays the current text width in the system. Changing the 

text width will change the width property of all selected text. Clicking the toggle box (modify selected items 

only) at the bottom right will change the width property of only the selected text in the text box. 

• Obliquing Angle: When the dialog box is activated, it displays the current text obliquing angle in the system. 

Changing the text obliquing angle will change the obliquing angle of all selected text. Clicking the toggle box 

(modify selected items only) at the bottom right will change the obliquing angle of only the selected text in the 

text box. 



• Text Color: When the dialog box is activated, it displays the current text color in the system. Changing the text 

color will change the color property of all selected text. Clicking the toggle box (modify selected items only) at 

the bottom right will change the color property of only the selected text in the text box. 

• Upside Down: Clicking the checkbox will flip the text vertically. 

• Backwards: Clicking the checkbox will mirror the text horizontally. 

• Justification: When the dialog box is activated, it displays the current text justification in the system. Changing 

the text justification will change the justification property of all selected text. Clicking the toggle box (modify 

selected items only) at the bottom right will change the justification property of only the selected text in the text 

box. 

       

 

• Text Style: When the dialog box is activated, it displays the current text style in the system. Changing the text 

style will change the style of all selected text. Clicking the toggle box (modify selected items only) at the bottom 

right will change the style of only the selected text in the text box. 

• Modify Selected Items Only: Clicking the checkbox will apply property changes only to the selected text in the 

text box. 

• Preview: This feature allows you to preview text property changes before applying them to the drawing. Clicking 

the Preview button will hide the dialog box and apply the changed properties to the text. To return to the dialog 

box, press the "Esc" button. The text properties will not be changed until the Confirm button is clicked. 

 

 

 

❏ Modify Text 

 

· Command: TEXTMODIFY 



· Select text: Click points ⓐ and ⓑ to select the text objects. 

     

 · Select objects: Press Enter to end the selection, and the dialog box below will be 

activated. Click the Modify Text tab. 

 

    

 

• Replace: Automatically changes specific characters (strings) in all selected text. 

• Parentheses: Clicking the Parentheses button allows you to add or remove parentheses characters in the selected 

text. 

• Case: Clicking the Case button automatically changes the text case based on the selected option. 



· Select objects: Press Enter to end the selection, and the dialog box below 

will be activated. Click the Remove Text tab. 

 

- Upper Case: Changes all selected text to upper case. 

- Lower Case: Changes all selected text to lower case. 

- Capitalize First Letter: Changes the first letter of all selected text to upper case. 

- Toggle Case: Changes upper case to lower case and vice versa for all selected text. 

• Add Text: Adds text to the beginning, end, or specified position of all selected text. Prefix, middle, and suffix 

can be added separately or simultaneously. 

 

❏ Remove Text 

 

· Command: TEXTMODIFY 

· Select text: Click points ⓐ and ⓑ to select the text objects. 

 

    

 

 

      



 

 

 

• Insert/Remove Space: Inserts or removes spaces at the selected position in the selected text. 

• Specific Character: Specify and remove characters included in the selected text by choosing the option to remove 

and clicking the specific character button. If the same character appears multiple times, it will execute from the 

leftmost position and can be repeatedly clicked to move rightward. Text is case-sensitive. 

• Trim: Enter the number of characters and choose the option to trim, then click the Trim button to automatically 

cut the text. Text is case-sensitive. 

 

 

 

 

 

 

  



12-19. Text - Increment Numbers 

 

Repeatedly copies the selected number by adding an increment value. 

 

❏ Increment at the Beginning of the Text 

 

· Command: TEXTINC 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

 

  

 

· Select objects: Press Enter to end the selection. 

· Increment value <1>: Enter "2". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Enter "F". 

· Base point: Click point ⓒ. 

· Specify next point: Click points ⓓ, ⓔ, ⓕ consecutively. 

· Specify next point: Press Enter to end the command. 

 

    

❏ Increment at the End of the Text 



 

· Command: TEXTINC 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

 

    

 

· Select objects: Press Enter to end the selection. 

· Increment value <1>: Enter "1". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Enter "B". 

· Base point: Click point ⓒ. 

· Specify next point: Click points ⓓ, ⓔ, ⓕ consecutively. 

· Specify next point: Press Enter to end the command. 

 

    

 

 

 

 

❏ Increment "?" in the Text 



 

If "?" is included in the drawn text, it can be changed to a number and incremented. If both "?" and a number 

are included, only the number is incremented, ignoring the "?". 

 

· Select objects: Click point ⓐ to select the objects. 

 

 

     

 

· Increment value <1>: Enter "1". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Press Enter. 

 

     

 

· Base point: Click point ⓑ. 

· Specify next point: Click the desired location to draw the text. (Continuing to click points 

will increment and draw the numbers automatically, and pressing Enter will end the 

command.) 

 

 

 

 

  



12-20. Text - Linear Consecutive Numbers 

 

Draws text with specified increment values at regular intervals for the numbers included in the selected text. 

❏ Drawing 1 

 

· Command: LINCTEXT 

· Select text: Click point ⓐ to select the text. 

 

     

 

· Select objects: Press Enter. 

· Increment value <1>: Enter "2". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Enter "F". 

· Base point: Click point ⓑ. 

· Specify distance: Enter "1000". (You can also use the mouse to enter the distance 

between two points.) 

· Specify position: Click point ⓒ. (Dragging the crosshair to the right will display 

incremented text at 1000 intervals. Click near the displayed text to automatically draw it.) 

 



     

❏ Drawing 2 

If "?" is included in the drawn text, it can be changed to a number and incremented. If both "?" and a number 

are included, only the number is incremented, ignoring the "?". 

 

Command: LINCTEXT 

Select text: Click point ⓐ to select the text. 

 

    

 

· Select objects: Press Enter. 

· Increment value <1>: Enter "2". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Press Enter. 

· Base point: Click point ⓑ. 

· Specify distance: Enter "1000". (You can also use the mouse to enter the distance between two 

points.) 

· Specify position: Click point ⓒ. (Dragging the crosshair to the right will display 

incremented text at 1000 intervals. Click near the displayed text to automatically draw it. 

If the text includes numbers, it will ignore the "?" and increment the numbers.) 

 

12-21. Text - Circular Consecutive Numbers 



 

Draws text with specified increment values in a circular direction for the numbers included in the selected 

text. 

 

❏ Drawing 1 

 

· Command: PINCTEXT 

· Select text: Click point ⓐ to select the text. 

· Select objects: Press Enter. 

· Increment value <1>: Enter "1". 

· Number of digits <1>: Enter "1". 

· Number position [Front(F)/Back(B)]: Enter "F". 

· Center point: Click point ⓑ. (Use OSNAP <“CEN”> to click the center point of the 

circle.) 

· Number of items [Angle Between(A)/Rotate Text(R)] <4>: Enter "12". (Enter the 

number of copies to rotate.) 

 

                                 

 

· Angle to fill [Rotate Text(R)] (+=CCW, -=CW) < 360 >: Enter "R" 

 

 



  

 

· Angle to fill [Rotate Text(R)] (+=CCW, -=CW) < 360 >: Enter "360". 

 

❏ Drawing 2 

If "?" is included in the drawn text, it can be changed to a number and incremented. If both "?" and a number 

are included, only the number is incremented, ignoring the "?". 

 

· Command: PINCTEXT 

· Select text: Click point ⓐ to select the text. 

· Select objects: Press Enter. 

· Increment value <1>: Enter "1". 

· Number of digits <1>: Enter "2". 

· Number position [Front(F)/Back(B)]: Press Enter. 

· Center point: Click point ⓑ. (Use OSNAP <“CEN”> to click the center point of the 

circle.) 

· Number of items [Angle Between(A)/Rotate Text(R)] <4>: Enter "12". (Enter the 

number of copies to rotate.) 

 

 

 



 

 

· Angle to fill [Rotate Text(R)] (+=CCW, -=CW) < 360 >: Enter "360". 

 

 

 

 

 

 

 

 

 

  



12-22. Text - Insert Number 

 

This command allows adding sequential numbers to the selected text based on specified rules. 

 

· Command: TEXTNUMBERING 

· Select text: Click points ⓐ and ⓑ to select the objects. 

· Select objects: Press Enter. 

 

 

 

· Start value [Dialog(D)] < 1 > : Enter "D". (The dialog box below will be activated.) 

 

 

 

• Start Value: Enter the first value of the starting number. 

• Increment Value: Enter the number to increment. 

• Number of Digits: Enter the number of digits for the added number (e.g., 001). 

• Add Text: Enter the text to add before or after the number (e.g., TA-001-L). 

• Number of Spaces: Enter the number of spaces to add before or after the added text. 



• Add Text Position 

- Front: Add at the beginning of the selected text (e.g., TEXT => T1L TEXT). 

- Middle: Add in the middle of the selected text (e.g., TEXT => TE T1L XT). 

- End: Add at the end of the selected text (e.g., TEXT => TEXT T1L). 

• Order of Creation 

- Left to Right: Numbers increment from left to right based on the starting point of the selected text. 

- Top to Bottom: Numbers increment from top to bottom based on the starting point of the selected text. 

- Selection Order: Numbers increment in the order the text is selected. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-23. Text - Text Border 

 

Automatically draws increasing text within a shape or adds shapes around existing text. 

 

 

• New Creation: Draw shapes and text at user-specified locations. 

• Existing Text: Select existing text to draw shapes around it. 

• Start Value: Specify the first number to start. 

• Increment Value: Specify the increment value. 

• Number of Digits: Enter the number of digits. 

• Prefix: Specify text to add before the number. Leave blank if not needed (e.g., AA001). 

• Suffix: Specify text to add after the number. Leave blank if not needed (e.g., 001BB). 

• Leader Line: Select the option to draw leader lines. 

• Align to Center of Shape: The endpoint of the leader line aligns with the center of the shape. 

• Align to Shape Sides: The leader line is automatically centered on the shape's side based on its position. 

 

<After clicking Confirm...> 



 

· Leader Line Position: Click point ⓐ. 

· Mark Position: Click point ⓑ. 

· Leader Line Position: Click point ⓒ. 

· Mark Position: Click point ⓓ. 

· Leader Line Position: Press Enter to end the command. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-24. Text - Align Text 

 

This command allows automatic alignment of multiple text strings to the left, right, or top, among other 

options. 

 

❏ Vertical Alignment 

 

· Command: TEXTARRANGE 

· Select text: Click points ⓐ and ⓑ to select the objects. 

· Select objects: Press Enter. 

· Alignment Point: Click point ⓒ. (After clicking, drag the crosshair centered for 

alignment.) 

 

 

 

· Align Text [Horizontal(H)/Vertical(C)/Spacing(S)/Alignment: 

Left(L)/Center(C)/Right(R)/Bottom(B)/Middle(M)/Top(T)/Apply Properties(A)]: Enter 

"L". (Drag the crosshair centered for left alignment.) 

 



     

 

· Align Text [Horizontal(H)/Vertical(C)/Spacing(S)/Alignment: 

Left(L)/Center(C)/Right(R)/Bottom(B)/Middle(M)/Top(T)/Apply Properties(A)]: Enter 

"S". 

· Text Spacing: Click points ⓓ and ⓔ. (The selected text will be evenly spaced as shown 

below.) 

  

 

     

 

· Align Text [Horizontal(H)/Vertical(C)/Spacing(S)/Alignment: 

Left(L)/Center(C)/Right(R)/Bottom(B)/Middle(M)/Top(T)/Apply Properties(A)]: Click 

point ⓕ. (Dragging the mouse toward point ⓕ will automatically snap to the previously 

clicked alignment point, and clicking will align the text as shown below.) 

       



       

 

❏ Vertical Alignment 

 

Command: TEXTARRANGE 

· Select text: Click points ⓐ and ⓑ to select the objects. 

· Select objects: Press Enter. 

· Alignment Point: Click point ⓒ. (After clicking, drag the crosshair for alignment as 

shown below. The text is aligned to the bottom as shown.) 

  

    

 

· Align Text [Horizontal(H)/Vertical(C)/Spacing(S)/Alignment: 

Left(L)/Center(C)/Right(R)/Bottom(B)/Middle(M)/Top(T)/Apply Properties(A)]: Enter 

"M". (The crosshair moves to the center of the text, and dragging starts from the center 

point as shown below.) 

     



    

 

 

· Align Text [Horizontal(H)/Vertical(C)/Spacing(S)/Alignment: 

Left(L)/Center(C)/Right(R)/Bottom(B)/Middle(M)/Top(T)/Apply Properties(A)]: Click point ⓓ. 

(Using OSNAP <“MID”>, click point ⓓ to align the text in the middle of the box as shown 

below.) 

 

     

 

 

 

 

 

 

 

 

 

  



· Select text to copy: Press Enter to end the command. 

 

12-25. Text - Copy Text 

 

This command copies the text content of the original text without changing its properties. 

 

· Command: TEXTCOPY 

· Select original text: Click point ⓐ to select the original text. 

· Select text to copy: Click point ⓑ to select the original text.  

 

     

 

     

      

 

 

12-26. Text - Swap Text 

 

This command swaps the content of the text while retaining the text properties. 

 

· Command: TEXTSWAP 

· Select text: Click point ⓐ to select the text. 

· Select text to swap: Click point ⓑ to select the text to swap. 

 

        

  



12-27. Text - Append Text 

 

Select two text strings, and the second selected string will be appended to the end of the first. The combined 

text will adopt the properties of the first text string. 

 

· Command: TEXTADD 

· Select text: Click point ⓐ to select the original text. 

· Select objects: Press Enter. 

· Select text to append: Click point ⓑ to select the text to append. 

      

      

 

 

 

 

 

 

 

 

 

 

 

  



12-28. Block - Insert Multiple Blocks 

 

This command inserts multiple blocks automatically when selecting duplicate block files and can also create 

a title block accordingly. 

  

 

Add: Click the Add button to activate the dialog box below. Select the block to insert and click the Open 

button. 



 

 

• Remove: Delete the selected block from the list. 

• Pitch: Click the Pitch button to deactivate the dialog box. Click two points in the rectangle to simultaneously 

input the horizontal and vertical pitch values. 

• Pitch X: Click the X button to deactivate the dialog box. Click two points on the line to input the X pitch value. 

• Pitch Y: Click the Y button to deactivate the dialog box. Click two points on the line to input the Y pitch value. 

• Spacing: Click the Spacing button to deactivate the dialog box. Click two points in the rectangle to simultaneously 

input the horizontal and vertical spacing values. 

• Spacing X: Click the X button to deactivate the dialog box. Click two points on the line to input the X spacing 

value. 

• Spacing Y: Click the Y button to deactivate the dialog box. Click two points on the line to input the Y spacing 

value. 



       

 

• GAP: Checking the checkbox sets the input values of pitch X and Y as the inside spacing of the title block, as 

shown below. 

   

  

• Outline: If the checkbox is not checked, the outline box of the title block will not be drawn. 

• Block Name Entry: Set whether to enter the block name in the title block. 

• Number of Cells: Enter the number of cells for placement. If the number of blocks exceeds the entered number 

of cells, rows are automatically added for drawing. 

• Text Height: Set the text size for the block name. 

• Internal Block: Insert the inserted block as a block property. 

• Explode: If the checkbox is checked, the block will be inserted in an exploded state. 



• External Reference: The inserted block will be inserted as an external reference. 

• Relative Path: The external reference block will be inserted with a relative path property. 

 

· Command: MINS 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-29. Block - Insert Multiple Images 

 

This command inserts multiple images. 

 

· Command: MIMAGE 

 

 

12-30. Block - Insert External Reference 

 

Selecting an externally referenced block changes its properties to a block within the drawing. 

 

· Command : XREFINS 

 

 

12-31. Block - Detach External Reference 

 

Selecting an externally referenced block detaches (deletes) the external reference from the drawing. 

 

· Command: XREFDETACH 

 

 

12-32. Block - Unload External Reference 

 

Selecting an externally referenced block unloads it. To reload, use the external reference command. 

 

· Command: XREFUNLOAD 

 

  



12-33. Block - Rename Block 

 

When a block object is selected, the dialog box below is activated, allowing the user to rename the block. 

    

 

Command : BLOCKRENAME 

 

 

 

 

 

  



12-34. Block - Add Object to Block 

 

This command inserts user-selected objects into an inserted block. 

 

· Command: APPENDBLKENT 

· Select block: Click a point to select the block object. 

· Select object: Click a point to select the object to add. (The "CADian" text object is 

added to the block.) 

  

     

 

 

12-35. Block - Remove Object from Block 

 

Selecting a specific object within an inserted block deletes it. The command process is the same as the delete 

command. 

 

Command : REMOVEBLKENT 

 

 

 

  



12-36. Block - Copy Object within Block 

 

Selecting an object within an inserted block allows you to copy a specific object within the block. The 

command process is the same as the copy command. 

 

Command : COPYBLKENT 

 

 

12-37. Block - Explode Multiple Inserted Blocks 

 

This command explodes blocks inserted with MINSERT. 

 

Command: MULTBLOCKEXP 

 

 

 

  



12-38. Array - Linear Array 

 

This command allows dynamically dragging and arranging selected objects in a straight line.(The text size of 

the array information display help is proportional to the "PICKBOX" value.) 

 

· Command: LARRAY 

· Select objects: Click point ⓐ to select the objects. 

· Enter number of items [Base point(B)] <10> : Enter "5". (Dragging the cursor 

dynamically changes the array spacing and angle as shown below.) 

 

                            

 

· Enter spacing <100> : Enter "800". (You can also specify the spacing by selecting a 

point.) 

· Linear array [Base point(B)/Count(C)/Spacing(S)/Rotate objects(R)/Exit(X)] Angle: 

<0.00>: Enter "45". 

 

                                        

 

 

  



12-39. Array - Circular Array 

 

This command allows arranging selected objects in a circular pattern while visually confirming the 

placement. 

 

· Command: PARRAY 

· Select objects: Click point ⓐ to select the objects. 

· Select objects: Press Enter. 

· Center point: Click point ⓑ. 

· Enter number of items [Angle Between(A)] <4> : Enter "10". 

 

  

 

· Angle to fill (+=CCW, -=CW) < 360 > : Enter "270". 

   

  

 

· Circular array [Base point(B)/Count(C)/Angle between items(S)/Angle to fill(D)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] : Enter "R". 

· Enter number of rows <1> : Enter "3". 

 



 

 

· Circular array [Base point(B)/Count(C)/Angle between items(S)/Angle to 

fill(D)/Rows(R)/Row spacing(RS)/Rotate objects(RO)/Exit(X)] : Enter "RS". 

· Enter row spacing <100> : Enter "900". 

 

 

 

· Circular array [Base point(B)/Count(C)/Angle between items(S)/Angle to 

fill(D)/Rows(R)/Row spacing(RS)/Rotate objects(RO)/Exit(X)] : Enter "X" to end the 

command. 

 

 

 

 

 

 

  



12-40. Array - Rectangular Array 

 

Select the objects to array and drag the cursor to dynamically display the objects in rows and columns on the 

screen. The user can quickly and accurately execute the array command by viewing the displayed array. 

 

· Command: RARRAY 

· Select objects: Click point ⓐ to select the objects. 

· Select objects: Press Enter. 

· Enter number of items [Array Angle(A)/Number of Items(C)] : Enter "C". 

 

    

 

· Enter number of columns <3>: Enter "4". 

· Enter number of rows <1>: Enter "3". 

  

 

 

· Enter item spacing [Spacing(S)] : Enter "S". 

· Enter column spacing [Total Length(L)] <2418.1> : 2400 

· Enter row spacing [Total Length(L)]<2418.1> : 3000 



    

 

· Rectangular array [Columns(C)/Rows(R)/Column spacing(CS)/Row spacing(RS)/Array 

angle(A)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "X" or click the left mouse button. 

(Forcing the command to end before it is completely finished may result in an incomplete 

array.) 

 

 

 

 

  



 

12-41. Array - Path Array 

 

This command dynamically, quickly, and accurately arrays objects along a selected curve. 

 

❏ Open Curve Segment 

 

· Command: CARRAY 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

· Select objects: Press Enter. 

· Select curve: Click point ⓒ and select the curve. (Selecting the curve dynamically and 

automatically arrays the objects from the start point of the curve. The default reference 

point for arraying objects is the center point. To change the reference point, enter "B".) 

 

      

  

· Enter number of items [Base point(B)/Start position(SP)/Rotate objects(RO)] <10> : 

Enter "4". (The number of dynamically arrayed objects is set to 4.) 

      



      

 

· Enter item spacing [Equal Spacing(F) <3000> : Enter "F". (Arrays objects at equal 

intervals along the selected curve. The array is not complete until the command is ended. 

The objects shown are virtual.) 

· Path array [Base point(B)/Number of items(C)/Spacing(S)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "B". 

· Base point: Click point ⓓ. (The reference point may flip vertically depending on the 

starting direction of the curve.) 

 

     

 

· Path array [Base point(B)/Number of items(C)/Spacing(S)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "RO". 

 



     

 

· Path array [Base point(B)/Number of items(C)/Spacing(S)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "R". 

 

     

 

· Enter number of rows(1): Enter "2". 

 

     

 

· Path array [Base point(B)/Number of items(C)/Spacing(S)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "X" to end the command. (The 

objects are drawn when the exit command is given. Forcing exit with the "Esc" key will 

delete the virtual objects and cancel the array command.) 

❏ Closed Curve Segment 



 

· Command: CARRAY 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

· Select objects: Press Enter. (In the case of a circle as shown below, the  

start point is at 0 degrees. To change the start point, enter "SP".) 

 

    

 

· Enter number of items [Base point(B)/Start position(SP)/Rotate objects(RO)] <10> : 

Enter "SP". 

· Start point: Click point ⓓ. 

· Array direction: Click point ⓔ. (Moving the crosshair in the opposite direction reverses 

the arrow direction.) 

 

      



 

· Enter number of items [Base point(B)/Start position(SP)/Rotate objects(RO)] <10> : 

Enter "8". 

· Enter item spacing [Equal Spacing(F)] <2352.47> : Enter "F". 

 

 

      

 

· Path array [Base point(B)/Number of items(C)/Spacing(S)/Rows(R)/Row 

spacing(RS)/Rotate objects(RO)/Exit(X)] <Exit> : Enter "X" to end the command. 

 

 

 

  



12-42. Array - Vector Array 

 

This command arranges objects in rows and columns in a rhomboid shape instead of a rectangle. 

 

· Command: VARRAY 

· Select objects: Click point ⓐ to select the objects. 

· Select objects: Press Enter. 

· Base point: Click point ⓑ. 

· X-axis direction: Click point ⓒ. 

· Y-axis direction: Click point ⓓ. 

 

     

 

· Array endpoint: Click point ⓔ. (Moving the crosshair arrays the objects in a rhomboid 

shape as shown below. Row spacing is based on the distance between points, and column 

spacing is based on the distance between and points.) 

 

     

· Vector array [Number of columns(C)/Number of rows(R)/Column spacing(CS)/Row 

spacing(RS)/Exit(X)] : Enter "R". 

· Enter number of rows <4>: Enter "3". 



  

 

· Vector array [Number of columns(C)/Number of rows(R)/Column spacing(CS)/Row 

spacing(RS)/Exit(X)] : Enter "CS". 

· Enter column spacing [Total Length(L)] <5000> : Enter "8000". 

 

     

 

· Vector array [Number of columns(C)/Number of rows(R)/Column spacing(CS)/Row 

spacing(RS)/Exit(X)] : Enter "X" to end the command. 

 

 

12-43. Dimension - Linear Dimension 

 

After clicking two points to dimension, move the cursor as shown below to automatically switch between 

vertical, horizontal, and aligned dimensions. When the desired dimension line is displayed, click to place the 

dimension line. 

 

Command : LDIM 

 

 

  



12-44. Dimension - Circular Dimension 

 

Selecting a circle or arc allows automatically drawing linear, diameter, angle dimensions, etc., based on the 

crosshair position or option settings. 

 

❏ Selecting a Circle 

The dimension line type is determined by the crosshair position as shown below. Entering the "R" or "D" 

keyword automatically switches between radius and diameter. 

 

Command : CDIM 

 

❏ Selecting an Arc 

· Command: CDIM 

· Select arc or circle: Click point ⓐ to select the arc. 

 

     

 

· Specify dimension line position [Diameter(D)/Radius(R)/Angle(A)/Arc Length(L)/Chord 

Length(C)/Exit(X)]: Enter "R". (Switches to radius dimension as shown below.) 

 

     

 

· Specify dimension line position [Diameter(D)/Radius(R)/Angle(A)/Arc Length(L)/Chord 

Length(C)/Exit(X)]: Enter "A". (Switches to angle dimension as shown below. If an object 

intersects the arc, it automatically finds the intersection point and displays the angle 



dimension line.) 

 

     

    

· Specify dimension line position [Diameter(D)/Radius(R)/Angle(A)/Arc Length(L)/Chord 

Length(C)/Exit(X)]: Enter "L". (Displays the arc length dimension line at the crosshair 

position as shown below.) 

    

  

 

· Specify dimension line position [Diameter(D)/Radius(R)/Angle(A)/Arc Length(L)/Chord 

Length(C)/Exit(X)]: Enter "C". (Automatically finds and displays the chord length at the 

crosshair position as shown below.) 

 

    

 

 

  



12-45. Dimension - Object Dimension 

 

This command allows selecting multiple objects to dimension at once and automatically finds the objects at 

the crosshair position to place dimensions. 

 

· Command: OBJDIM 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

 

   

 

· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc 

Length(L)/Chord Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: 

Click point ⓒ to draw the dimension line. (After drawing the dimension line, a virtual 

dimension line is displayed at the cursor position for the next dimension line.) 

 

    

 



· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc 

Length(L)/Chord Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: 

Enter "I". (Automatically draws dimension lines only to the intersection points. Applying 

the "I" option ignores intersections and draws the full dimension.) 

· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc 

Length(L)/Chord Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: 

Click point ⓓ to draw the dimension line. (After drawing the dimension line below, enter 

"I" again to return to the intersection function and automatically draw the dimension 

line.) 

 

    

 

· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc Length(L)/Chord 

Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: Enter "A". (Move the 

crosshair to an arc object to automatically draw the angle dimension line.) 

· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc 

Length(L)/Chord Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: 

Click point ⓔ to draw the angle dimension line. 



     

 

· Specify dimension line position 

[Horizontal(H)/Vertical(V)/Aligned(G)/Diameter(D)/Radius(R)/Angle(A)/Arc 

Length(L)/Chord Length(C)/Intersection(I)/Specify point(P)/Exit(X)] <Aligned,Diameter>: 

Enter "X" to end the command. 

 

“As explained above, applying each function key during the command allows for various dimension styles.” 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



12-46. Dimension - Outline Dimension 

 

This command automatically finds and draws the outline dimensions of selected objects. Move the crosshair 

to draw the desired shape of the virtual dimension line, and click to place it. The outline dimensioning function 

can be applied in real-time, allowing adjustments while the virtual dimension line is displayed. The drawn 

dimension line adopts the current dimension style. 

 

· Command: OUTDIM 

· Select objects: Click points ⓐ and ⓑ to select the objects. 

   

   

 

 

 

 

 

 

 

· <When the objects are selected, virtual dimension lines are automatically drawn to the 

external points of the objects as shown above. Users can change the crosshair position to 

set the dimension line position. When the final position is specified, the dimension line is 

automatically drawn.> 

· Specify dimension line position 

[Continuous(C)/Zigzag(Z)/Baseline(B)/Multiple(S)/Vertical 

Coordinate(O)/Origin(G)/Overall(A)/One Side(I)/Both Sides(D)/Exit(X)] : Enter "B". (The 

dimension line input method automatically changes to baseline dimensioning based on the 

crosshair position. The dimension line is not drawn until the position is clicked.) 



    

 

· Specify dimension line position 

[Continuous(C)/Zigzag(Z)/Baseline(B)/Multiple(S)/Vertical 

Coordinate(O)/Origin(G)/Overall(A)/One Side(I)/Both Sides(D)/Exit(X)] : Enter "I". (The 

dimension line is virtually drawn only in the direction of the crosshair as shown below.) 

 

 

    

 

· Specify dimension line position 

[Continuous(C)/Zigzag(Z)/Baseline(B)/Multiple(S)/Vertical 

Coordinate(O)/Origin(G)/Overall(A)/One Side(I)/Both Sides(D)/Exit(X)] : Enter "D". (The 

dimension line is virtually drawn vertically and horizontally in the direction of the 

crosshair as shown below.) 

 



     

 

· Specify dimension line position 

[Continuous(C)/Zigzag(Z)/Baseline(B)/Multiple(S)/Vertical 

Coordinate(O)/Origin(G)/Overall(A)/One Side(I)/Both Sides(D)/Exit(X)] : Enter "G". 

(Aligns the start points of the dimension extension lines as shown below.) 

 

· Specify dimension line position [Continuous(C)/Zigzag(Z)/Baseline(B)/Multiple(S)/Vertical 

Coordinate(O)/Origin(G)/Overall(A)/One Side(I)/Both Sides(D)/Exit(X)] : Enter "Z". 

(Continuous dimension text is staggered up and down, useful for tightly spaced dimensions, as 

shown below.) 

 

· [One Side(I)/Both Sides(D)/Exit(X)] : Click point ⓒ to draw the dimension line and end 

the command as shown below. 

 

    

 

 

 

 

  



12-47. Dimension - Curve Length Dimension 

 

This command automatically draws the length and radius when selecting curves (polylines, splines, ellipses) 

as shown below. (The text size applies the current dimension style's text size [text size X dimension scale 

"DIMSCALE"].) 

 

❏ Selecting a Polyline 

 

· Command: CURVELEN 

· Show length, radius [Length and Radius(A)/Length(L)/Radius(R)/Intersection(I)] : Click 

point ⓐ to select the polyline object. 

 

     

 

❏ Selecting Multiple Intersecting Objects 

 

· Command: CURVELEN 

· Show length, radius [Length and Radius(A)/Length(L)/Radius(R)/Intersection(I)] : Enter "I". 

· Show intersection points [Length and Radius(A)/Length(L)/Radius(R)/Intersection(I)] : 

Click points ⓐ and ⓑ to select the objects. (Automatically creates lengths for all 

intersecting parts between objects.) 

 



     

 

 

 

 

 

 

 

 

  



13. CADian 2026 Menu - Windows 

 

13-1. New Window (Wopen) 

 

Opens the current drawing in a new window. 

 

1) Menu: Select Windows → New Window. 

 

2) A new window opens, creating another instance of the current drawing. 

 

 

  



13-2. Close 

 

Closes the current drawing. 

 

1) Menu: Select Windows → Close. (Or type "close" in the command line) 

 

2) The current drawing closes immediately. If the drawing is not saved, a prompt to save the drawing appears. 

 

 

 

 

13-3. Close All Drawings (Closeall) 

 

Closes all open drawings. 

 

1) Menu: Select Windows → Close All. 

 

2) All drawings close immediately. If any drawing is not saved, a prompt to save the drawings appears. 

 

 

 

  



13-4. Cascade Windows (Wcascade) 

 

Arranges all open drawings in a cascade. 

 

1) Menu: Select Windows → Cascade. 

 

2) All drawings are arranged in a cascade immediately. 

 

 

 

 

 

 

  



13-5. Tile Horizontally (Whtile) 

 

Arranges all open drawings horizontally. 

 

1) Menu: Select Windows → Tile Horizontally. 

 

2) All drawings are arranged horizontally immediately. 

 

 

 

 

 

 

 

  



13-6. Tile Vertically (Wvtile) 

 

Arranges all open drawings vertically. 

 

1) Menu: Select Windows → Tile Vertically. 

 

2) All drawings are arranged vertically immediately. 

 

 

 

 

 

 

 

  



13-7. Arrange Icons (Wiarrange) 

 

Arranges minimized drawing windows so that their icons are located in the bottom left corner of the 

window. 

 

1) Menu: Select Windows → Arrange Icons. 

 

2) All drawings are minimized and their icons are located in the corner immediately. 

 

  



13-8. Windows (Window) 

 

Arranges multiple drawing windows or activates the selected drawing. 

 

1) Menu: Select Windows → Window. 

 

2) The window screen appears immediately. 

 

󰋮 Activate: Activates the selected drawing from the list on the left. 

 

󰋮 Save: Saves the selected drawing from the list on the left. 

 

󰋮 Close Window: Closes the selected drawing from the list on the left. 

 

󰋮 Minimize: Minimizes the selected drawing from the list on the left. 

 

 

 

 

 

 

 

 



14. CADian 2026 Menu - Help 

 

14-1. Help (Help) 

 

Calls the help function of CADian. 

 

1) Menu: Select Help → CADian Help. (Or type "help" in the command line or press the F1 key on the 

keyboard) 

 

2) The CADian Help window appears. 

 

 

3) In the Contents tab on the left, click on the command list to view help for the commands. 



 

 

4) In the Index tab on the left, type the desired command to view the help. 

 

  



14-2. Tip of the Day (Tipofday) 

 

Calls the Tip of the Day function in CADian. 

 

1) Menu: Select Help → Tip of the Day. (Or type "tipofday" in the command line) 

 

2) The Tip of the Day appears in the bottom right corner of the CADian window. 

 

 

 

 

 

 

 

 

 

 

  



14-3. CADian Webpage (Onweb) 

 

Displays the CADian homepage via the internet browser. 

 

1) Menu: Select Help → CADian on the Web. 

 

2) The internet browser opens and displays the CADian homepage (www.cadian.com). 

 

 

 

 

 

 

 

 

  



14-4. About CADian (About) 

 

Displays information about CADian (version, registration details, etc.). 

 

1) Menu: Select Help → About CADian. (Or type "about" in the command line) 

 

2) The CADian information window appears. 

 

 

 

  



14-5. CADian License Information 

 

Displays the registration information of CADian (serial number, etc.). 

 

1) Menu: Select Help → CADian License Information. 

 

2) The CADian License Information window appears. 

 

 

 

  



15. CADian 2026 Menu - Utility 

 

15-1. SDM (Smart Dimension) 

 

 

 

Smart Dimension: SDM 

Run SDM to open the dialog. It provides 10 automatic dimensioning options along with layer/style settings 

and more. Below is an overview of each option’s purpose. 

 

Option 1 "Hor/Ver Dimension" 

As the main function of Smart Dimension, it was created to automatically apply overall dimensioning for 



typical drawings. It recognizes objects and places dimensions; if a rectangle exists inside, its endpoints are 

recognized and dimensions are placed at the nearest quadrant. 

(Spline objects are not supported for dimensioning.) 

 

 

Basic usage: run SDM, then click the broom icon next to "Dimension style settings" (Copy dimension style). 

Select the target dimension style and apply it. (DIMDLI also follows the copied style settings.) 

If you change dimension variables like DIMSCALE, DIMTXT, or DIMASZ in the command line, incorporate 

those changes into the dimension style, then dimension using that style and copy the style for reuse. 

 



 

When you load a dimension style this way, the loaded style becomes the current style with scale set 

to 1. This includes a feature to exclude the outer R (arc) portions so arc endpoints are not 

incorrectly dimensioned as linear dimensions, among other behaviors. 

 

 

There is also an "Select Layer to Ecxlude" feature (e.g., for centerlines). If centerlines protrude 

outside the object, you can exclude their layers. SDM can apply the dimension line color 

consistently so dimension and extension lines follow the same color (e.g., yellow). 

 

Option 2 "Hor/Ver Dimension Select" 

Use this option when you want dimensions only in a specific direction in the drawing. See the 

illustration below. 

This option lets you dimension only the desired direction, and it also includes the overall length in 

the dimensioning result. 



 

 

Option 3 "Hor/Ver Dimension Block" 

This option quickly places dimensions for the outer extents of block objects. Note in the example 

that for "Block 2" on the right, dimensioning extends to the end of the centerline. 



 

 

Option 4 "Hor/Ver Vertex Dimension" 

This option adds linear dimensions between vertices of an open or closed polyline. 

 

 

Option 5 "Dim. Between Vertices of Polyline" 

This option dimensions the distance between vertices of an open or closed polyline. Unlike Option 

4, when arcs are included it reports the arc length, which is useful for showing lengths of polylines 

that include arcs. Please note that Option 5 does not copy an existing dimension style. Instead, 

once all desired values are entered, the arrows, text size, and other elements are newly created and 

applied according to those settings. 



 

 

Option 6 "Dim. along polyline" 

This option is for fully dimensioning an open polyline; it does not work on closed polylines. Please 

note that Option 6 does not copy an existing dimension style. Instead, once all desired values are 

entered, the arrows, text size, and other elements are newly created and applied according to those 

settings. 

 

 

Option 7 "Circle/arc Dimension" 

This convenient option automatically detects radius and diameter dimensions for arcs and circles 

within the selection and applies DIMRAD and DIMDIA accordingly. 

It can automatically dimension not only arcs/circles inside an object outline, but also arcs/circles 

that are separate, as shown in the lower-right image. 



 

 

Option 8 "H-Chain/V-Pair Dimension" 

This option conveniently automates paired dimensions. In mechanical drawings like shafts, the top 

often requires diameter dimensions including the Ø symbol, so it is useful in those cases; it also 

supports applying paired dimensions selectively. 

This is a convenient feature that lets you finalize dimensions in a chosen direction while also 

applying the Ø symbol in one pass. The image below shows an example where only the first sub-

option under Option 8 ("Add Ø to paired dimensions") is enabled while automatically dimensioning 

a shaft. 

The image below shows the result when both sub-options under Option 8 are enabled. After 

selecting all objects, only the right side is dimensioned: Ø is automatically added for diameter 

paired dimensions, and only the right direction receives paired dimensions. 



 

 

Even in drawings like the one below, you can very quickly place paired dimensions (concentric Ø 

dimensions). 

 

 

If you enable only the second sub-option under Option 8 and leave the first "Add diameter 

symbol(Ø)" option unchecked, dimensions will be created without the Ø symbol, as shown below. 



 

 

Even in drawings like the one shown above, paired dimensions (concentric Ø dimensions) can be 

created very quickly. 

 

 

Option 9 "Hor/Ver Baseline Dimensions" 

This option automates DIMBASELINE. A key point is that you should click the first pick point in the 

direction you want as the baseline; that direction is then used as the reference. 



 

 

Option 10 "Smart Dimordinate" 

This option improves the inconvenient workflow of the DIMORDINATE (ordinate dimension) 

command. The Smart Dimordinate option streamlines the process. 

In the example below, click points 1 through 9 in order; the vertical ordinate dimensions at the 

bottom are created. 

 



15-2. DETAIL (Detail view generator) 

 

The DETAIL command extracts a selected area as a detail view in a rectangular (or polygonal) or circular 

shape at the desired scale. You can also generate a detail view directly. Enter DETAIL to open the dialog 

below; it provides four options. 

 

There are three initial settings. First is "Boundary layer setting"—this controls which layer the 

rectangular/circular boundary is created on. Click the broom icon (Copy properties) to set the layer first, 

then proceed with the settings below. 

If you set "Boundary color" to BYLAYER, the boundary uses the layer’s color and linetype. If you set a 

specific color, that color is applied. In the lower-right, "Scale" controls the output scale—setting it to 2 

generates a detail view at twice the size. 

After setting these defaults, you can select one of the four options on the left to generate the detail view. 

 

The first option is "Draw a rectangle, then copy". 

Enter the detail scale as a real number and click Run. Pick pt1 and pt2 to define a rectangular area to extract; 

then click an empty area to place the detail view at the specified scale. 

 

 

The second option is "Select and copy a polyline object". Select a pre-drawn polyline rectangle or polyline 

polygon, then click an empty area; the detail view is generated at the entered scale. 



 

 

The third option is "Draw a circular area, then copy". Click the center of the area (pt1), then the circle 

boundary (pt2), then click an empty area; a circular detail view is generated at the entered scale. 

 

 

The fourth option is "Select and copy a circle object". If the detail area is already indicated by a 

circle, select that circle and then click an empty area; a circular detail view is generated at the 

entered scale. 

 

  



15-3. STOL (Smart Tolerence) 

 

The STOL command is designed to make inserting four types of tolerances easier. 

There are four tolerance options—Symmetric, Deviation, Limits, and Reference—and the fifth option 

removes tolerances. 

 

 

The first option, "Symmetric", is used when upper and lower tolerances are the same (e.g., ±0.1). 

After entering values and clicking Run, select a dimension; tolerance like ±0.1 appears to the right. 

 



 

The second option is "Deviation", used when upper and lower tolerances differ. After setting values, 

click Run and select the dimension; the upper and lower tolerances appear on the right. 

 

 

The third option is "Limits" tolerance. The fields are the same as the second option (Deviation), but 

in this mode two actual values (upper and lower limits) are displayed as the dimension value, as 

shown below. 

 

 



The fourth option is "Reference" tolerance. The input value is not used—click Run and select the 

dimension; a box appears around the dimension value as shown. 

 

 

The fifth option is "None". If a dimension already has tolerance, this removes the tolerance and 

returns it to a normal dimension value. 

In this option, the entered value is not used. Click Run and then select a dimension that has 

tolerance; the tolerance is removed as shown below. 

 

  



15-4. ADDPI (Add diameter symbol before the dimension value) 

 

The ADDPI command adds the diameter symbol (Ø) to the beginning of a dimension value. 

In CADian, the DIMTEXTADDPI command was added, and it can also be used via the alias ADDPI. 

Run ADDPI (or DIMTEXTADDPI) and select a dimension; the diameter symbol (Ø) is added before 

the selected dimension value. 

 

 

 

  



15-5. FLIP (Flip dimension arrows) 

 

The FLIP command reverses the direction of dimension arrows. It was added in CADian; the original 

command name is AIDIMFLIPARROW. You can also use the alias FLIP. 

Run FLIP (or AIDIMFLIPARROW), select the dimension arrow or extension line part, then press Enter; 

only the selected arrows change position. Each run flips the arrow direction. 

 

  



15-6. Q1, Q2, Q3, Q4 (Smart Offset) 

  

Q1–Q4 are Smart Offset commands designed to address common inconveniences of the OFFSET 

command. Q1–Q4 offset by the entered value; choose the appropriate target style and use the 

desired command among Q1–Q4. 

 

The Q1 offsets to layer 0 (outline) regardless of the original layer or linetype, producing a white 

continuous line. Layer 0 is commonly used for outlines. 

 

 

The Q2 command offsets objects to the CENTER layer regardless of the original layer or linetype. As 

a result, the offset is created as a color 1 (red) centerline, since red is commonly used for 

centerlines. If a CENTER layer already exists and is assigned a different color, the command follows 

the existing layer settings. LTSCALE follows the current CELTSCALE setting value 

 

 

The Q3 command offsets objects to the HIDDEN layer regardless of the original layer or linetype. 

As a result, the offset is created as a color 3 (green) hidden line, since green is commonly used for 

hidden lines. If a HIDDEN layer already exists and is assigned a different color, the command 

follows the existing layer settings. LTSCALE follows the current CELTSCALE setting value 



 

 

The Q4 command offsets objects to the PHANTOM layer regardless of the original layer or linetype. 

As a result, the offset is created as a color 6 (magenta) phantom line, since magenta is commonly 

used for phantom lines. If a PHANTOM layer already exists and is assigned a different color, the 

command follows the existing layer settings. LTSCALE follows the current CELTSCALE setting value 

 

 

 

  



15-7. Q11, Q22, Q33, Q44 (Smart Half - Offset) 

 

Q11, Q22, Q33, and Q44 automatically use half (1/2) of the entered value as the offset distance. 

Choose the appropriate target style and use the desired command among Q11, Q22, Q33, and Q44. 

 

Q11 uses half of the entered value as the offset distance and offsets to layer 0 (outline) regardless 

of the original layer or linetype, producing a white continuous line. Layer 0 is commonly used for 

outlines. 

 

The Q22 command uses half of the entered value as the offset distance. Regardless of the original 

layer or linetype, the offset is created on the CENTER layer and displayed as a color 1 (red) 

centerline. If a CENTER layer already exists and is assigned a different color, the command follows 

the existing layer settings. LTSCALE follows the current CELTSCALE setting value. 

 

The Q33 command uses half of the entered value as the offset distance. Regardless of the original 

layer or linetype, the offset is created on the HIDDEN layer and displayed as a color 3 (green) 

hidden line. If a HIDDEN layer already exists and is assigned a different color, the command follows 

the existing layer settings. LTSCALE follows the current CELTSCALE setting value. 



 

The Q44 command uses half of the entered value as the offset distance. Regardless of the original 

layer or linetype, the offset is created on the PHANTOM layer and displayed as a color 6 (magenta) 

phantom line in color 6 (magenta). If a PHANTOM layer already exists and is assigned a different 

color, the command follows the existing layer settings. LTSCALE follows the current CELTSCALE 

setting value. 

 

 

  



15-8. OFC (Offset and cap both ends) 

 

OFC is a useful command that offsets and automatically caps both ends, eliminating the extra step 

of drawing end caps with the LINE command after offsetting. 

Usage is the same as the standard OFFSET command, and the offset object and end caps follow the 

original object’s properties. Run OFC, select the object, pick the side/direction, and it offsets by the 

entered value while capping both ends as shown. 

 

 

  



15-9. OFD (Offset with distance adjustment and end caps) 

 

OFD can offset while extending or shortening the resulting object, and it can also cap both ends. Its 

key advantage is simplifying several additional steps that are normally required after offsetting. 

Run OFD, enter the offset distance (e.g., 20) and the length value (e.g., 50). The offset length is 

adjusted and both ends are capped; this can be applied to mechanical parts such as shafts. 

Yes, it is supported. 

 

 

  



15-10. OFS (Trapezoid Offset) 

 

The OFS command offsets in a trapezoid shape. 

Run OFS, enter the offset spacing (e.g., 20) and the length value (e.g., 50). Lines connect between 

endpoints, allowing trapezoid shapes that expand or contract. 

 

 

 

  



15-11. ML2 (Enhanced Multileader) 

 

ML2 is an enhanced multileader command commonly used in architectural drawings. It reduces the 

cumbersome steps of the existing method. First, you can choose the leader end style—arrow or 

dot. 

Variables that control arrow (dot) size and text size include DIMASZ, DIMTXT, and DIMSCALE. If you 

change DIMSCALE from 1 to 2, the arrow and text that were 5 mm become 10 mm—twice as large. 

The ML2 command automatically enables Ortho mode; choose the desired direction among 

up/down/left/right. 

Run ML2 and choose 1 for a dot start or 2 for an arrow start. Enter the text (top line first), then 

press Enter; the text and leader lines are drawn on screen. 

Before running it, set the current layer to the layer where you want the multileader to be drawn, 

then use ML2. 

 

 

  



15-12. TAG (Insert part numbers) 

 

The TAG command is intended to insert part numbers sequentially and automatically. 

Run TAG. Enter the circle diameter (e.g., 10), then enter the starting number (e.g., 1). Part numbers 

are assigned starting from 1. 

Now just repeat picking start point and end point on screen. Press ESC to finish. Arrow size can be 

adjusted using DIMASZ/DIMSCALE, and number size is determined proportionally to the circle 

diameter. 

Before running it, set the current layer to the layer where you want the part numbers to be placed, 

then run the TAG command. 

 

 

  



15-13. WW (Trim across) 

 

WW makes TRIM easier. Because TRIM is frequently used, WW is designed to be comfortable to 

type with the left hand. It trims immediately, and it is especially effective when trimming across 

multiple objects at once. 

Run WW and click just two points to cross the objects to trim; TRIM is performed automatically. 

 

  



15-14. WWW (Fence Trim) 

 

WWW differs from WW in that you define a fence with multiple points rather than only two. Run 

WWW, click several points, then press Enter; objects crossed by the fence line are trimmed. 

 

  



15-15. MI2 (Quick Mirror) 

 

Mi2 streamlines the standard MIRROR workflow when keeping the original object. The mirror line 

can be either a line or a polyline, and the mirror operation completes in just three clicks. 

Run Mi2, select objects to mirror using a two-point CROSSING selection, then select the mirror line 

or polyline; the mirror is applied immediately. Slanted objects are supported. 

 

  



15-16. DMI (Double Mirror) 

 

DMi is short for Double Mirror. It lets you perform two mirror operations in a single workflow when 

you have two mirror lines and objects to mirror. 

Run DMi, define the selection area with two points, select objects fully inside, then specify the 

mirror lines; the double mirror completes in four clicks. Mirror lines can be lines or polylines. 

 

  



15-17. DMIR (Double Mirror within a rectangle) 

 

DMiR is similar to DMi, but it applies double-mirror to objects inside a rectangle. Unlike DMi, you 

only need to specify the first corner and the diagonal corner of the rectangle to complete the 

command. 

This makes it a bit more convenient. 

Run DMiR and click the two diagonal corner points of the rectangle in order; objects inside the 

rectangle are double-mirrored as shown. 

 

  



15-18. XYL (Write XY coordinates) 

 

XYL writes XY coordinates. Arrow and text sizes can be adjusted using the dimension-related 

variables DIMASZ, DIMTXT, and DIMSCALE. 

Run XYL and first enter the number of decimal places (0 or an integer), then press Enter. Pick the 

leader start, leader end, and the horizontal end point (direction); XY coordinates are written on the 

leader. 

 

 

  



15-19. ML2 (Enhanced Multileader) 

 

The CL2 command automatically draws centerlines for circles. You can draw centerlines for one or 

multiple circles at once, and the density/spacing is adjusted automatically. Even if other objects are 

mixed in, only circles are selected automatically. 

Run CL2. If the _ADDONUTIL_CENTER layer does not exist, it is created first. Then select the circle 

area with a WINDOW so the circles are fully inside the selection. 

It automatically draws centerlines for all circles within the selected area. If multiple circles share the 

same center, the centerlines are drawn based on the largest circle. 

 

 

  



15-20. RCT (Draw rectangle centerlines) 

 

The RCT command automatically draws centerlines for a rectangle. 

Run RCT. If the _ADDONUTIL_CENTER layer does not exist, it is created first. Then select the 

rectangle(s) (including those drawn as polylines). 

For rectangles, partial selection with a CROSSING window is allowed; if the rectangle is made of 

regular line objects, it behaves like a WINDOW selection. Even if circles, arcs, dimensions, etc. are 

inside the selection area, they are excluded—so you can select freely. 

 

 

  



15-21. CLM (Draw a horizontal centerline) 

 

The CLM command draws a centerline between two selected lines. 

Run CLM and pick two lines. If the _ADDONUTIL_CENTER layer does not exist, it is created first. This 

works for line–line or polyline–polyline; avoid mixing a line and a polyline. 

 

 

  



15-22. M2 (One-click move) 

 

The M2 command lets you move an object with a single click. 

Run M2, select one object (line, circle, arc, rectangle, block, etc.), then click the target point to move 

it. The main goal is fast single-object moving in a chosen direction with minimal clicks. 

This is the purpose. 

 

  



15-23. CP2 (One-click copy) 

 

The CP2 command lets you copy an object with a single click. 

Run CP2, select one object (line, circle, arc, rectangle, block, etc.), then click the target point to 

copy. The main goal is fast single-object copying in a chosen direction with minimal clicks. 

 

  



15-24. STC (Quick stretch 

 

STC reduces the standard STRETCH workflow (often six clicks) to a simpler flow. If Ortho and 

Dynamic Input (F12) are enabled, you can set only the direction and type the stretch distance to 

stretch by that value in that direction. 

 

  



15-25. ST2 (One-click stretch) 

 

ST2 lets you select a rectangle-like object at once and stretch it immediately. Select the desired part 

and click the point you want to extend to; it stretches by that amount and Ortho mode is enabled. 

If F12 (Dynamic Input) is enabled, set the direction to the right and enter the stretch distance; it will 

stretch to the right by exactly the entered value. 

 

 

  



16. The End 

 

 


